WDM Streaming Capture Device changes filter moniker

Do you have questions about Desktop Video, Converters, Routers and Monitoring?
  • Author
  • Message
Offline

Albert Cobacha

  • Posts: 6
  • Joined: Wed Feb 03, 2016 2:08 pm

WDM Streaming Capture Device changes filter moniker

PostWed Mar 15, 2017 3:22 pm

We have an interesting case reported here where upon adding Blackmagic WDM Capture device on XSplit Broadcaster works fine, but according to user, after restarting XSplit Broadcaster, it shows "Camera is not available".

Upon further investigation, it turns out that the device changes it's filter moniker, several minutes after use. We've observed this behavior also with GraphEdit and w/o XSplit running, so this may affect other software using the WDM device.

It seems the issue can be triggered also by unplugging and replugging the USB device. Another way to trigger is by disabling the WDM Streaming device in Device Manager and enabling it again. After a few minutes, restart GraphEdit and see that "Blackmagic WDM Capture" became "Blackmagic WDM Capture (2)" and the moniker @device:pnp:\\?\decklink#avstream#6&21df0642&0&0000#{65e8773d-8f56-11d0-a3b9-00a0c9223196}\decklinkcapture1 became @device:pnp:\\?\decklink#avstream#6&21df0642&0&0000#{65e8773d-8f56-11d0-a3b9-00a0c9223196}\decklinkcapture2.

Our suspicion is either of the following:
- loose connection in USB port
- OS issue
- driver issue

For now, we've advised the user to update Blackmagic driver and install all OS updates and retry; but we'd like to know if you have other ideas on why this might happen and how to fix.

OS: Win10 Pro x64
BMD Driver: v10.5.4
Copy of msinfo32 dump.

Return to Post Production

Who is online

Users browsing this forum: No registered users and 17 guests