MJPEG AVI grabs show no audio in Premiere

Do you have questions about Desktop Video, Converters, Routers and Monitoring?
  • Author
  • Message
Offline
User avatar

Mike Boas

  • Posts: 17
  • Joined: Thu May 25, 2017 3:45 pm
  • Location: Rochester, NY

MJPEG AVI grabs show no audio in Premiere

PostThu Feb 14, 2019 9:51 pm

I'm running Windows 10 with Intensity Pro card for grabbing SD video input. My ultimate goal is to grab customers' home movies, so MJPEG compression will be preferable for the hours and hours of content.

With Media Express, I'm able to capture clips as motion-jpeg AVI files. There's no input choice for SD 29.97p, so I've had to choose NTSC 720x486i59.94.

Premiere doesn't show audio for the clips. I know it's there, because I can hear it when I test the AVI in Windows Media Player.

I've also grabbed as 8bit YUV AVI, and those files play the audio fine in Premiere. The file size is cumbersome, though and I'd like to get MJPEG working.

Any suggestions?
Offline
User avatar

Mike Boas

  • Posts: 17
  • Joined: Thu May 25, 2017 3:45 pm
  • Location: Rochester, NY

Re: MJPEG AVI grabs show no audio in Premiere

PostFri Feb 15, 2019 5:25 pm

Did some research on the internet, but didn't find an answer yet. Just people with similar problems.

I downloaded a program called MediaInfo to tell me what the properties are of the files that work and don't work.

First, here's the MJPEG that Premiere sees no audio for.
Image


Second, here's an uncompressed 8 bit YUV AVI grab that Premiere reads the audio just fine. As far as I can tell, the audio specs are the same with each.

Image
Offline
User avatar

Mike Boas

  • Posts: 17
  • Joined: Thu May 25, 2017 3:45 pm
  • Location: Rochester, NY

Re: MJPEG AVI grabs show no audio in Premiere

PostFri Feb 15, 2019 5:47 pm

I ran the files through GSPOT and saw that they each have an audio codec error, 0xfffe (Extensible wave format) not installed.

Weird that they both have error, while only the MJPEG doesn't show audio in Premiere.

Is it worth trying to download and install 0xfffe (Extensible wave format) on my PC? I've never heard of it and don't know where to obtain it.

Image
Offline

Greg_E

  • Posts: 183
  • Joined: Wed Jan 09, 2019 2:07 pm
  • Location: Central NY
  • Real Name: Greg Endler

Re: MJPEG AVI grabs show no audio in Premiere

PostFri Feb 15, 2019 6:36 pm

About the only thing I can help with is the video frame rate... NTSC only has interlaced as the standard, so the software is setting you up to produce standard video files from the SD (NTSC) sources.

Is that wave file the same as broadcast wave?

You could convert the files with HDcinematic's Convert V6, just requires more time. Or another option would be to try them in the free version of Davinci Resolve.
Offline
User avatar

Mike Boas

  • Posts: 17
  • Joined: Thu May 25, 2017 3:45 pm
  • Location: Rochester, NY

Re: MJPEG AVI grabs show no audio in Premiere

PostMon Feb 18, 2019 7:09 pm

I tried converting using Adobe Media Encoder. Didn't solve audio problem.

Not keen on trying HDcinematic Convert V6. Don't know anything about it, so maybe as a last resort.

Downloading free Resolve now.
Offline
User avatar

Mike Boas

  • Posts: 17
  • Joined: Thu May 25, 2017 3:45 pm
  • Location: Rochester, NY

Re: MJPEG AVI grabs show no audio in Premiere

PostMon Feb 18, 2019 9:10 pm

Okay, the MJPEG files play great in Resolve! Awesome!

Now I need to figure out how to decomb the captured interlaced video so it will look better on PC or the web. I've done this before in Quicktime Pro and in After Effects. Is there a way to do this right in Resolve so I don't have to render twice?
Offline
User avatar

Mike Boas

  • Posts: 17
  • Joined: Thu May 25, 2017 3:45 pm
  • Location: Rochester, NY

Re: MJPEG AVI grabs show no audio in Premiere

PostMon Feb 18, 2019 9:23 pm

Found it. In the media tab, click on the clip, choose clip attributes, and check enable deinterlace.

Looks like it would work. Unfortunately, it's a paid feature and I got the prompt to pay $299 to remove the watermark.
Offline

Uli Plank

  • Posts: 4491
  • Joined: Fri Feb 08, 2013 2:48 am

Re: MJPEG AVI grabs show no audio in Premiere

PostTue Feb 19, 2019 1:37 am

There is free software for deinterlacing, like this one for Avisynth: https://www.guthspot.se/video/AVSPorts/ ... nterlacer/
Resolve Studio and Fusion Studio
iMac 2017 Radeon Pro 580 8 GB VRAM and 32 GB RAM
Offline
User avatar

Mike Boas

  • Posts: 17
  • Joined: Thu May 25, 2017 3:45 pm
  • Location: Rochester, NY

Re: MJPEG AVI grabs show no audio in Premiere

PostTue Feb 19, 2019 7:24 pm

Thanks, but I'm afraid AVISynth is over my head. Looks like you have to write code every time you want to open a file.

I'm looking for a straightforward pipeline, a solution that I can set up and hand off to a co-worker or intern.
Offline

Walter Sonius

  • Posts: 21
  • Joined: Wed May 03, 2017 9:53 am

Re: MJPEG AVI grabs show no audio in Premiere

PostMon Mar 04, 2019 4:31 pm

Had this similar issue discussed a year ago 03/08/2018 with Blackmagic support in a 10+ mailing thread. Although my intention was to capture with Media Express in Linux/OSX and use the same mjpeg avi with both Windows and Mac versions of editing software.

viewtopic.php?f=3&t=68901

Their concluding answer was that Desktop video 10.9.11 mjpeg captures works (both audio & video) for them with premiere cc 2017 and 2018 on Windows 10. Likewise Mediaexpress playback, VLC playback or Davinci Resolve playback was fine. So the problem must have been somewhere @Adobe or @Apple... or before 10.9.11 Desktop video driver.

Didn't ask if they also tested osx and linux capturing and try to edit them on premiere cc on windows. Haven't tested it anymore after digging up yet another and another Desktop Video bug...

Return to Post Production

Who is online

Users browsing this forum: Google [Bot] and 3 guests