Page 1 of 1

Intensity 4K on new X570 mobo not recognised

PostPosted: Wed Jul 31, 2019 3:22 pm
by Ron Exalto
Hi there,

Doing a new computer build with an X570 mobo and a 3700X CPU, GTX980 GPU, running W10Pro, clean install on SSD.

While installing drivers and software, BMD Desktop Video installs, but states it can't find any appropriate hardware. In Device manager I can see that no drivers are installed for that card, since it are the only "unknown PCI device" entries left.

The strange thing is that the card can work in this computer if I put in the C drive from my old computer. Alas, that doesn't give me Raid without reinstalling Windows, so there's a catch 22.

So knowing that it can work, it must be something with the board/driver combination with a fresh install. Any thoughts?

Re: Intensity 4K on new X570 mobo not recognised

PostPosted: Fri Aug 09, 2019 3:31 pm
by Ron Exalto
Okay, so far it seems to be that the videosetup program can’t instal the drivers on a Windows10 computer when in UEFI mode.
Why is this?
What is the solution?

Re: Intensity 4K on new X570 mobo not recognised

PostPosted: Sat Aug 10, 2019 11:36 am
by Cooper
New board PCIe gen 4 possible backwards incompatibility issue. Not that familiar with the new ryzen boards, but have you tried on each PCIe slots, mainly cpu vs x570 chipset controlled slots. Could try changing the PCIe slot(s) to gen 3 in bios or even to gen 2 to see if it helps. Hmm load legacy drivers before uefi in boot options, disable fast boot, try without security boot. I have one usb expansion card that has hard time loading drivers for the usb controllers in windows, rarely it managed to load the driver for 1 of the 4 controllers, driver compatibility issue with amd. Then there are the 10G network cards they included with the mb... not working at all.

Re: Intensity 4K on new X570 mobo not recognised

PostPosted: Sun Aug 11, 2019 12:05 pm
by Ron Exalto
Thanks Jack for your reply,

The PCIe gen 4 is not the problem, since the card works when in BIOS/Legacy mode when I tested with my old SSD from my last computer. So also slotplacing is not the problem.
The new fresh install in EUFI mode, needed for RAID, is the problem.

I've checked your tip to try loading legacy drivers before UEFI, but that's not an available option.
I can choose (by using CSM) to not install drivers, legacy only, UEFI only.
When choosing legacy only the system doesn't boot into windows because it can't find a bootable drive.
That drive is the Windows bootloader under EUFI...

I just don't understand why the videosetup program doesn't see the Intensity card. It's beyond me what UEFI has to do with this as we're in W10 at that time already.
Windows detects an unknown PCIe device(s). I click on them and point to search/use drivers, but videosetup is only an exe file. No drivers to point to.
This shouldn't be so hard to solve for BMD, I suppose?

Re: Intensity 4K on new X570 mobo not recognised

PostPosted: Mon Aug 12, 2019 12:58 pm
by Cooper
What is this raid you keep mentioning, requiring windows reinstall and requiring uefi? What motherboard is this? Have you tested system/ram stability?

Re: Intensity 4K on new X570 mobo not recognised

PostPosted: Tue Aug 13, 2019 10:39 am
by Ron Exalto
Hi Jari (sorry for typing Jack in my prior reply)

Raid is combining 2 or more harddiscs or SSD's together as one large and/or fast drive.
UEFI is a newer format for BIOS since a few years.
My mobo is a new ASRock Phantom Gaming X model with the new X570 chipset for AMD Ryzen 3000 series processors. I'm currently running a 3700X cpu in it, awaiting the release of the 3950X in september.

If I don't use the UEFI standard, I'll get "normal" BIOS where I only can use SATA drives in legacy mode.
Which can be enough if you don't use raid or go the software raid route in Windows (slooooooow)
But in UEFI you get the RAID options from the motherboard to configure both NVME M2 raid and SATA RAID.
My C: drive (SSD) is the only one configured as a legacy SATA drive, mostly to prevent issues as the one still persisting with this BMD Intensity card.

So far I've found the system to perform rock solid, fast and very smooth in both Premiere Pro as in DaVinci Resolve editing.
The 3 PCIe slots are filled with an GTX980 graphics card, the Intensity 4K and a Thunderbold Add In Card. All is working properly, except for the Intensity 4K which I can't explain since it does work with the motherboard in BIOS mode. Just not in UEFI.
Hope this clarifies your question

Re: Intensity 4K on new X570 mobo not recognised

PostPosted: Tue Aug 13, 2019 4:38 pm
by Cooper
Have you tried disabling secure boot. Also the motherboard does have legacy raid... if you really need the motherboard raid, I would not trust any data on those controllers.

Re: Intensity 4K on new X570 mobo not recognised

PostPosted: Tue Aug 13, 2019 7:35 pm
by Ron Exalto
Secure boot is disabled.
I really don’t see why videosetup is so persistent to not install under UEFI. It is the newer BIOS standard after all. Everything else installs properly.
Can the motherboard raid be trusted? Only time will tell. But all files are backed-up anyhow, so I’m not too worried about that.