BMD Devices not recognised in Mac OSX High Sierra

Questions about ATEM Switchers, Camera Converter and everything live!
  • Author
  • Message

Daniel Müller

  • Posts: 4
  • Joined: Mon Mar 03, 2014 4:41 pm

Re: BMD Devices not recognised in Mac OSX High Sierra

PostFri Apr 20, 2018 10:49 am


i made a new clean install and that helped.


User avatar

Scott Smith

  • Posts: 954
  • Joined: Sat Apr 13, 2013 12:51 pm

Re: BMD Devices not recognised in Mac OSX High Sierra

PostFri Apr 20, 2018 12:55 pm

Tangentially related issue is that High Sierra has disabled a few protocols by default - one of which is telnet. I frequently use telnet with Videohub routing. It can also be used with Hyperdeck machine control. It is often a part of the blackmagic to computer interfacing, or a protocol used by third party software stuff. I don't know if any of the stuff under the hood of Blackmagic software actually employs telnet in the background of the software, but it wouldn't surprise me. So, you may have to enable Telnet.

In terminal, type:
brew install telnet telnetd

You may have to run this one twice, as the first effort may say that Homebrew is not installed. If so, confirm installation of Homebrew, and run it again.

If you want ftp stuff, it has also been disabled....
brew install tnftp tnftpd
Scott R Smith
BMD Stuff I use: ATEM 2-M/E, 4 x ATEM PS 4K, Broadcast Videohub, 6 Hyperdeck Pros, 4 Hyperdeck Shuttles, Multidock, Smartscope Duo, Smartview, Intensity Extreme, Decklink Studio, and lots of Miniconverters and Open Gear Converters.


  • Posts: 2
  • Joined: Thu Mar 29, 2018 9:58 pm
  • Real Name: Terry Lewis

Re: BMD Devices not recognised in Mac OSX High Sierra

PostSat May 05, 2018 7:56 pm

Even though disabling SIP does work it also causes problems. After disabling my iMac restarts on it's own several times a day.

Could BlackMagic address this in a software or firmware update?

Tony Rivera

Blackmagic Design

  • Posts: 3364
  • Joined: Mon Aug 12, 2013 4:52 pm
  • Real Name: Tony Rivera

Re: BMD Devices not recognised in Mac OSX High Sierra

PostMon May 07, 2018 11:46 pm

to quote myself from just a bit ago.

Tony Rivera wrote:Xtreemtec (Daniel) was nice enough to put together a list of information for users. You can find information on this topic here.

Follow us on Instagram:


  • Posts: 1
  • Joined: Wed Jun 20, 2018 9:55 pm
  • Real Name: Marc Coyles

Re: BMD Devices not recognised in Mac OSX High Sierra

PostWed Jun 20, 2018 10:00 pm

Fix for Intensity Shuttle USB3 on MacOS HighSierra with mid-2014 MacBook Pro: NO visits to Sys Prefs > Security & Privacy required. No root accounts required. No disabling critical system sanity routines.

This works if you haven’t updated Desktop Video in eons, and decide to go straight to 10.11 (which won’t work).

  • Use AppCleaner to remove all traces of Black Magic from system.
  • UNPLUG all devices.
  • Download Desktop Video 10.7 and install.
  • Restart.
  • Plug in. You should be prompted to update firmware. Do so.
  • Unplug, replug as prompted.
  • Run Desktop video. Confirm device is detected.
  • NOW install Desktop Video 10.11
  • Restart when prompted.
  • Tada - works.

Going from ancient Desktop Video (10.5) directly to 10.11 doesn't update the device's firmware, thus 10.11 doesn't recognise it nor provide a firmware updater for it.


  • Posts: 1
  • Joined: Sat Jul 14, 2018 1:16 pm
  • Real Name: Tom Tapp

Re: BMD Devices not recognised in Mac OSX High Sierra

PostSat Jul 14, 2018 1:22 pm

I also had this problem with the intensity shuttle USB 3.0 and Mac High Sierra. I tried all of the approaches mentioned. Here is what finally worked for me: I downloaded the Desktop Video 10.9.7 version. (had tried 10.11 and 10.10). When I went through the installation for 10.9.7, a message came up that the shuttle itself needed to be updated. I had not received that message through the numerous times I tried to install 10.10 and 10.11. Once the update was completed (a minute or two) then, at least with 10.9.7, everything worked and all my software now recognized the shuttle. Hope this may help someone else


  • Posts: 1
  • Joined: Sat Sep 29, 2018 7:39 pm
  • Real Name: Sue Quesenberry

Re: BMD Devices not recognised in Mac OSX High Sierra

PostSat Sep 29, 2018 7:53 pm

I have the UltraStudio Mini Recorder and it won't be recognized on macOS High Sierra 10.13.6 on a MBP Retina 15-inch Mid 2014. I've tried the many fixes here (system integrity disabled, allow all apps to run) and installed and uninstalled practically every version. I haven't seen it at any point give me a prompt to 'allow' black magic design. Obviously an expensive device that I don't want to throw in the junk pile and have to switch to cables and adapters to try to get video from Canon HV20 DV to MBP (which some people say works and others say doesn't work). I originally bought the BM device when my old laptop stopped working and I lost the mini firewire connection on it to go directly to the camera. Frustrated, out of ideas, and don't want to have to spend more when I already spent a lot for this device. How do I make it work? Not really excited about going back to an old OS and losing the state of all my other apps either. HELP!!!

Drew Lahat

  • Posts: 25
  • Joined: Tue Jun 16, 2015 2:13 am

Re: BMD Devices not recognised in Mac OSX High Sierra

PostWed Nov 14, 2018 8:41 pm

Looking into buying an old(er) used HD-SDI Decklink card for my home-edit High Sierra Mac. Are those issues still happening, or these are rare exceptions nowadays?
Are they linked to specific or older hardware? (Doesn't seem so.)

You'd think that by now the current drivers would be up-to-date and properly code-signed with Apple...

Return to Live Production

Who is online

Users browsing this forum: No registered users and 8 guests