HyperDeck Studio Pro 2 - Won't Record Some Sources

Questions about ATEM Switchers, Camera Converter and everything live!
  • Author
  • Message

Nick Marques

  • Posts: 4
  • Joined: Wed Feb 19, 2014 8:43 pm

HyperDeck Studio Pro 2 - Won't Record Some Sources

PostMon Nov 27, 2017 4:24 pm


I am sharing this problem with the community to see if anyone else has ran into this, and to try to get more brains on the situation. I have Case #EFW-169-15549 open with Tech Support. For background, I am a Pro AV Integrator, and have used the HyperDeck Studio Pro 1 in the same setup with no problems.

The Gear
- Crestron DM-MD8X8 with DigitalMedia (DM, Supports HDBaseT) and 4K HDMI input cards, HDMI Output Cards (Non-Scaling)
- Vaddio RoboSHOT 30 HDBT PTZ Camera
- HyperDeck Studio Pro 2 w/ Samsung 850 PRO 250GB SSD
- The HyperDeck is connected to a Crestron HDMI Output. Camera and Laptops connect to Crestron inputs.

The problem:
- When I switch sources to the HyperDeck, I see preview and audio meters on the LCD on HDMI+HDMI.
- The LCD shows the resolution.
- I formatted the SSD HFS+, and chose ProRes codec.
- When I press REC, the disk LED glows RED, and the button is RED, but timer does not run. The transport icon on the LCD sometimes switches to a red circle icon but sometimes it stays a black square.
- When I press stop and read the SSD, the recorded files have no video, but are 7KB in filesize.

When I called BMD last week, they originally thought from the symptoms that the unit was bad immediately. No questions asked. The unit's LCD also randomly faded out to completely black for no reason.

I got the replacement in but this one is doing almost the same thing, but oddly, it behaves differently. The replacement unit doesn't even show it recording... I press REC and the button flashes RED and then goes back WHITE. Timer still does not run.

So, when it came time to troubleshoot, here's what I did:

- The ONLY thing I can get to record is a laptop plugged directly into the HyperDeck.
- The laptop or camera through the Crestron DM-MD8X8 switcher does not work.
- The camera directly into the HyperDeck does not work.
- I have tried 720p59.94, 720p60, and 1080p60 resolutions in both RGB and YBR color spaces.
- I do get preview on the HyperDeck, but sometimes (mainly with the camera) it is scrunched up and doesn't fill the preview area.
- Codec selection does not matter.
- HFS+ vs exFAT does not matter.
- It does not matter if there is audio embedded or not, or if I select HDMI+XLR.
- I have tried with HDCP on and off from the Crestron switcher and it does not matter.
- I have called Crestron about the same issue and they don't have any ideas either. The HyperDeck doesn't like something about the Crestron or Vaddio HDMI output and I have no way of identifying what it is. Crestron is 100% standards compliant and a top pro-level switcher.
- I have confirmed that the Crestron switcher picks up an EDID from the BMD.
- Both the laptop and camera work 100% plugged into any computer monitor, a Digital Projection Laser Insight 4K 3-chip DLP projector (it's a $90,000 unit), or a 4K Samsung TV.
- Considering the Vaddio camera doesn't work plugged directly into the HyperDeck, I can't really blame the Crestron switcher here.

BMD seems to think "everything else" is the problem, or there's a compatibility issue. But, in my defense, where is the problem? There aren't any detailed specifications regarding the HDMI input of the HyperDeck and on paper, this should all work plug and play with no problems. Heck, I've used the HyperDeck Studio Pro 1 with the same switchers with no problems.

My next step is to put a HDMI - SDI micro converter in between the Crestron switcher and HyperDeck, but that's an expense I didn't factor in. I've asked if BMD would comp me one, but that's to be determined.

If anyone has any ideas, I'm all ears. Thanks!

Return to Live Production

Who is online

Users browsing this forum: Asgeir Hustad, Google [Bot] and 11 guests