Web Presenter, Audio consistently out of sync

Questions about ATEM Switchers, Camera Converter and everything live!
  • Author
  • Message
Offline

xrkund

  • Posts: 4
  • Joined: Mon Feb 11, 2019 6:47 pm
  • Real Name: Cody Brown

Web Presenter, Audio consistently out of sync

PostMon Feb 11, 2019 6:59 pm

I'm in charge of designing and installing AV systems for my organization across multiple states. The main purpose for the installations is web conferencing via Zoom. I'm using the BMD Cleanswitch for seamless camera switching (integrated via Extron Control on an iPad), and outputting SDI to the BMD Web Presenter to get video into the PC.

For Audio, I've got two wireless mics (handheld/lav combo) and 16 wireless boundary mics that communicate over Dante into a hardware audio DSP that connects to the PC via USB.

My issue is that the video is consistently nearly a second behind the audio. I initially attributed this to the fact that audio and video are coming into the PC over two different devices, so I routed all the microphones through an analog out of the DSP to go into the XLR input of the Web Presenter. Unfortunately, there was no change in the delay. The video is still nearly a second behind the audio. I've maxed out the delay processing on the DSP, which is only 400ms, but it still has a ways to go before its even close.

The Web Presenter was just purchased and has the latest firmware. I'm considering using the Analog Audio to SDI Mini Converter to embed the audio onto the SDI signal prior to input into the Web Presenter, but I'm hesitant if its not going to correct the problem.

Any ideas?
Offline

roger.suski

  • Posts: 65
  • Joined: Thu Jul 02, 2015 7:03 pm

Re: Web Presenter, Audio consistently out of sync

PostMon Feb 11, 2019 8:59 pm

Yeah, lots of variables here.

What are your cameras, and how do they arrive at the CleanSwitch? (what is the baseline latency?)

Your switcher will add 1 frame of delay to be clean. The amount of latency depends on the frame rate of the video.

Did you double/triple check that the DSP was applying the delay to the proper output?

My thought was in alignment with your next step.
Offline

xrkund

  • Posts: 4
  • Joined: Mon Feb 11, 2019 6:47 pm
  • Real Name: Cody Brown

Re: Web Presenter, Audio consistently out of sync

PostMon Feb 11, 2019 10:34 pm

The cameras are PTZOptics 12x SDI cameras running at 1080p30. They're plugged directly into the BMD CleanSwitch, and the BMD CleanSwitch directly into the BMD Web Presenter. I did anticipate that there would be a maximum of 1 frame of latency to resync the inputs for seamless switching.

I did double/triple check the latency on the output of the DSP, and it does seem to help, but they're so far out of sync that the measly 400ms I'm able to apply only gets me about halfway there, and that should be more than enough for the latency introduced on the BMD CleanSwitch.

I'd just rather not have to shell out another $300 on a hunch if embedding the audio onto the SDI signal isn't going to help.
Offline
User avatar

Thomas Seewald

  • Posts: 1149
  • Joined: Fri Aug 24, 2012 11:57 am

Re: Web Presenter, Audio consistently out of sync

PostTue Feb 12, 2019 9:01 am

The WebPresenter is designed to keep audio and video in sync. One second Video delay is huge and no cheep device would have a video memory for 25 or 30 frames without any need.... Normally you may have up to 4 or 5 frames audio before video caused in the total signal chain including cameras.

When I‘m right, the WebPresenter has a SDI out. So what appears, when you control video and embedded audio at this output, so before processing inside the PC ?

When you have nearly the same delay on both audio signal paths - via WebPresenter and also directly to PC, it seems for me that this is a PC issue...

Maybe check your software configuration and also try for testing other software (e.g. OBS)
thos-berlin - Thomas S e e w a l d
Offline

Nerds LTD

  • Posts: 17
  • Joined: Tue Jun 05, 2018 11:49 pm
  • Real Name: Jason Bache

Re: Web Presenter, Audio consistently out of sync

PostThu Feb 14, 2019 2:42 am

xrkund wrote:I'm in charge of designing and installing AV systems for my organization across multiple states. The main purpose for the installations is web conferencing via Zoom. I'm using the BMD Cleanswitch for seamless camera switching (integrated via Extron Control on an iPad), and outputting SDI to the BMD Web Presenter to get video into the PC.

For Audio, I've got two wireless mics (handheld/lav combo) and 16 wireless boundary mics that communicate over Dante into a hardware audio DSP that connects to the PC via USB.

My issue is that the video is consistently nearly a second behind the audio. I initially attributed this to the fact that audio and video are coming into the PC over two different devices, so I routed all the microphones through an analog out of the DSP to go into the XLR input of the Web Presenter. Unfortunately, there was no change in the delay. The video is still nearly a second behind the audio. I've maxed out the delay processing on the DSP, which is only 400ms, but it still has a ways to go before its even close.

The Web Presenter was just purchased and has the latest firmware. I'm considering using the Analog Audio to SDI Mini Converter to embed the audio onto the SDI signal prior to input into the Web Presenter, but I'm hesitant if its not going to correct the problem.

Any ideas?

I’ve had the same issue and gave up on using the web presenter itself for sync. I explored a genlock approach but decided it was prohibitively expensive.

I ended up fixing it two ways depending on the rig I was running. Since you’re not embedding any audio on the web presenter cameras, turn all rca/xlr audio off. Next, either buy an embedding mini converter to embed audio you’ve verified with headphones to be in sync with the video into hdmi or sdi in line

Or

Use a webcam hijack intermediate app on the computer to adjust your delay. I’ve also had luck with a dedicated audio delay but I find that’s annoyingly difficult to calibrate especially if the web conference interface runs it’s own delays depending on CPU usage.
https://NerdsLimited.com
Legal Flyer® for iOS: Property Releases For Drone Pilots http://legalflyer.com/
Offline
User avatar

Thomas Seewald

  • Posts: 1149
  • Joined: Fri Aug 24, 2012 11:57 am

Re: Web Presenter, Audio consistently out of sync

PostThu Feb 14, 2019 2:37 pm

Genlock don‘t fix this issue. Genlock ist for synchronizing the timing of connected devices, e.g. that all cameras start the outputted frame exactly at the same time. So mixing videosources could be possible without any frame synchonizer and the vision mixers works with nearly zero latency. A second effect is that genlock-able cameras are made for live use and are designed with less latency. Non genlocked cameras are made for recording and so a lot of cameras have delay at output caused in video processing.

So in the complete signal chain, you may have near zero delay with genlock and mybe 5 frames without genlock. Both values are far away from a second delay (25-30 frames).

So again, I’m pretty sure, that the delay comes from computer. Maybe you can adjust audio/video timing and delay inside the software. Did you tested the SDIout at WebPresenter ? What about test with oter software ?

One second can‘t be caused in VideoHub cleanswitch.
thos-berlin - Thomas S e e w a l d
Offline

xrkund

  • Posts: 4
  • Joined: Mon Feb 11, 2019 6:47 pm
  • Real Name: Cody Brown

Re: Web Presenter, Audio consistently out of sync

PostThu Feb 14, 2019 6:34 pm

This installation is in another state, and I've asked my guys on site to do some additional testing for me. I'll keep you updated with what I find out.
Offline

Nerds LTD

  • Posts: 17
  • Joined: Tue Jun 05, 2018 11:49 pm
  • Real Name: Jason Bache

Re: Web Presenter, Audio consistently out of sync

PostFri Feb 15, 2019 2:14 am

Which app are you using for the teleconference?
https://NerdsLimited.com
Legal Flyer® for iOS: Property Releases For Drone Pilots http://legalflyer.com/
Offline

xrkund

  • Posts: 4
  • Joined: Mon Feb 11, 2019 6:47 pm
  • Real Name: Cody Brown

Re: Web Presenter, Audio consistently out of sync

PostFri Feb 15, 2019 4:46 pm

We primarily use Zoom, but also use Skype for Business, WebEx and Adobe Connect depending on the meeting.

I've been sick the past few days, so hopefully I'll be able to make some headway on this very soon.
Offline

Nerds LTD

  • Posts: 17
  • Joined: Tue Jun 05, 2018 11:49 pm
  • Real Name: Jason Bache

Re: Web Presenter, Audio consistently out of sync

PostSat Feb 16, 2019 7:34 am

Have you tried different computers? I’ve had decent results with dedicated, “conference only” machines.
https://NerdsLimited.com
Legal Flyer® for iOS: Property Releases For Drone Pilots http://legalflyer.com/

Return to Live Production

Who is online

Users browsing this forum: ljjlong and 34 guests