ATEM Software doesn't recognize new clips on hyperdeck

Questions about ATEM Switchers, Camera Converter and everything live!
  • Author
  • Message
Offline

Paulo Fernandes

  • Posts: 3
  • Joined: Fri May 19, 2017 12:22 pm

ATEM Software doesn't recognize new clips on hyperdeck

PostFri May 19, 2017 12:25 pm

I'm FTP transferring clips into my hyperdeck's SD card.

From Filezilla I can see the new clips inside the SD card, but Atem Software control only shows new clips on the "Media Players" / HyperDecks submenu if I remove and reinsert the SD card on the hyperdeck.

Is this supposed to happen?

Thanks
Offline
User avatar

Xtreemtec

  • Posts: 2323
  • Joined: Wed Jan 02, 2013 11:48 am
  • Location: The Netherlands

Re: ATEM Software doesn't recognize new clips on hyperdeck

PostSat May 20, 2017 5:08 pm

I guess they should refresh the playlist.. But this does not seem to happen if i read this story.
Maybe the interval for refresh is too high Or maybe they should add a Refresh playlist button..
Daniel Wittenaar .:: Xtreemtec Media Productions ::. -= www.xtreemtec.nl =-
4K OBV, ATEM TVS HD, 1M/E 4K, 2M/E Broadcast Studio 4K, Hyperdeck Studio Mini, SONY FS7 4K, Ursa Broadcast 4K
Offline

Paulo Fernandes

  • Posts: 3
  • Joined: Fri May 19, 2017 12:22 pm

Re: ATEM Software doesn't recognize new clips on hyperdeck

PostThu May 25, 2017 12:17 pm

Yeah, that's really annoying, and I'm afraid of damaging my SD card in the process
Offline

Paulo Fernandes

  • Posts: 3
  • Joined: Fri May 19, 2017 12:22 pm

Re: ATEM Software doesn't recognize new clips on hyperdeck

PostTue Sep 12, 2017 1:25 pm

Any update on this issue?
Offline
User avatar

Xtreemtec

  • Posts: 2323
  • Joined: Wed Jan 02, 2013 11:48 am
  • Location: The Netherlands

Re: ATEM Software doesn't recognize new clips on hyperdeck

PostTue Sep 12, 2017 4:49 pm

Maybe next week.. When IBC has started that they have a Firmware update with new functions.. But who knows..
Daniel Wittenaar .:: Xtreemtec Media Productions ::. -= www.xtreemtec.nl =-
4K OBV, ATEM TVS HD, 1M/E 4K, 2M/E Broadcast Studio 4K, Hyperdeck Studio Mini, SONY FS7 4K, Ursa Broadcast 4K
Offline

Alar Suija

  • Posts: 22
  • Joined: Sun Jan 24, 2016 11:16 am

Re: ATEM Software doesn't recognize new clips on hyperdeck

PostMon Feb 12, 2018 6:41 am

I have similar issue. ATEM software do not recognize files on inserted SD card (HFS+) and it takes power cycle to show them. I can see and play files using terminal and of course pressing "play" on deck.

BTW, if i use deck controls, then ATEM show dimmed play button, but nothing more (e.g. no running timecode).

Is this okay? (I mean, does anyone have same issue?)

latest FW and ATEM software. SD card is SanDisk Extreme PRO 128 GB and other than that all works O.K.

Thank You for any help!

EDIT: if i change IP (e.g. reconnect deck) clip list is refreshed.
Offline

Ian Morrish

  • Posts: 227
  • Joined: Sun Jan 18, 2015 9:24 pm
  • Location: New Zealand

Re: ATEM Software doesn't recognize new clips on hyperdeck

PostMon Feb 12, 2018 6:48 pm

According to the SDK, you should be able to just switch the active media card to get it to refresh the clip cache. This could easily be automated with PowerShell ;-)

HyperDeck Clip Cache: To speed up processing, the list of clips located on the active storage media of the HyperDeck is cached locally by the switcher. This cache is automatically invalidated when a recording session ends, or when the active storage media changes, and is signaled by a change in clip count on the HyperDeck’s interface. Clients should listen for this change and discard any held clip entry references, re-fetching the new entries from the clip cache when the change occurs. Previously invalidated clip cache entires will remain invalid indefinitely. The clip cache is filled asynchronously to free up bandwidth for user-initiated actions. This means that cache entries may exist (be valid) but may not have their clip information properties populated until a later point in time.
Regards,
Ian Morrish
Video Integrated Scripting Environment
(Windows PowerShell with ATEM driver + more)
https://ianmorrish.wordpress.com

Return to Live Production

Who is online

Users browsing this forum: No registered users and 4 guests