no desktop video device detected - BlackMagic Decklink Mini

Getting started with a Blackmagic product? Ask questions here about setup and installation.
  • Author
  • Message
Offline

nilesh7136

  • Posts: 4
  • Joined: Sat Sep 15, 2018 2:09 pm
  • Real Name: Nilesh Varchand

no desktop video device detected - BlackMagic Decklink Mini

PostSat Sep 15, 2018 2:19 pm

Hello Team,

I have Windows 10 Pro 64bit Activated OS, and its Up to date.
Driver Installed complete. In Device Manager Showing Driver for this device.
But when i open BlackMagic Desktop Video Setup Software its show "no desktop video device detected", i have attached error screenshot for clarification.

Attachment
* Screeenshot of Device Manager & BlackMagic Desktop Video Setup Software

Thank You
Nilesh Varchand
Attachments
Untitled.png
Untitled.png (169.1 KiB) Viewed 920 times
Offline

Tony Rivera

Blackmagic Design

  • Posts: 3255
  • Joined: Mon Aug 12, 2013 4:52 pm
  • Real Name: Tony Rivera

Re: no desktop video device detected - BlackMagic Decklink M

PostTue Sep 18, 2018 10:04 pm

Try reseating the card or a completely different PCIe slot and check the Desktop Video setup again.
Support: http://www.blackmagicdesign.com/support
Info: http://www.blackmagicdesign.com/company

Follow us on Instagram:
@blackmagicnewsofficial
Offline

nilesh7136

  • Posts: 4
  • Joined: Sat Sep 15, 2018 2:09 pm
  • Real Name: Nilesh Varchand

Re: no desktop video device detected - BlackMagic Decklink M

PostThu Sep 20, 2018 12:38 pm

Thank you for valuable reply.

I Have try both. Resetting card and changed PCIe slot, but still same issue.

Thank you
Offline

Tony Rivera

Blackmagic Design

  • Posts: 3255
  • Joined: Mon Aug 12, 2013 4:52 pm
  • Real Name: Tony Rivera

Re: no desktop video device detected - BlackMagic Decklink M

PostThu Sep 20, 2018 5:06 pm

I know you say the OS is up to date but make sure it is and check to make sure you are the administrator for the account. You also don't mention what version of Desktop Video drivers you have installed but make sure you have the most current ones available.
Support: http://www.blackmagicdesign.com/support
Info: http://www.blackmagicdesign.com/company

Follow us on Instagram:
@blackmagicnewsofficial
Offline

nilesh7136

  • Posts: 4
  • Joined: Sat Sep 15, 2018 2:09 pm
  • Real Name: Nilesh Varchand

Re: no desktop video device detected - BlackMagic Decklink M

PostSat Sep 22, 2018 6:11 am

Thank you for Response.

Yes I have check again and OS is up to date. And I am using 10.11.2 Version of Desktop Video Setup Software.

Attachment: OS Up to Date and Version of Desktop Video Setup Software

Thank you
Attachments
Untitled.png
Untitled.png (112.32 KiB) Viewed 818 times
Offline
User avatar

Eric-Jan

  • Posts: 164
  • Joined: Tue Jul 24, 2018 11:58 pm
  • Location: The Netherlands, Haarlem
  • Real Name: Eric-Jan van den Bogaard

Re: no desktop video device detected - BlackMagic Decklink M

PostMon Sep 24, 2018 3:06 pm

Could it be that the Decklink is allready in use by other software, or other system items ?
check out the running tasks, in the task manager,
equipment/software used:
UltraStudio Mini Recorder, Intensity Shuttle (Thunderbolt), ADVC-100 (DV/iLink/Firewire), Davinci Resolve 15 free version, Media Express, MacX Video Converter Pro
Offline

robinhepburn

  • Posts: 2
  • Joined: Wed Sep 26, 2018 8:28 pm
  • Real Name: Robin Hepburn

Re: no desktop video device detected - BlackMagic Decklink M

PostThu Sep 27, 2018 6:55 pm

Can anyone shed any light on this as I have the same problem. I have a Decklink Quad and a Mini Recorder in my workstation at the moment and noticed a few problems.

Both work with driver version 10.9.12, show up in Device Manager, Video Device Setup and work with our test app which uses the Medialooks SDK.
After 10.9.12, the Blackmagic Decklink SDI entries for the Quad still show up under Sound, video and game controllers in Device Manager for the four channels but the four entries for Blackmagic Decklink WDM Streaming are gone. The Decklink Quad also doesn't show up in Video Device Setup and doesn't work with our test app.
After 10.9.12 the Mini Recorder shows up in Device Manager, doesn't show up in Video Device Setup but does work with our test App.
I'd like all my Decklink cards to work properly - 2x Decklink Quad, An Extreme 3D+, Decklink Duo and a Mini Recorder.

Which driver do I need to install for all to work correctly?


FYI I have the latest patched Windows 10 Pro and the latest BlackMagic drivers v10.11.2.0

Thanks
Offline

nilesh7136

  • Posts: 4
  • Joined: Sat Sep 15, 2018 2:09 pm
  • Real Name: Nilesh Varchand

Re: no desktop video device detected - BlackMagic Decklink M

PostFri Sep 28, 2018 1:31 pm

Eric-Jan wrote:Could it be that the Decklink is allready in use by other software, or other system items ?
check out the running tasks, in the task manager,

Sir, Thank you for response.

The device is not detected by BlackMagic Video Setup Software. Nothing showing in task manager.

Thanks
Offline
User avatar

Eric-Jan

  • Posts: 164
  • Joined: Tue Jul 24, 2018 11:58 pm
  • Location: The Netherlands, Haarlem
  • Real Name: Eric-Jan van den Bogaard

Re: no desktop video device detected - BlackMagic Decklink M

PostFri Sep 28, 2018 9:56 pm

The only other thing i can imagine is that you have a conflict with an other "image device",
disconnect/remove other hardware in/from your pc, and see if the Video Desktop Setup will then detect the device correctly. (restart pc)
Firmware of the motherboard is also up to date ? chip sets, etc.... ?
Maybe there are any weird BIOS settings ? like switched off funcitions ?
connect device to card after boot up ?
equipment/software used:
UltraStudio Mini Recorder, Intensity Shuttle (Thunderbolt), ADVC-100 (DV/iLink/Firewire), Davinci Resolve 15 free version, Media Express, MacX Video Converter Pro
Offline

robinhepburn

  • Posts: 2
  • Joined: Wed Sep 26, 2018 8:28 pm
  • Real Name: Robin Hepburn

Re: no desktop video device detected - BlackMagic Decklink M

PostSat Sep 29, 2018 9:41 am

Eric-Jan,
There is no evidence to support any of those ideas. Occam's Razor: it's a Blackmagic Design software and/or firmware issue but, given how common this appears to be, I was hoping someone has had advice from Blackmagic on how to fix it.

The Blackmagic support guys are always helpful when I contact them but I was hoping that this would have been answered already so I wouldn't need to. I'll contact them later to see if they can help.

Robin.
Offline

Melvin Chong

  • Posts: 7
  • Joined: Mon Sep 10, 2012 2:55 am

Re: no desktop video device detected - BlackMagic Decklink M

PostThu Oct 04, 2018 4:32 pm

I have posted this same problem several times regarding my Intensity Pro 4K but it seems no fix is in sight. An older version (I believe 10.8.6 or earlier) actually could actually detect the card but any newer driver from that point onwards was a no-go till today. So it is definitely not a conflict or seating problem but a driver or firmware issue.

To Blackmagic support : does the new driver actually improve the stability or performance of the older cards or only to the newer ones?

Return to Getting Started

Who is online

Users browsing this forum: No registered users and 3 guests