Linux kernel 4.20 - blackmagic-io no load

Ask software engineering and SDK questions for developers working on Mac OS X, Windows or Linux.
  • Author
  • Message
Offline

JeromeFr

  • Posts: 2
  • Joined: Tue Dec 25, 2018 12:32 pm
  • Real Name: Jérome Bihoue

Linux kernel 4.20 - blackmagic-io no load

PostTue Dec 25, 2018 1:01 pm

Hello,

To signal that the blackmagic-io module does not load with kernel 4.20-rcX and 4.20
The modules seem to compile, but impossible to load blacmagic-io

Regards,
Jerome
Attachments
noLoad.png
noLoad.png (22.32 KiB) Viewed 1364 times
Offline

ggrub08

  • Posts: 1
  • Joined: Mon Jan 07, 2019 6:23 pm
  • Real Name: Gerald Gruber

Re: Linux kernel 4.20 - blackmagic-io no load

PostMon Jan 07, 2019 6:28 pm

I can confirm that. Intensity Pro 4k. Arch, kernel 4.20.0. Please fix this.
Offline

wakuken

  • Posts: 1
  • Joined: Mon Feb 04, 2019 4:03 am
  • Real Name: Kensaku Wakuda

Re: Linux kernel 4.20 - blackmagic-io no load

PostMon Feb 04, 2019 4:40 am

I have the same problem in Kernel v4.20.6.
I tried the following command but "depmod" failed.

Code: Select all
$ sudo dkms install blackmagic-io/10.11.4a9 -k 4.20.6-042006-generic --verbose --force

blackmagic-io:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.20.6-042006-generic/updates/dkms/

snd_blackmagic-io.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.20.6-042006-generic/updates/dkms/

Warning: The post_install script is not executable.

do_depmod 4.20.6-042006-generic
depmod: ERROR: Cycle detected: blackmagic_io -> blackmagic_io
depmod: ERROR: Found 1 modules in dependency cycles!
(bad exit status: 1)

-------- Uninstall Beginning --------
Module:  blackmagic-io
Version: 10.11.4a9
Kernel:  4.20.6-042006-generic (x86_64)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

blackmagic-io.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.20.6-042006-generic/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.

snd_blackmagic-io.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.20.6-042006-generic/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.

do_depmod 4.20.6-042006-generic

DKMS: uninstall completed.
Error! Problems with depmod detected.  Automatically uninstalling this module.
DKMS: Install Failed (depmod problems).  Module rolled back to built state.


The depmod says:
Code: Select all
depmod: ERROR: Cycle detected: blackmagic_io -> blackmagic_io
depmod: ERROR: Found 1 modules in dependency cycles!
(bad exit status: 1)


Could anyone help me?
Offline

Lexridge

  • Posts: 2
  • Joined: Tue Nov 13, 2012 8:39 pm

Re: Linux kernel 4.20 - blackmagic-io no load

PostFri Feb 08, 2019 3:29 pm

I am also having this problem. Decklink Duo on Fedora 28. kernel version 4.20.6-100.
--
Jim Hines
Offline

wmendez

  • Posts: 4
  • Joined: Fri Dec 14, 2018 6:43 pm
  • Real Name: Will Mendez

Re: Linux kernel 4.20 - blackmagic-io no load

PostSun Feb 10, 2019 4:41 am

Confirming the same on this end Fedora 29 Intensity Pro 4K , 4.20.6-200. It was working under 4.20.5, I booted into that version but no go.

Emailed issue to Devs.
Offline

box293

  • Posts: 1
  • Joined: Fri Feb 15, 2019 2:37 am
  • Real Name: Troy Lea

Re: Linux kernel 4.20 - blackmagic-io no load

PostFri Feb 15, 2019 2:40 am

Any update on this?

Can't get Intensity Shuttle Thunderbolt working on Fedora 29.

Code: Select all
# dkms install -m blackmagic-io -v 10.11.4a9 --all

blackmagic-io.ko.xz:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.20.7-200.fc29.x86_64/extra/

snd_blackmagic-io.ko.xz:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.20.7-200.fc29.x86_64/extra/
Adding any weak-modules

Warning: The post_install script is not executable.

depmod....(bad exit status: 1)

-------- Uninstall Beginning --------
Module:  blackmagic-io
Version: 10.11.4a9
Kernel:  4.20.7-200.fc29.x86_64 (x86_64)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.
Removing any linked weak-modules

blackmagic-io.ko.xz:
 - Uninstallation
   - Deleting from: /lib/modules/4.20.7-200.fc29.x86_64/extra/
rmdir: failed to remove 'extra': Directory not empty
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


snd_blackmagic-io.ko.xz:
 - Uninstallation
   - Deleting from: /lib/modules/4.20.7-200.fc29.x86_64/extra/
rmdir: failed to remove 'extra': Directory not empty
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.

depmod....

DKMS: uninstall completed.
Error! Problems with depmod detected.  Automatically uninstalling this module.
DKMS: Install Failed (depmod problems).  Module rolled back to built state.
My real name is Troy.

Return to Software Developers

Who is online

Users browsing this forum: einar-adolfsen and 1 guest