Resolve 15 - silent crash on startup (Win10)

Get answers to your questions about color grading, editing and finishing with DaVinci Resolve.
  • Author
  • Message
Offline

Snowly

  • Posts: 11
  • Joined: Thu Apr 26, 2018 12:19 am
  • Real Name: Stani Tolmi

Resolve 15 - silent crash on startup (Win10)

PostSat Dec 15, 2018 7:12 am

I had 15.0.1 installed, after a couple months of not using it I tried to start it and it silently crashed on a splash screen, on "loading Fairlight". No crash dump produced.
Downloaded and installed the latest 15.2.1, exactly the same result.

What I have tried:
* Reinstall Resolve and Resolve Panels with removing both of them beforehand;
* Rebooting;
* Moving away "C:\ProgramData\Blackmagic Design\DaVinci Resolve" contents.
In fact, I tried all of this multiple times.
Also tried reinstalling video drivers. On a forum there was a recent post about crashes and it worked out with 18.10.2, but not for me.
I wish I could tell more, but there's not much to tell in my situation...

System: Windows 10 ent 1803, Ryzen 5 1400, 32GB RAM (AMD), MSI Radeon RX560 4GB (18.12.2 latest), Samsung 960 EVO SSD.
Tried to figure the problem comparing the log files with a Resolve on a similar PC, but nothing to catch on, they look normal. Mine look like they got suddenly cut during loading.

Attaching VS2013 debugger shows error on fusionscript.dll thread right before the crash:
Code: Select all
Unhandled exception at 0x00007FF9F95B85E0 (ntdll.dll) in Resolve.exe: 0xC000000D: An invalid parameter was passed to a service or function.

Call stack on crash: fusionscript.dll > python27.dll > [external code] > FairlightPage.dll > this
debug.png
call stack on crash
debug.png (17.01 KiB) Viewed 368 times


What else can I try?
Attachments
DaVinci-Resolve-logs-_ 61137.zip
(25.1 KiB) Not downloaded yet
Last edited by Snowly on Wed Dec 19, 2018 7:48 am, edited 1 time in total.
Offline

Snowly

  • Posts: 11
  • Joined: Thu Apr 26, 2018 12:19 am
  • Real Name: Stani Tolmi

Re: Resolve 15 - silent crash on startup (Win10)

PostWed Dec 19, 2018 12:55 am

15.2.2 not working as well.
I've also created another local user on windows, tried to run under it and got the same result.
Antivirus was disabled when I tried this.
Offline

Snowly

  • Posts: 11
  • Joined: Thu Apr 26, 2018 12:19 am
  • Real Name: Stani Tolmi

Re: Resolve 15 - silent crash on startup (Win10)

PostWed Dec 19, 2018 6:29 am

And another update:
14.3.1 somehow works. Tried 15.0.0 right after - it doesn't.
I used 15.x versions since betas, but never had problems like this one...

I'm running out of ideas :( And I do need 15 fixed, because Fusion is a killer feature to me. Projects are waiting...
Offline

Snowly

  • Posts: 11
  • Joined: Thu Apr 26, 2018 12:19 am
  • Real Name: Stani Tolmi

Re: Resolve 15 - silent crash on startup (Win10)

PostMon Dec 31, 2018 12:47 am

I suspect there's something to do with Resolve15 audio subsystem. Installed 15.2.2 again to try and disable some audio devices (leaving the only one enabled; I have multiple) in the device manager, yet again no luck.
Still waiting for someone to suggest something...
a sad end of the year :(
Offline

Snowly

  • Posts: 11
  • Joined: Thu Apr 26, 2018 12:19 am
  • Real Name: Stani Tolmi

Re: Resolve 15 - silent crash on startup (Win10)

PostFri Jan 25, 2019 8:44 pm

Same issue with 15.2.3 (with cleaned up Preferences and Support)

Fresh logs capture:
DaVinci-Resolve-logs-_204218.zip
(21.95 KiB) Downloaded 5 times

BMD, where are you?
Offline
User avatar

Dwaine Maggart

Blackmagic Design

  • Posts: 4925
  • Joined: Wed Aug 22, 2012 2:53 pm

Re: Resolve 15 - silent crash on startup (Win10)

PostFri Jan 25, 2019 11:10 pm

Multiple people have had AMD driver issues lately.

If you haven't already, try the current Adrenaline 19.1.1 and 19.1.2 and see if those help.
Dwaine Maggart
Blackmagic Design DaVinci Support
Offline

Snowly

  • Posts: 11
  • Joined: Thu Apr 26, 2018 12:19 am
  • Real Name: Stani Tolmi

Re: Resolve 15 - silent crash on startup (Win10)

PostSat Jan 26, 2019 1:16 am

Thank you for a response!
I already tested this on a multiple versions, including all 19 versions, because I'm still trying to test Resolve 15 after every new Radeon Software is released, so I had tested Resolve 15.2.3 on 19.1.1 drivers. And just now on 19.1.2.

As a reminder, I'm sure there's something wrong with audio, not video:
1. Resolve 15 crashes on loading Fairlight, an audio editor. (But worked before ~October.)
2. Resolve 14 works, with its old audio subsystem.
3. Resolve 15 logs look similar to my partner with Resolve 15 on a similar PC (Ryzen and Radeon as well, but with a bit less recent driver versions). Not only regarding AMD/OpenCL, but the whole logs look similar and fine, except mine got cut due to crash.
Offline
User avatar

Dwaine Maggart

Blackmagic Design

  • Posts: 4925
  • Joined: Wed Aug 22, 2012 2:53 pm

Re: Resolve 15 - silent crash on startup (Win10)

PostSat Jan 26, 2019 7:02 am

In the last logs you sent, it's hanging after initializing the RX560. Almost certain this has nothing to do with Fairlight and audio and everything to do with the AMD driver.

A couple of people have reported that the Crimson 17.11.4 driver has worked for them. So, try the following:

Install the current version of Display Driver Uninstaller, AKA DDU, from here:

https://www.wagnardsoft.com/

Uninstall the current AMD driver, whatever it is, and install the Crimson 17.11.4 driver from here:

https://www.amd.com/en/support/kb/relea ... in-17-11-4


EDIT! I've discovered that the 17.11.4 driver will not install on Windows 10 version 1809. While it works fine on version 1803, since many people are likely updating to 1809, it should not be installed on that version.

The Adrenaline 17.12.1 driver will install on Windows 10 1809, so that would be something to try:

https://www2.ati.com/drivers/win10-64bi ... -dec11.exe



If that works, you can try installing the current Adrenaline driver and see if that then works.
Last edited by Dwaine Maggart on Wed Jan 30, 2019 6:52 am, edited 1 time in total.
Dwaine Maggart
Blackmagic Design DaVinci Support
Offline

Snowly

  • Posts: 11
  • Joined: Thu Apr 26, 2018 12:19 am
  • Real Name: Stani Tolmi

Re: Resolve 15 - silent crash on startup (Win10)

PostSat Jan 26, 2019 11:52 pm

Thank you. I did, but no luck. Yet it helped with something: logs now look the same as from the first post. Probably past attempts with reinstalling video drivers broke something, which is now fixed. Anyway, here's the log:
ResolveDebug.zip
debug log with dump summary
(6.15 KiB) Downloaded 1 time

This time I'm not using capture-logs because there's a big dump file and it is not compressing well. Opening it in VS reveals ntdll error, but the different one: "The thread tried to read from or write to a virtual address for which it does not have the appropriate access." Summary of that dump is included in the attached zip.
Do you need that big zip created by capture-logs? And what should I try next?

For your information, here's what I did:
1. Disconnected network cable as DDU recommends.
2. Restarted in Safe mode, DDU, installed 19.1.2 (in case there's just a settings corruption) after restart - didn't worked.
3. Repeated step 2, but with installing 17.11.4 after restart - didn't worked too.
4. Restarted to be sure, still no luck.
(5. Upgraded back to 19.1.2, selecting clean install, and reconnected network.)
Offline

Snowly

  • Posts: 11
  • Joined: Thu Apr 26, 2018 12:19 am
  • Real Name: Stani Tolmi

Re: Resolve 15 - silent crash on startup (Win10)

PostSat Feb 09, 2019 9:07 am

Regarding your edit:
Win10ent does not appear to have 1809 update, it is still on 1803 (just checked on WinUpdate - it tells me that system is up to date). Latest "Feature Update" installation date is 2018-05-11, latest "Quality Update" - 2019-01-26.
So if you're telling that Resolve15 should work with 17.11.4 drivers on 1803, then I can skip testing for 17.12.1.
Yet again, Resolve15 was working fine before...
Offline

Snowly

  • Posts: 11
  • Joined: Thu Apr 26, 2018 12:19 am
  • Real Name: Stani Tolmi

Re: Resolve 15 - silent crash on startup (Win10)

PostSun Mar 17, 2019 3:47 pm

Well, the problem is still there... Still unable to do anything since December :(

Return to DaVinci Resolve

Who is online

Users browsing this forum: Bing [Bot], Jack Swart, Leslie Wand, Seth Goldin and 22 guests