What versions of python work?

Ask software engineering and SDK questions for developers working on Mac OS X, Windows or Linux.
  • Author
  • Message
Offline

Henalds

  • Posts: 23
  • Joined: Mon Jul 22, 2019 2:24 am
  • Real Name: Samuel Cruickshank

What versions of python work?

PostTue Jun 22, 2021 9:09 am

Simply put, im wondering what versions of python work with what versions of Davinci Resolve.

A while ago when I was using the Resolve API (for version 15 I think) I remember having to use Python 2.7, is this still the case with newer versions of Danvinci Resolve?
Offline
User avatar

iddos-l

  • Posts: 536
  • Joined: Sat Mar 30, 2019 7:55 pm
  • Real Name: iddo lahman

Re: What versions of python work?

PostTue Jun 22, 2021 11:49 am

You can use python3 but not 3.7 and above.
I personally use 3.68.
The ‘imp’ module was deprecated since 3.7 and for now it is the only module able to load resolve object.

2.7 is also support.


Sent from my iPhone using Tapatalk

Return to Software Developers

Who is online

Users browsing this forum: No registered users and 5 guests