Upload still to media pool failing

Ask software engineering and SDK questions for developers working on Mac OS X, Windows or Linux.
  • Author
  • Message
Offline

johnd126

  • Posts: 3
  • Joined: Mon Jun 20, 2022 3:15 pm
  • Real Name: John Deweerd

Upload still to media pool failing

PostMon Jun 20, 2022 5:35 pm

Hi,

I'm trying to upload a still image to the media pool but it's constantly failing.

I was basing my code on the SwitcherMediaPool code from the 8.7.1 SDK package. The upload also fails when using the compiled version of the SwitcherMediaPool.exe included in the package. I've tried with a few .tga's created using a variety of graphic software packages.

During debugging I can see that it gets to the point where it writes "Extension data is unsupported" in the TGALoader.cpp. The "TRUEVISION-XFILE" signature does exist in the sample files.

Any ideas?

Thanks,

John
Offline

Ian Morrish

  • Posts: 576
  • Joined: Sun Jan 18, 2015 9:24 pm
  • Location: New Zealand

Re: Upload still to media pool failing

PostWed Jun 29, 2022 4:37 am

The TGA file can't have any compression. Most graphics apps save TGA with RLE on by default which isn't supported. The file must also be in the same resolution as the switcher.

I have use GIMP to create compatible TGA files, just turn off the RLE compression option when you export to tga extension.
Regards,
Ian Morrish
Video Integrated Scripting Environment
(Windows PowerShell with ATEM driver + more)
https://ianmorrish.wordpress.com
Offline

johnd126

  • Posts: 3
  • Joined: Mon Jun 20, 2022 3:15 pm
  • Real Name: John Deweerd

Re: Upload still to media pool failing

PostWed Jun 29, 2022 5:05 pm

Yep, that was it.

That's disappointing: all the tools we use create the compressed versions and all the other displays expect it.

Oh well.

Thanks!

Return to Software Developers

Who is online

Users browsing this forum: No registered users and 6 guests