Audio dropouts capturing 2+ streams (DeckLink 8K Pro)

Ask software engineering and SDK questions for developers working on Mac OS X, Windows or Linux.
  • Author
  • Message


  • Posts: 1
  • Joined: Sun Nov 10, 2019 6:17 pm
  • Real Name: Andrew Armenia

Audio dropouts capturing 2+ streams (DeckLink 8K Pro)

PostSun Nov 10, 2019 6:34 pm

We've got a couple of DeckLink 8K Pro cards that we are using in 4-channel half-duplex mode to capture up to 4 1080i/60 streams (upgraded from DeckLink Quads). Using the same code we had been using for the Quads, we are able to capture one stream seemingly without issues. Two streams usually work, but after some time (30 minutes to a few hours) we get intermittent or complete audio dropouts on one or both of them, and have to reboot the machine to get things back to normal (restarting our program doesn't change things). With four streams this starts to happen very quickly (within a minute or two).

Specifically, the symptom is that we continue to receive audio callbacks, but the buffer received only contains zeros. We've been able to reproduce this on two different cards.

I tried initializing all streams from the same process/thread vs. different processes; this didn't seem to make any difference.

Using one subdevice as input while other subdevices are acting as outputs doesn't seem to trigger the issue.

Once the problem is triggered, even the SDK sample capture program is not able to capture audio from the card until after a reboot - though I have not yet tried to trigger the bug using just the sample program.

This is on Linux, with Desktop Video 11.4. We have tried several kernel versions (4.9, 4.19, 5.2) and have seen the same issues on all of them. The system is a Xeon E5-2630v3, 32GB RAM, Supermicro X10DRL-i motherboard.


  • Posts: 1
  • Joined: Mon Dec 02, 2019 9:02 am
  • Real Name: Sergey Kukota

Re: Audio dropouts capturing 2+ streams (DeckLink 8K Pro)

PostWed Dec 11, 2019 9:44 am


We have identical situation with DeckLink 8K Pro, use kernel versions 3.10.0-*.
On previous cards models this problems is not appearing on the same hardware.

CPU: Intel(R) Xeon(R) CPU E3-1585L v5 @ 3.00GHz
Motherboard: X11SSH-GF-1585L
Desktop Video: 11.4a14.x86_64
Capture: 1080i/50

We tried the previous driver versions, but the situation doesn't change.

Return to Software Developers

Who is online

Users browsing this forum: No registered users and 3 guests