Page 1 of 1

Blackmagic RAW SDK: OpenClip file permissions

PostPosted: Sat Jun 13, 2020 6:25 am
by soulthreads
Hello!

During a particular investigation we've found out that IBlackmagicRaw::OpenClip() opens the clip file in read-write mode (at least on Windows).

This messes up things that try to simultaneously open that file in read-only mode (with "FILE_SHARE_READ" shared mode).

If it's not a secret, is there a particular reason why OpenClip does that? Does it actually write something to that file, and is there a way to open clip in read-only mode?

Re: Blackmagic RAW SDK: OpenClip file permissions

PostPosted: Wed Jun 24, 2020 8:36 am
by antoine
Hi,
Interesting question, is anyone from Blackmagic passing through here ?

Re: Blackmagic RAW SDK: OpenClip file permissions

PostPosted: Wed Jun 24, 2020 11:35 pm
by CaptainHook
It's basically a bug that was introduced in 1.7 for the Windows version (lead to us removing thumbnail support for Windows temporarily as it was caught too late). We should be fixing the behaviour in a future update, if its a big issue you could revert to 1.6.x for now.

Re: Blackmagic RAW SDK: OpenClip file permissions

PostPosted: Sat Jun 27, 2020 10:37 am
by antoine
Thanks for confirming what I was guessing in the other thread viewtopic.php?f=12&t=112955

Did you have trouble / interactions issues between shell thumbnail generation and the Blackmagic plugins for Adobe ? We've seen file error access issues (on both our plugin and Blackmagic official Adobe plugins), it might be related and need to know


Thing is if we rollback to 1.6.1 we would loose the new features from 1.7

Added support for Panasonic EVA1 Blackmagic RAW clips captured by Blackmagic Video Assist.
Added support for Canon EOS C300 Mark II Blackmagic RAW clips captured by Blackmagic Video Assist.

Re: Blackmagic RAW SDK: OpenClip file permissions

PostPosted: Sat Jun 27, 2020 1:21 pm
by antoine
Since this is affecting our users in all Adobe apps, especially After Effects we published an article to warn our users :

Blackmagic RAW 1.7 Bug : no thumbnails and file access issues


https://www.autokroma.com/blog/Blackmag ... ess-Issues

Re: Blackmagic RAW SDK: OpenClip file permissions

PostPosted: Mon Jun 29, 2020 10:34 am
by antoine
CaptainHook wrote:It's basically a bug that was introduced in 1.7 for the Windows version (lead to us removing thumbnail support for Windows temporarily as it was caught too late). We should be fixing the behaviour in a future update, if its a big issue you could revert to 1.6.x for now.

Would you know if the same issue happens on Mac OSX ? Thanks !