Controlling different ATEM versions from the same software

Ask software engineering and SDK questions for developers working on Mac OS X, Windows or Linux.
  • Author
  • Message
Offline

lanephillips

  • Posts: 5
  • Joined: Wed Dec 06, 2017 10:05 pm

Controlling different ATEM versions from the same software

PostTue Jan 12, 2021 10:16 pm

My company has its own software to control Blackmagic devices at customer locations. When we started using the ATEM SDK, 7.2 was the current version. Now that we're starting to use the Mini Pro at some locations, we've had to start building our software with the 8.5 SDK, no problem.

But now we're finding our software doesn't work for customers that have the older 7.* ATEM drivers and firmware installed. Although we send out automatic updates of our own software, we don't have a process in place to automatically update the ATEM software at dozens of customer locations. Is it possible to control ATEMs with different versions of the firmware from the same application?

I see there is a Legacy folder in the SDK that appears to have headers and code for every older version of the SDK. I looked in one of the header files and I see the the classes have names like "IBMDSwitcherKey_v7_2". So maybe I can include multiple versions of the SDK in my app and it should build fine without any name collisions.

So assuming I can control different ATEM versions the question now is: Is it possible to detect which version of ATEM software is installed on the computer, or which firmware version is on the ATEM? I think this is possible since the ATEM control panel can detect it. (Or maybe that's the ATEM Setup software I'm thinking of.)

Return to Software Developers

Who is online

Users browsing this forum: No registered users and 3 guests