Decklink opencv init capture problems

Ask software engineering and SDK questions for developers working on Mac OS X, Windows or Linux.
  • Author
  • Message
Offline

AdriaComos

  • Posts: 2
  • Joined: Fri Feb 27, 2015 9:18 am

Decklink opencv init capture problems

PostFri Feb 27, 2015 9:57 am

Hello!

I'm trying to initialize a BlackMagic Decklink (USB3 Duo) with OpenCV to capture frames. I trying to do this, if possible, with OpenCV exclusively and without the DeckLink SDK. It's not working very well... The device it's opened ok, but, randomly, in some executions the code can't read any frame (in another, however, its working fine).

Basically, the code is as follow:

c::VideoCapture capture;
capture.open( 0 )
if (capture.isOpened())
{
capture.set( CV_CAP_PROP_FRAME_WIDTH, 1920);
capture.set( CV_CAP_PROP_FRAME_HEIGHT, 1080);
capture.set( CV_CAP_PROP_FPS , 50);
capture.set( CV_CAP_PROP_FOURCC, CV_FOURCC('U','Y','V','Y'));

cv::Mat m;
capture.read(m);
}

The parameters seems correct because sometimes work... (my doubts its for CV_FOURCC, but I try some of them with identical results). I miss something? ...or perhaps OpenCV for initializing the device isn't the best choice, and I'm need to go throw Decklink SDK?

Thanks in advance...and sorry for my poor english!
Offline

Matt Jefferson

Blackmagic Design

  • Posts: 130
  • Joined: Fri Aug 31, 2012 12:50 am

Re: Decklink opencv init capture problems

PostMon Mar 02, 2015 1:51 am

Hello Adria Comos -

Blackmagic Design Desktop video SDK is the recommended way to control the input / output solution or cards. We do not support any specific OpenCV functionality here at Blackmagic Design. Any development or support completed by third parties is not supported by our developer or technical support.

We do not have any open source software drivers (no V4L or similar) support officially here from our team so we do recommend creating your own interface to you software with the Blackmagic Design SDK.

Matt Jefferson
Offline

AdriaComos

  • Posts: 2
  • Joined: Fri Feb 27, 2015 9:18 am

Re: Decklink opencv init capture problems

PostMon Mar 02, 2015 3:05 pm

Thanks Matt... Then I will try to do with the BlackMagic SDK

Return to Software Developers

Who is online

Users browsing this forum: No registered users and 1 guest