Page 1 of 1

Unable to set VideoHub info via Ethernet protocol

PostPosted: Mon Jul 15, 2019 10:16 pm
by guzewski
I'm using the VideoHub Ethernet Protocol to set up a VideoHub, and it's going OK except for one very significant issue.

First of all, my application is able to connect to the VideoHub and it sends me everything that the document says it should (i.e. Preamble, Device Information, label and routing information, etc). The version reported in the PROTOCOL PREAMBLE is 2.8. The VIDEO OUTPUT ROUTING shows that all video inputs are assigned to -1, which I guess means they're not routed yet. All locks show up as U (i.e. unlocked).

So this is great, and then I tried to change the video output routing with the following command:

0 5\n

The VideoHub first responds with an ACK\n\n which is encouraging.

It then sends the following status update:

0 -1\n

That -1 value in the response indicates that the change I requested was not actually done, in spite of the previous ACK response.

As an experiment, I also tried to change an output label, and I get the same behavior: the system first ACKs my command and then send me the label status with the old label.

I'm not sure what I'm missing here. Is there some feature of the VideoHub that prevents updates via the Ethernet protocol? I can't think of any other reason that my commands don't latch on the system.

Re: Unable to set VideoHub info via Ethernet protocol

PostPosted: Tue Jul 16, 2019 3:17 pm
by guzewski
Thanks to Hersh Burston of BMD for setting me straight.

I can tell from the preamble that you are connecting to an IP Videohub but it has no IP Video devices connected.

What you are seeing is expected.

Please let me know if you need more assistance.

Indeed, there was a PC in the lab running VideoHub software and somehow that IP address was given for my testing. :oops:

I found the right IP address and everything works perfectly. Thanks for the help and this matter is now closed.