Decklink Quad 2 driver install gives BSOD

Getting started with a Blackmagic product? Ask questions here about setup and installation.
  • Author
  • Message


  • Posts: 1
  • Joined: Wed Feb 01, 2023 11:02 am
  • Real Name: Nico Pinxteren

Decklink Quad 2 driver install gives BSOD

PostWed Feb 01, 2023 11:27 am


I'm building a setup for use with vMix for our local broadcasting company. I have bought a system with these specs:
Intel Processor i9-12900K
Micro-Star International Co. Ltd. MEG Z690 UNIFY (MS-7D28) (U3E1)
64GB Kingston DDR5 FURY Beast 2x32GB 4800-38
4095MB NVIDIA GeForce RTX 3070 Ti (NVIDIA)
2x Samsung SSD 980 PRO with Heatsink 2TB
Windows 11 Pro 64-bit
No additional Anti-virus installed
I have plugged in the Decklink Quad 2 card in the second PCIe slot. Bios is set to 8x/8x lanes.
All is well up to this point.
Then I install the driver for the declink (Blackmagic_Desktop_Video_Windows_12.4.2 software).
Software installs correctly.
All seems to function I can set the declink in- and outputs correctly, it works in vMix.

But then: when I log out BSOD.

WinDbg tells me BlackmagicIO.sys is the cause of the BSOD's. I have removed all kinds of software, but the BSOD's only stop when I uninstall Blackmagic_Desktop_Video_Windows_12.4.2. I have also tried 12.4.1, 12.4.0 and 12.3.1 but they also cause BSOD.

So it seems I can't build a vMix PC with these components? What do I do wrong?

I hope for some help here cuz I'm in desperate need for a fix!

Best regards,


Keith Gresham

  • Posts: 19
  • Joined: Mon Feb 10, 2014 12:42 am

Re: Decklink Quad 2 driver install gives BSOD

PostWed Apr 12, 2023 8:16 pm

I'm having the same issue:
SYMBOL_NAME: BlackmagicIO+51e1f
IMAGE_NAME: BlackmagicIO.sys
STACK_COMMAND: .cxr; .ecxr ; kb
FAILURE_BUCKET_ID: AV_BlackmagicIO!unknown_function
OS_VERSION: 10.0.22621.1
BUILDLAB_STR: ni_release
OSNAME: Windows 10
FAILURE_ID_HASH: {6bffa081-2d07-8278-2b62-d585f8d43363}

I'm actually on Windows 11 Pro 64-bit. Decklink 8K Pro. Z790 chipset (ASUS Proart Creator). Going to try the previous version of Desktop Video.


  • Posts: 5
  • Joined: Wed Mar 22, 2023 11:25 am
  • Real Name: Ofer Shafir

Re: Decklink Quad 2 driver install gives BSOD

PostWed Apr 19, 2023 12:59 pm

A similar situation here:

Installed a Duo 2 in an Asus Z790 board (Creator Wifi) and got a BSOD (IRQL Not less or equal) on next boot attempts.

Tried both CPU PCIe slot (with and without x8/x8), and chipset PCIe slot which is PCIe-3 x4 with no change. In both ways, Duo 2 is recognized correctly by the BIOS (Gen-2, x4).

Tried older versions of Desktop Video with no change.

Tried a different Asus Z790 Board (Z790-A WiFi), and a Gigabyte Z790 (Aero-G) and got the same BSOD.

Tested these boards with RTX 4080, RTX 3060 which made no difference.

Removing the GPU or the NVIDIA driver avoids the BSOD but of course irrelevant.

Same problem occurs when replacing Duo 2 with 8K Pro.

Contacted Support and was told this is probably a system issue :geek:

However at this point any idea is welcome :D

Edit: Forgot to mention, all tests with W11. No problems with W10.


  • Posts: 4
  • Joined: Mon Feb 13, 2017 4:45 pm
  • Real Name: Dipen Shah

Re: Decklink Quad 2 driver install gives BSOD

PostThu May 11, 2023 5:50 pm

Having the same issue on a Lenovo P360 Ultra with a i9-12900 with an NVidia A2000.

Anyone hear anything from support? About to file a file a support request.

Francisco Silva

  • Posts: 1
  • Joined: Thu May 11, 2023 8:02 pm
  • Real Name: Francisco Silva

Re: Decklink Quad 2 driver install gives BSOD

PostThu May 11, 2023 8:17 pm

Registered just to add that I'm also facing the same issue. I cannot reproduce the BSOD reliably, it seems to happen more or less randomly.

Tried all the available driver versions - problem remains, more with some versions than others but that my be just down to luck.

Using Windows 11, AMD Radeon RX6600, i7-11700K, Asus Z590 chipset.

Full windbg output:

Code: Select all

Microsoft (R) Windows Debugger Version 10.0.25200.1003 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.

Loading Dump File [C:\Users\...\Desktop\050723-7875-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

************* Path validation summary **************
Response                         Time (ms)     Location
Deferred                                       srv*
Symbol search path is: srv*
Executable search path is:
Windows 10 Kernel Version 22621 MP (16 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS
Edition build lab: 22621.1.amd64fre.ni_release.220506-1250
Machine Name:
Kernel base = 0xfffff802`7fe00000 PsLoadedModuleList = 0xfffff802`80a13420
Debug session time: Sun May  7 10:14:24.962 2023 (UTC + 1:00)
System Uptime: 0 days 0:00:09.700
Loading Kernel Symbols
Loading User Symbols
Loading unloaded module list
For analysis of this file, run !analyze -v
fffff802`802293a0 48894c2408      mov     qword ptr [rsp+8],rcx ss:0018:ffffae00`26cd5f60=000000000000000a
12: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If a kernel debugger is available get the stack backtrace.
Arg1: 00000000058002ff, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000000, bitfield :
   bit 0 : value 0 = read operation, 1 = write operation
   bit 3 : value 0 = not an execute operation, 1 = execute operation (only on chips which support this level of status)
Arg4: fffff80280032335, address which referenced memory

Debugging Details:


    Key  : Analysis.CPU.mSec
    Value: 1203

    Key  : Analysis.DebugAnalysisManager
    Value: Create

    Key  : Analysis.Elapsed.mSec
    Value: 3022

    Key  : Analysis.IO.Other.Mb
    Value: 0

    Key  : Analysis.IO.Read.Mb
    Value: 0

    Key  : Analysis.IO.Write.Mb
    Value: 0

    Key  : Analysis.Init.CPU.mSec
    Value: 108

    Key  : Analysis.Init.Elapsed.mSec
    Value: 8169

    Key  : Analysis.Memory.CommitPeak.Mb
    Value: 90

    Key  : Bugcheck.Code.DumpHeader
    Value: 0xa

    Key  : Bugcheck.Code.Register
    Value: 0xa

    Key  : WER.OS.Branch
    Value: ni_release

    Key  : WER.OS.Timestamp
    Value: 2022-05-06T12:50:00Z

    Key  : WER.OS.Version
    Value: 10.0.22621.1

FILE_IN_CAB:  050723-7875-01.dmp

TAG_NOT_DEFINED_202b:  *** Unknown TAG in analysis list 202b


BUGCHECK_P1: 58002ff



BUGCHECK_P4: fffff80280032335

READ_ADDRESS: fffff80280b1c468: Unable to get MiVisibleState
Unable to get NonPagedPoolStart
Unable to get NonPagedPoolEnd
Unable to get PagedPoolStart
Unable to get PagedPoolEnd
unable to get nt!MmSpecialPagesInUse

BLACKBOXBSD: 1 (!blackboxbsd)

BLACKBOXNTFS: 1 (!blackboxntfs)

BLACKBOXPNP: 1 (!blackboxpnp)


PROCESS_NAME:  svchost.exe

TRAP_FRAME:  ffffae0026cd60a0 -- (.trap 0xffffae0026cd60a0)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=ffffd3821b2d6730 rbx=0000000000000000 rcx=00000000058002f7
rdx=0000000000000001 rsi=0000000000000000 rdi=0000000000000000
rip=fffff80280032335 rsp=ffffae0026cd6230 rbp=0000000000000000
 r8=0000000000000000  r9=0000000000000000 r10=ffffd3821b477820
r11=0000000000000000 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei ng nz ac pe cy
fffff802`80032335 4c395108        cmp     qword ptr [rcx+8],r10 ds:00000000`058002ff=????????????????
Resetting default scope

ffffae00`26cd5f58 fffff802`8023e9a9     : 00000000`0000000a 00000000`058002ff 00000000`00000002 00000000`00000000 : nt!KeBugCheckEx
ffffae00`26cd5f60 fffff802`8023a034     : 00000000`f575e6a2 ffffd382`2d0f99e0 00000000`00000001 00000000`00000000 : nt!KiBugCheckDispatch+0x69
ffffae00`26cd60a0 fffff802`80032335     : 00000000`00000000 ffffd382`2d0f99e0 ffffd382`3291de80 fffff802`8089bb9e : nt!KiPageFault+0x474
ffffae00`26cd6230 fffff802`b94a1e1f     : ffffd382`00000000 ffffae00`26cd6510 ffffae00`26cd6328 ffffd382`1b477820 : nt!KeSetEvent+0xa5
ffffae00`26cd62c0 ffffd382`00000000     : ffffae00`26cd6510 ffffae00`26cd6328 ffffd382`1b477820 ffffd382`3291de80 : BlackmagicIO+0x51e1f
ffffae00`26cd62c8 ffffae00`26cd6510     : ffffae00`26cd6328 ffffd382`1b477820 ffffd382`3291de80 fffff802`b9476c7e : 0xffffd382`00000000
ffffae00`26cd62d0 ffffae00`26cd6328     : ffffd382`1b477820 ffffd382`3291de80 fffff802`b9476c7e ffffd382`33078130 : 0xffffae00`26cd6510
ffffae00`26cd62d8 ffffd382`1b477820     : ffffd382`3291de80 fffff802`b9476c7e ffffd382`33078130 ffffd382`2af45600 : 0xffffae00`26cd6328
ffffae00`26cd62e0 ffffd382`3291de80     : fffff802`b9476c7e ffffd382`33078130 ffffd382`2af45600 00000000`00000000 : 0xffffd382`1b477820
ffffae00`26cd62e8 fffff802`b9476c7e     : ffffd382`33078130 ffffd382`2af45600 00000000`00000000 fffff802`b9458d72 : 0xffffd382`3291de80
ffffae00`26cd62f0 ffffd382`33078130     : ffffd382`2af45600 00000000`00000000 fffff802`b9458d72 00000000`00000000 : BlackmagicIO+0x26c7e
ffffae00`26cd62f8 ffffd382`2af45600     : 00000000`00000000 fffff802`b9458d72 00000000`00000000 fffff802`b9460b0e : 0xffffd382`33078130
ffffae00`26cd6300 00000000`00000000     : fffff802`b9458d72 00000000`00000000 fffff802`b9460b0e ffffd382`24cf5b50 : 0xffffd382`2af45600

SYMBOL_NAME:  BlackmagicIO+51e1f


IMAGE_NAME:  BlackmagicIO.sys

STACK_COMMAND:  .cxr; .ecxr ; kb


FAILURE_BUCKET_ID:  AV_BlackmagicIO!unknown_function

OS_VERSION:  10.0.22621.1

BUILDLAB_STR:  ni_release


OSNAME:  Windows 10

FAILURE_ID_HASH:  {6bffa081-2d07-8278-2b62-d585f8d43363}

Followup:     MachineOwner



  • Posts: 4
  • Joined: Mon Feb 13, 2017 4:45 pm
  • Real Name: Dipen Shah

Re: Decklink Quad 2 driver install gives BSOD

PostTue May 16, 2023 4:43 pm

After some additional testing, can confirm that this is a BMD driver issue, once the drivers (BMD Desktop Video) is removed, the system operates normally. With the drivers, there are issues with the integrated Intel UHD 770 and discrete graphics cards. In my case its the Intel and nVidia A2000 12GB. But as this thread seems to show, the driver issue is not limited to this combination of system hardware.

I did open a ticket, but haven't heard back. Hopefully soon.


  • Posts: 17
  • Joined: Sun Apr 23, 2023 6:50 pm
  • Real Name: Doug Floyd

Re: Decklink Quad 2 driver install gives BSOD

PostTue May 30, 2023 7:32 pm

Other people, including myself are having simililar BSOD issues with Windows 11.

See this topic for details:

So far BM support has been pretty quiet about addressing this serious Windows 11 issue! Hello, anyone there?


  • Posts: 17
  • Joined: Sun Apr 23, 2023 6:50 pm
  • Real Name: Doug Floyd

Re: Decklink Quad 2 driver install gives BSOD

PostWed Jun 14, 2023 3:58 pm

Attached is a link to a Video outlining the steps I took to identify and stop the Blackmagic software from causing Windows 11 to Crash (BSOD).

I hope this will be helpful to some of you that are experiencing this similar problem on your PC :-) ... sp=sharing

Return to Getting Started

Who is online

Users browsing this forum: Bing [Bot] and 5 guests