Old Decklink not recognized by Video Desktop utility

Getting started with a Blackmagic product? Ask questions here about setup and installation.
  • Author
  • Message
Offline

ppblais

  • Posts: 7
  • Joined: Wed Nov 07, 2012 10:18 pm
  • Real Name: Pierre Paré-Blais

Old Decklink not recognized by Video Desktop utility

PostSun Mar 22, 2020 11:30 pm

I have recently recsusitated my old online mac pro after a long period of dormance...

the computer works fine, even better then my newer Macbook Air.

It has an old Decklink Studio HD-SDI card in it. I just recently tried pugling my SDI monitor back in and realized that the desktop utility app was not recognizing it anymore, I am not sure why.

When I take a look in system info I notice it sees the card, but is marking it as having no driver installed for it... it was working fine up to a few years ago when I was still using this workstation.

The only thing that has changed since then is at somepoint I upgraded to High Sierra, which at the time was the newest OS my system could support. I have to admit I don't think I tried using the decklink since upgrading so I am wondering if that could be the issue.

I understand that both my machine and the decklink are some old piece of equipement in today's standard. But I feel like it should still work...

any thoughts on what could be wrong here?

thanks!
Attachments
Screen Shot 2020-03-22 at 7.29.06 PM.jpg
Screen Shot 2020-03-22 at 7.29.06 PM.jpg (46.34 KiB) Viewed 235 times
Screen Shot 2020-03-22 at 7.10.46 PM.jpg
Screen Shot 2020-03-22 at 7.10.46 PM.jpg (81.37 KiB) Viewed 235 times
Offline
User avatar

Xtreemtec

  • Posts: 4332
  • Joined: Wed Jan 02, 2013 11:48 am
  • Location: The Netherlands

Re: Old Decklink not recognized by Video Desktop utility

PostMon Mar 23, 2020 9:08 am

The upgrade to high sierra is where it gone wrong ;)

See this topic>> viewtopic.php?f=4&t=64943
Daniel Wittenaar .:: Xtreemtec Media Productions ::. -= www.xtreemtec.nl =-
4K OBV Trailer, ATEM TVS HD, 4M/E Broadcast Studio 4K, Constelation 8K, Hyperdeck Studio 12G, Ursa Broadcast 4K, 4K fiber converters with Sony Control
Offline

goran diffner

  • Posts: 32
  • Joined: Tue Feb 04, 2020 9:40 pm
  • Real Name: Göran Diffner

Re: Old Decklink not recognized by Video Desktop utility

PostMon Mar 23, 2020 5:53 pm

If you still have the dmg for the older mac os versions you can always back down to a version that works with the card.
Offline

ppblais

  • Posts: 7
  • Joined: Wed Nov 07, 2012 10:18 pm
  • Real Name: Pierre Paré-Blais

Re: Old Decklink not recognized by Video Desktop utility

PostTue Mar 24, 2020 3:20 am

Xtreemtec wrote:The upgrade to high sierra is where it gone wrong ;)

See this topic>> viewtopic.php?f=4&t=64943


Thank you for you reply and for pointing me in the direction of that thread! I managed to solve my problem thanks to your solution on this thread: viewtopic.php?f=4&t=68455&p=382926#p382915

I had to repeat step 1 to 3 twice, but after two uninstall/reinstall my system magically recognized my decklink again in system specs

but the latest version of desktop video still did not see it. So I tried installing version 10.4 which was mentioned in one of the post in that thread and that did it for me, restarted, and as soon as I logged back in my computer prompted to update firmware, and now everything is back to how it should be!

Thanks!

Return to Getting Started

Who is online

Users browsing this forum: No registered users and 7 guests