UltraStudio Mini Recorder Not Connecting

Getting started with a Blackmagic product? Ask questions here about setup and installation.
  • Author
  • Message


  • Posts: 1
  • Joined: Thu Jun 25, 2020 4:54 pm
  • Real Name: Phil Crosby

UltraStudio Mini Recorder Not Connecting

PostThu Jun 25, 2020 5:01 pm

Hi, I know this has been talked about loads but I can't seem to get mine working.

I have a MacMini 2020 running Catalina 10.15.5 but I can not for the life of me get the Blackmagic software to see the Mini Recorder. I've uninstalled, reinstalled multiple times (gone through the Mac security settings to allow the install), tried older versions of the software. The light on the box will not come on. I've bought a new thunderbolt cable incase it was the cable but it hasn't changed anything (The cable is connecting via an Apple TB 2 to 3 converter).

I've tried it with my older 2014 MBP with a TB 2 connector but I have the same issue. My 2014 MBP is also running Catalina 10.15.5.

I want to connect a Canon G40 camera to the Mini Recorder ultimately for live streaming but can't even get the box to be recognised.

I sent a support ticket a week ago to BM but haven't had a response.

I'd really appreciate any help anyones got, thanks in advance.

Return to Getting Started

Who is online

Users browsing this forum: No registered users and 14 guests