Page 1 of 1

DeckLink Mini Record 4K doesn't work in Unreal

PostPosted: Fri Jul 24, 2020 5:11 pm
by porpho
Hi.

I just bought a DeckLink Mini Record 4K to use with my Sony A7 III. It works great with every other software that I tried: OBS, every video meeting app, and the built-in BMD software. I'm using the HDMI port.

When I try to send the camera signal to Unreal I cannot get any image. I'm using 4.25.2 with the BMD plugin. I get to the configuration of the input, see attached, but then the MediaBundle actor shows the failure texture.

Please advise.

Re: DeckLink Mini Record 4K doesn't work in Unreal

PostPosted: Tue Jul 28, 2020 3:28 pm
by porpho
Hi.

I posted the same inquiry via the support page. Any news?

Thank you.

Re: DeckLink Mini Record 4K doesn't work in Unreal

PostPosted: Sat Aug 15, 2020 4:38 pm
by FritzII
I had the same problem. I have a Decklink Mini Recorder. I purchased an HDMI to SDI converter because I believed that this might have been part of the issue. Turns out it was not. I still could not get my video into Unreal. I have tested this fix out with HDMI in and SDI in. They both work now. It is the settings between the camera, the BMD Decklink, and Unreal. Open up your BMD Desktop Video Setup to check your configurations. On the main window there will be a video input and it will either show HDMI or SDI. Above the HDMI or SDI words there should be some numbers and letters. Mine reads right now 1080i59.94. These are the exact same settings you need to set up in Unreal in the media bundle. For your Source select your BMD capture card. Then in Configuration select you settings. Mine is HD1080 because of the input. If you have an i in your BMD Desktop settings, select Interlace. If you have a p, select Progressive. The 59.94 from the BMD Desktop Settings is your Frame Rate. If you have 60, select that, or what ever the number you have is. The next thing you need to change in your media bundle in Unreal is your Video. It is defaulted to 8 bits. Select 10 bits. This is what fixed mine. It should work for you from here. If you change your camera out put settings, you will have to go back and adjust everything.

Re: DeckLink Mini Record 4K doesn't work in Unreal

PostPosted: Tue Aug 18, 2020 5:35 pm
by porpho
Thank you for the reply, it seems that I can't get anything from BMD.

Can I ask you what camera do you use?

Re: DeckLink Mini Record 4K doesn't work in Unreal

PostPosted: Thu Sep 17, 2020 8:57 am
by Vertstream
I just tried an a7iii with a 4K mini recorder and have got an image into unreal. I am using pal though. I only had a small amount of time to look at it today but the image did look rather blown out and with the srgb setting enabled it looked better but not accurate. I may be missing something there though.

Re: DeckLink Mini Record 4K doesn't work in Unreal

PostPosted: Thu Sep 17, 2020 10:12 pm
by porpho
Really? You get some image using the MediaBundle in Unreal? That is the first bit of good news about this issue that I hear. If you have the time, could you post screenshots of your plugin settings?

Thank you.

Re: DeckLink Mini Record 4K doesn't work in Unreal

PostPosted: Sat Sep 19, 2020 12:53 pm
by Vertstream
Yep with media bundle and I can do a composite with it in composure and remote with iPhone too. I will take a photo with it all step up. U need to check 10 bit uhd 4K I was set on 25 progressive but I did see it at HD 1080 50p too. Can’t seem to just do 1080 at 25p camera is always read at 50p for some reason. I actually managed to get it to use the Sony webcam function too at first before I installed the card. Follow this tutorial but instead of just doing a media player do a media bundle instead and u might get it up and running.

Re: DeckLink Mini Record 4K doesn't work in Unreal

PostPosted: Sat Sep 19, 2020 1:08 pm
by Vertstream
B7553ECB-1562-4F07-AD1D-454769EA80D1.png
B7553ECB-1562-4F07-AD1D-454769EA80D1.png (81.6 KiB) Viewed 242 times
3D57E141-04A3-4E10-836E-5DD3650D53A5.png
3D57E141-04A3-4E10-836E-5DD3650D53A5.png (81.6 KiB) Viewed 242 times
ED0E159D-B2C4-4792-AFD8-798AFCE11C05.jpeg
ED0E159D-B2C4-4792-AFD8-798AFCE11C05.jpeg (223.36 KiB) Viewed 242 times


Here you go

Re: DeckLink Mini Record 4K doesn't work in Unreal

PostPosted: Mon Sep 21, 2020 10:21 pm
by porpho
Thank you very muh, this is a big help. Just to make sure, your camera is the A7 III, not the A7R III. Is that correct?

Re: DeckLink Mini Record 4K doesn't work in Unreal

PostPosted: Mon Sep 21, 2020 10:22 pm
by Vertstream
A7iii yes

Re: DeckLink Mini Record 4K doesn't work in Unreal

PostPosted: Tue Sep 22, 2020 2:54 am
by porpho
THANK YOU! It works! Thank you very much! It was the 10 Bit YUV configuration. I was certain that the A7 III was 8 bit and I never tried that. Where BMD support gave up, you helped so generously. I am very happy to report that it works!

I really appreciate it.

Re: DeckLink Mini Record 4K doesn't work in Unreal

PostPosted: Tue Sep 22, 2020 11:07 am
by Vertstream
Great stuff. I did check whether it would work before I bought it and heard mixed reports so was a risk but I remembered seeing this so when I did I thought I’d share as it seemed you were out of luck and I was really happy it did. A7iii is 8bit but I think it does send 422 over hdmi which isnt 10bit still but seems like the deck sees the 422 and wants to process it that way. No harm really. Prob the best value for green screen virtual production in unreal. The only downside is i don’t think the card does hemlock it u did want to use led screens eventually

Re: DeckLink Mini Record 4K doesn't work in Unreal

PostPosted: Tue Sep 22, 2020 11:10 am
by porpho
Yes, the 10 bit thing is bizarre but if it works I'm not the one to complain. At this stage I'm not concerned with genlock, I use greenscreen and the A7 III does a great job at it.

Thanks again.