Firmware compatibility with different BMD cameras

Getting started with a Blackmagic product? Ask questions here about setup and installation.
  • Author
  • Message
Offline

Ellory Yu

  • Posts: 1788
  • Joined: Wed Jul 30, 2014 5:25 pm

Firmware compatibility with different BMD cameras

PostFri Nov 20, 2020 6:20 pm

This always confuses me so can someone who has different and multiple BMD cameras provide some clarity.

I have the Pocket 6K and the UMP G2. The pocket latest firmware is 6.9.6 and the UMP G2 is at 6.5.1. If I installed the camera update software for version 6.9.6, can I use that installation to update both cameras, or do I update the firmware of the Pocket with it, then uninstall 6.9.6 and install 6.5.1 to update the UMP G2?
MSI Raider X99 MB / Intel i7 5280 6 core CPU / 2 x AMD R9 390X 8Gb GPU / 32Gb 3200 RAM / Decklink 4K Mini Monitor / 240Gb SSD OS Drive / 500Gb RAID 0 SSD Cache/Scratch Drive / 14Tb 7200rpm HDD Data Drive / Win 10 Pro 64bit / Resolve 16.2.7
Offline

Jim Simon

  • Posts: 11137
  • Joined: Fri Dec 23, 2016 1:47 am
  • Warnings: 1

Re: Firmware compatibility with different BMD cameras

PostSun Nov 22, 2020 9:37 pm

I know that for the ATEM switchers, a single Updater is used. If an update doesn't apply to the connected ATEM, it just won't show as needing an update.
Offline

Asgeir Hustad

  • Posts: 141
  • Joined: Tue Sep 26, 2017 10:13 am

Re: Firmware compatibility with different BMD cameras

PostMon Nov 23, 2020 9:08 am

It's the same for the cameras.

You install the latest version on your PC, for example 6.9.6. This will then prompt you to update your cameras to the latest version for them. I.E. Pocket to 6.9.6, and UMP to 6.5.1. No need to change versions on your PC.
Offline

Ellory Yu

  • Posts: 1788
  • Joined: Wed Jul 30, 2014 5:25 pm

Re: Firmware compatibility with different BMD cameras

PostMon Nov 23, 2020 8:51 pm

Asgeir Hustad wrote:It's the same for the cameras.

You install the latest version on your PC, for example 6.9.6. This will then prompt you to update your cameras to the latest version for them. I.E. Pocket to 6.9.6, and UMP to 6.5.1. No need to change versions on your PC.


That's convenient. Thank you for responding.
MSI Raider X99 MB / Intel i7 5280 6 core CPU / 2 x AMD R9 390X 8Gb GPU / 32Gb 3200 RAM / Decklink 4K Mini Monitor / 240Gb SSD OS Drive / 500Gb RAID 0 SSD Cache/Scratch Drive / 14Tb 7200rpm HDD Data Drive / Win 10 Pro 64bit / Resolve 16.2.7

Return to Getting Started

Who is online

Users browsing this forum: No registered users and 6 guests