Fusion doesn't detect audio for videos 47 minutes or longer

Getting started with a Blackmagic product? Ask questions here about setup and installation.
  • Author
  • Message
Offline

adamwentz

  • Posts: 15
  • Joined: Wed Oct 09, 2019 5:00 pm
  • Real Name: Adam Wentz

Fusion doesn't detect audio for videos 47 minutes or longer

PostFri Jan 29, 2021 1:56 pm

I have a collection of long H.264 MP4 video+audio files, each of which is about 3 hours. If I place any portion of that MP4 onto a timeline, either the full file or just a few seconds as a small clip, and then switch to the Fusion tab, the audio within the clip is not detected, ie no audio displayed for MediaIn1 in the keyframes panel inside fusion. And no audio is heard on playback within the same fusion tab.

However, if I create a subclip from those same media files and that subclip is approximately 46 minutes or shorter then the fusion tab properly detects the audio. If the subclip is 47 minutes or longer then fusion doesn't recognize the audio.

Also, for a subclip that is 46 minutes or shorter that properly displays audio in Fusion, if I then enable that subclip's "Use full clip extents" the audio for the clip stops being detected in the fusion tab.

FYI, each MP4 has an average bitrate of 930kbps, in case this issue is related to the clip size (bytes) rather than the clip length.

This is with Resolve 17 Beta 7 (Windows).
Last edited by adamwentz on Fri Jan 29, 2021 4:19 pm, edited 2 times in total.
Offline

Uli Plank

  • Posts: 10161
  • Joined: Fri Feb 08, 2013 2:48 am
  • Location: Germany and Indonesia

Re: Fusion doesn't detect audio for clips 47 minutes or long

PostFri Jan 29, 2021 2:36 pm

There seems to be a general problem with long mp4 files with AAC sound. I can't hear the sound if I cut such a file or a part of in into a timeline, even without going to the Fusion page. The sound is audible in the source page, but not from the timeline.
Other shorter sources with the same codecs are audible when cut into the timeline.

I can play the same file just fine in 16.2.8.
Don't approach Resolve with your expectations from other NLEs! They are all different.
Resolve Studio 17.2 and Fusion Studio 17, macOS 10.15.7
iMac 2017 Radeon Pro 580 8 GB VRAM, 32 GB RAM
2018 Mac mini 16 GB RAM, eGFX Breakway RX 580 MacOS 10.15.7
Offline

Jim Simon

  • Posts: 16429
  • Joined: Fri Dec 23, 2016 1:47 am

Re: Fusion doesn't detect audio for videos 47 minutes or lon

PostFri Jan 29, 2021 10:42 pm

What camera created the files, Adam?
Offline

adamwentz

  • Posts: 15
  • Joined: Wed Oct 09, 2019 5:00 pm
  • Real Name: Adam Wentz

Re: Fusion doesn't detect audio for videos 47 minutes or lon

PostSat Jan 30, 2021 1:22 am

Jim Simon wrote:What camera created the files, Adam?

Hi Jim - the MP4's were downloaded off YouTube (via youtube-dl).
Offline

Uli Plank

  • Posts: 10161
  • Joined: Fri Feb 08, 2013 2:48 am
  • Location: Germany and Indonesia

Re: Fusion doesn't detect audio for videos 47 minutes or lon

PostSat Jan 30, 2021 5:40 am

Mine are from German public TV official 'Mediathek' and I've been doing short excerpts for teaching purposes all the time in version 16.
Don't approach Resolve with your expectations from other NLEs! They are all different.
Resolve Studio 17.2 and Fusion Studio 17, macOS 10.15.7
iMac 2017 Radeon Pro 580 8 GB VRAM, 32 GB RAM
2018 Mac mini 16 GB RAM, eGFX Breakway RX 580 MacOS 10.15.7
Offline

Jim Simon

  • Posts: 16429
  • Joined: Fri Dec 23, 2016 1:47 am

Re: Fusion doesn't detect audio for videos 47 minutes or lon

PostSat Jan 30, 2021 2:47 pm

adamwentz wrote:the MP4's were downloaded off YouTube

Try it with proper camera originals. Report back.
Offline

Uli Plank

  • Posts: 10161
  • Joined: Fri Feb 08, 2013 2:48 am
  • Location: Germany and Indonesia

Re: Fusion doesn't detect audio for videos 47 minutes or lon

PostSat Jan 30, 2021 3:57 pm

Aren't most cameras which do mp4 overheating before reaching 48 minutes?
;-)
Don't approach Resolve with your expectations from other NLEs! They are all different.
Resolve Studio 17.2 and Fusion Studio 17, macOS 10.15.7
iMac 2017 Radeon Pro 580 8 GB VRAM, 32 GB RAM
2018 Mac mini 16 GB RAM, eGFX Breakway RX 580 MacOS 10.15.7
Offline

Jim Simon

  • Posts: 16429
  • Joined: Fri Dec 23, 2016 1:47 am

Re: Fusion doesn't detect audio for videos 47 minutes or lon

PostSat Jan 30, 2021 7:31 pm

GH5 doesn't.

Don't know about others.

But...I probably wouldn't include any H.264/5 as a "proper camera original". RAW, ProRes, DNx...those are where my head's at.
Offline

adamwentz

  • Posts: 15
  • Joined: Wed Oct 09, 2019 5:00 pm
  • Real Name: Adam Wentz

Re: Fusion doesn't detect audio for videos 47 minutes or lon

PostSat Jan 30, 2021 9:37 pm

Jim Simon wrote:
adamwentz wrote:the MP4's were downloaded off YouTube

Try it with proper camera originals. Report back.

Is there a known issue with Resolve's handling of MP4s generated by YouTube's system?
Offline

Uli Plank

  • Posts: 10161
  • Joined: Fri Feb 08, 2013 2:48 am
  • Location: Germany and Indonesia

Re: Fusion doesn't detect audio for videos 47 minutes or lon

PostSun Jan 31, 2021 3:08 am

It seems you just discovered it.
Don't approach Resolve with your expectations from other NLEs! They are all different.
Resolve Studio 17.2 and Fusion Studio 17, macOS 10.15.7
iMac 2017 Radeon Pro 580 8 GB VRAM, 32 GB RAM
2018 Mac mini 16 GB RAM, eGFX Breakway RX 580 MacOS 10.15.7

Return to Getting Started

Who is online

Users browsing this forum: No registered users and 6 guests