Page 1 of 1

Formatting SSDs as exFat under Windows 7

PostPosted: Thu Oct 04, 2012 1:49 am
by Jay Bloomfield
The BMD Hyperdeck software Version 3.5 was released today, allowing the Shuttle and Studio units to read read not only HFS SSDs, but also exFAT formatted SSDs. A couple of thoughts. First, if you are connecting an SSD to your Windows 7 PC via an external dock (USB 3, Firewire 800 or eSATA), be forewarned that the drivers for these docks may preclude formatting your SSDs as anything but NTFS from the Windows 7 GUI. You can, however open a command window (formerly called a "DOS box") and type:

format z: /fs:exfat

where "z:" is the drive letter that you have assigned the SSD partition in the Windows disk utility.

This limitation is not universal to all brands of docks, but mine (a newertechnolgy VoyagerQ, which is a common dock) does it, so there are probably others. It may also be remedied by seeing if there is a driver/firmware/software update for your specific brand of dock.

The second item is that it is common for Windows 7 to not read exFAT SSDs that have been initially formatted on a Mac. In this case always format these SSDs on a Win 7 PC first, because Macs will always read those disks.

Lastly, formatting an large capacity SSD as exFAT is going to take a long time, especially for 512 GB SSDs.

Re: Formatting SSDs as exFat under Windows 7

PostPosted: Thu Oct 04, 2012 9:43 am
by James Hope
A couple of notes with my experiences today:
1. You may have to just create a partition on the SSD using the Disk Maintenance in the Computer Management admin tool, and then Windows Explorer will pop up a format disk message box. When you format it, you should have the choice of exFAT, though YMMV.
2. The manual recommends using a quick format which was instant for me.

Re: Formatting SSDs as exFat under Windows 7

PostPosted: Thu Oct 04, 2012 11:53 pm
by Jay Bloomfield
Was the SSD in an external dock when you formatted it or connected directly to a SATA port? Not all docks will show this problem. But others have posted elsewhere that the problem exists, other than myself. BTW, I wouldn't have been able to format the SSD as exFAT via a command window, if I hadn't already created a partition and assigned it a drive letter using the Disk Maintenance utility.

Re: Formatting SSDs as exFat under Windows 7

PostPosted: Fri Oct 05, 2012 2:19 am
by James Hope
Good point. I didn't think of that.
It was in a caddy that I have lying around.

Re: Formatting SSDs as exFat under Windows 7

PostPosted: Fri Oct 19, 2012 7:21 pm
by Neil Adamson

The hyperdeck shuttle does not appear to recognise my SSD disk when formatted as exFAT.
I checked my format process as per the steps above and I don't seem to have done anything different - (Although I did delete an EFI system partition off the disk as well)

I now have an exFAT formatted SSD disk that is accessible to Windows 7, it is a blank partition with no data or name etc

I also updated to the 3.5 software and ran the update onto the shuttle and this appeared to work correctly.

But when I insert the SSD into the shuttle - the SSD light gives a desultory green flash or 2 then goes red

Any advice will be greatly appreciated as running an exFat file system would be of much greater use to me than the Mac file system is


Re: Formatting SSDs as exFat under Windows 7

PostPosted: Sat Oct 20, 2012 7:32 am
by Neil Adamson

Just to clear up the problem re: my previous post

The fault was entirely due to a user ID-10-T error - everything was working fine from the beginning - but I seemed to think that previously with HFS disks the green SSD light on the shuttle remained green once the SSD was inserted and did not go off once it established that the disk was okay.

So when this happened with exFAT I thought it was a problem.

Somehow during all the testing and trial and error stuff that I did - I must have created an MBR partition and then the device started to show red on the SSD indicator.

Only after reverting to an HFS and seeing that the SSD light went off with this format drive inserted as well did I actually think to test the shuttle by recording some footage - Damn - it worked

I went back to ExFat and with the correct GUID partition the SS indicator light on the shuttle went on and off as well but video recorded correctly.

What a waste of a few hours - brings to mind that one should always RTFM!!!


my SSD disappeared during or after format.. fix here

PostPosted: Thu Apr 04, 2013 6:14 am
by DanielDragonFilms
I bought a 256 Gb Crucial m4 laptop transfer kit. I immediately (and foolishly) did a full (and not quick format).. during formatting my SSD "disappeared" from my computer.

I rebooted, I tried enabling ACHI in my BIOS (which caused an immediate crash on boot).

I tried the SSD in 2 other computers, including an iMac. Neither computer recognized that a drive was plugged in. Nothing was working.

Then, on a hunch, I tried this advice on Crucial's website, here: ... ta-p/65215

I plugged the USB-to-SSD cable into a cell phone USB charger for 20 minutes. I unplugged it for 30 seconds.. then plugged it into the charger for at least another 20 minutes again.

I unplugged it for 30 seconds.. then plugged into my computer. This time the drive came up right away. I did a quick (instant) format. I put the drive into my Black Magic camera and voila! the camera said ready.

I did quick demo clip, and plugged into my computer. There was the data; everything seems to be working properly now.

Re: Formatting SSDs as exFat under Windows 7

PostPosted: Fri Jun 14, 2013 8:06 am
by thegridrunner
hmmm, will try and see if it corrects the problem