Page 1 of 1

Linux No Audio Troubleshooting Help Needed

PostPosted: Mon Mar 04, 2024 3:10 pm
by enorbet2
Greetings and thank you in advance for any and all suggestions or I may soon grow bald from tearing my hair out ;)

I want very much to learn DaVinci Resolve but I really do need it working on Slackware 15.0. It installed with nary a hiccup once I used "sudo" (which I never use as I prefer "su" but that failed as did launching as $User) and after I wrestled with the whole H264 debacle and transcoded to a (hard to find) compatible codec, Resolve finally loads both Video and Audio tracks, and Video plays nicely but zero audio, not even VU meter flicker.

I finally installed Rocky Linux just to compare and see if the same sound system works in Rocky to troubleshoot sound in Slackware. Video and Audio worked out of the box with Rocky with either Pulseaudio or Pipewire. I screenshotted settings in both Main and in Fairlight to make sure Bus assignments, patch I/O, etc were identical and now they are... but still no audio activity of any kind in Slackware. FWIW all other audio apps, Ardour, Audacity, SMPlayer, VLC, etc work perfectly in Slackware so the blockage or lack of activation, whatever, is all something I must be doing incorrectly in Resolve.

I know it seems a simple solution to just use Rocky Linux but the learning curve is steep enough with just video editing with such a powerful, featureful suite so I really don't want to learn an alien (to me) Distro as well. I've been using Slackware as my Main for 20+ years so I suppose I am something of an Old Dog reticent to take on too many new tricks.

Isn't there some way to get a basic output that I can get started with and play with optimizing once I am comfortable with Resolve?

Any suggestions for troubleshooting or paring down will be greatly appreciated. Thank you.

Re: Linux No Audio Troubleshooting Help Needed

PostPosted: Thu Mar 07, 2024 3:01 pm
by enorbet2
I'd still prefer to get Resolve working properly on Slackware and it baffles me why it has any difficulty since it installed without even a hiccup on Slackware, no hoops to leap through.

Audio did work on Rocky Linux out-of-the-bpx but Rocky would only install on an older PC on a spinner drive. It failed repeatedly (like 2 weeks of repeatedly) on NVME drives on my Main. I finally gave up on Rocky and accepted the leaping through a few hoops to get Resolve installed on Suse Tumbleweed.

It works perfectly there.