Intensity Pro 4K *device not detected* [SOLVED]

Getting started with a Blackmagic product? Ask questions here about setup and installation.
  • Author
  • Message


  • Posts: 3
  • Joined: Sat Mar 17, 2018 2:08 pm
  • Real Name: Chris Prey

Intensity Pro 4K *device not detected* [SOLVED]

PostSat Mar 17, 2018 2:37 pm


i hope to find some help here with a very annoying problem:

2 days ago i bought a (used) Intensity Pro 4K (Silent Edition) card, installed it in my PC yesterday and to my surprise it was working immediately as it should be (should've knocked on wood). I'm using the card for Cubase Pro as video output for scoring, and so worked with it for a couple of hours. Today, waking the PC from sleep mode, is see a Blue Screen of Death (first time since years i think), since then the card is not detected by any software anymore (incl. Desktop Video). It is recognized in the device manager though (screenshot below).

What i've tried, all without any change:

- reinstalling drivers
- reinstalling Quicktime
- reseating the card from a PCIe 4x to PCIe 8x slot
- all drivers up to date, including Windows

Does that mean the card is defective and would BM exchange it even if i bought it used ? How is it possible that it is seen in the device manager but not in the software ?
Any idea is highly appreciated, thank you!

My system:

Windows 10 LTSB 64 Bit
Mainboard: Gigabyte GA-Z170X Ultra Gaming
Intel i7 4770K
Cubase Pro 9.5.2
device manager
IntPro4k.png (53.93 KiB) Viewed 1069 times
Last edited by chris_P on Wed Mar 21, 2018 9:49 am, edited 1 time in total.


  • Posts: 3
  • Joined: Sat Mar 17, 2018 2:08 pm
  • Real Name: Chris Prey

Re: Intensity Pro 4K *device not detected*

PostWed Mar 21, 2018 9:49 am

Problem solved:

As i found in another, similar thread, this obviously occurs when you disable the blackmagic services Blackmagic Software Updater, BMDStreamingServer and DesktopVideoUpdater in the taskmanager and prevent them from autostart. As silly as this is, it was the solution. After a reboot (in my case a system restore was required) things should work well.

Return to Getting Started

Who is online

Users browsing this forum: No registered users and 13 guests