Page 1 of 1

Teranex Mini converters failing at alarming rate

PostPosted: Sun Sep 08, 2019 2:55 am
by Shane French
I have 6 Teranex mini converters (a combination of HDMI->SDI and SDI->HDMI versions). They're in a mobile production truck.

In the past year I have replaced all 6. Now I'm back on the truck and 2 more are down.

That's 8 bad in past year.

Spacing/cooling adequate (they're in two sets of the little 3-up mount, with 1U space between).

They're operated via POE from UniFi 48 switch.

There's a LOT of equipment in this truck, and none of it fails except for these converters.

What gives? Should I just find something else?

Re: Teranex Mini converters failing at alarming rate

PostPosted: Mon Sep 09, 2019 4:04 pm
by Xtreemtec
That is kind of weird. We have multiple units, SDI HDMI HDMI SDI OPTICAL HDMI etc.. Have them for 3 years now.. No issues at all, only fans that get louder..

But we power them from mains, instead off PoE. Do they work with mains after they fail over PoE? Or did the power supply die?

Re: Teranex Mini converters failing at alarming rate

PostPosted: Tue Sep 10, 2019 3:19 am
by Shane French
They stop working on AC power as well. Oddly, if plugged into POE, the switch ports they're connected to still show as as something is connected (no activity though).

They do not pass video signals though, and they're not reachable via IP/config software. Additionally, the front screens (we have the addon faceplates) go black as well.

Re: Teranex Mini converters failing at alarming rate

PostPosted: Tue Sep 10, 2019 9:41 am
by Xtreemtec
So it seems the power supply dies when you use it with PoE for an extended periode of time.

Just for test, Start running 1 or 2 new ones on mains instead of PoE and see if they survive. Mine do for couple of years now.