Lens mount Pocket Camera

The place for questions about shooting with Blackmagic Cameras.
  • Author
  • Message
Offline

markdaunt

  • Posts: 20
  • Joined: Tue Aug 13, 2013 12:51 pm

Lens mount Pocket Camera

PostTue Sep 24, 2013 9:09 pm

Finally got my Pocket Camera today, no orbs, no black dots but half my lenses don't work at the don't lock off when mounted, all work with other cameras. Anyone else had this problem?
Offline

MMedia

  • Posts: 61
  • Joined: Fri Sep 06, 2013 11:52 am

Re: Lens mount Pocket Camera

PostTue Sep 24, 2013 9:19 pm

Yes. My lenses wouldnt lock onto the lens mount.

Replacement camera sent out today.
Offline

Austin Reed

  • Posts: 52
  • Joined: Mon Aug 19, 2013 2:18 am

Re: Lens mount Pocket Camera

PostWed Sep 25, 2013 3:07 am

I don't know what lenses are giving you problems but I had a cheap fd-m4/3 adapter that didn't work so I purchased a better one(less cheap) that works. Same thing with the c-m4/3 adapter. My new C-mount to m4/3 adapter wasn't locking until I unscrewed the tiny screw. After that, "click" locked in! You can try that if yours has a tiny screw. Be careful not to loose it in case that's not the issue. I doubt that you should have mounting issues with most native micro 4/3 lenses. Be careful with adapters...

Austin
Offline

markdaunt

  • Posts: 20
  • Joined: Tue Aug 13, 2013 12:51 pm

Re: Lens mount Pocket Camera

PostWed Sep 25, 2013 12:44 pm

Panasonic 12-35, 20 and olympus 45 not working but Panasonic 7-14 is. All work on other cameras.
Offline

markdaunt

  • Posts: 20
  • Joined: Tue Aug 13, 2013 12:51 pm

Re: Lens mount Pocket Camera

PostThu Sep 26, 2013 12:21 am

`no response from either Blackmagic or my dealer, going to start getting real cross in the morning.
Offline

Chris Whitten

  • Posts: 506
  • Joined: Mon Jul 22, 2013 10:10 pm

Re: Lens mount Pocket Camera

PostThu Sep 26, 2013 1:04 am

My Lumix 14-140mm works.
Seems like a few people are having problems though.
Chris Whitten
Offline

markdaunt

  • Posts: 20
  • Joined: Tue Aug 13, 2013 12:51 pm

Re: Lens mount Pocket Camera

PostThu Sep 26, 2013 11:05 am

Think your right Chris, starting to see this pop up in other threads.
Offline

MMedia

  • Posts: 61
  • Joined: Fri Sep 06, 2013 11:52 am

Re: Lens mount Pocket Camera

PostThu Sep 26, 2013 6:46 pm

Another one with a lens mount problem? I had my camera replaced.
Offline

au8ust

  • Posts: 5
  • Joined: Thu Mar 14, 2013 5:56 am

Re: Lens mount Pocket Camera

PostSat Sep 28, 2013 1:55 am

MMedia wrote:Another one with a lens mount problem? I had my camera replaced.

You've got your camera replaced? Did that fix the mount issue?
Offline

michelemiorelli

  • Posts: 2
  • Joined: Sat Sep 28, 2013 9:39 am

Re: Lens mount Pocket Camera

PostSat Sep 28, 2013 9:41 am

Not working with leica 25mm mft, but for me work with olympus 12, 17, 45 mm
Offline

au8ust

  • Posts: 5
  • Joined: Thu Mar 14, 2013 5:56 am

Re: Lens mount Pocket Camera

PostWed Oct 30, 2013 2:54 pm

Sent my BMPCC for recalibrating and mentioned this with the tech support. However, they couldn't identify the mount issue. So nothing get fixed for the lens mount problem. :cry:
Offline

momentusstudios

  • Posts: 6
  • Joined: Wed Oct 30, 2013 3:41 pm

Re: Lens mount Pocket Camera

PostWed Oct 30, 2013 4:06 pm

au8ust wrote:
MMedia wrote:Another one with a lens mount problem? I had my camera replaced.

You've got your camera replaced? Did that fix the mount issue?

I had this same issue and had mine replaced.

Works 100% now.
Momentus Studios, LLC
Atlanta-Based Video Production
www.getmomentus.com

2 Blackmagic Pocket Cinema Cameras w/ Panasonic Lumix 12-35mm
Offline

markdaunt

  • Posts: 20
  • Joined: Tue Aug 13, 2013 12:51 pm

Re: Lens mount Pocket Camera

PostWed Oct 30, 2013 6:29 pm

Mine was repaired / adjusted.
Offline

Richard Brown

  • Posts: 73
  • Joined: Fri Apr 12, 2013 8:29 pm
  • Location: Hollywood, CA

Re: Lens mount Pocket Camera

PostWed Oct 30, 2013 11:19 pm

I found that the lens or lens mount, not the camera, can be at fault. On the Metabones C-Mount to M43 Adapter, there is a little screw which must be removed to allow the adapter to mount properly. Once cured, the adapter is flawless. I suspect many M43 lens mounts (on lenses) may have a similar issue.

I do not plan to use any M43 lenses, because with the OTHER Metabones Speed Booster adapter, I cover most of the needed focal lengths with great glass, and for the wide stuff, both Kowa and Zeiss have C-Mount solutions I plan to buy shortly with resolving power beyond that of the Pocket Camera.

Of course, the route I suggests offers ZERO automation of any kind. No professional production would ever use automation like that found in M43 lenses. Basically, auto is not good enough. Pulling focus and iris are a more expensive, but better route for production.
All Things Behind the Camera are my Art,
Baking and Making Dessert, my Passion.

Return to Cinematography

Who is online

Users browsing this forum: Howard Roll, Neil-G and 26 guests