Ursa Mini Pro Black Screen (of death?)

The place for questions about shooting with Blackmagic Cameras.
  • Author
  • Message
Offline

JacobSchuhle

  • Posts: 135
  • Joined: Mon Jul 31, 2017 8:37 pm

Ursa Mini Pro Black Screen (of death?)

PostThu Apr 15, 2021 7:35 pm

Hi guys, I think I know the answer to this but my UMP will no longer boot properly. About 50% of the time it fails to boot (the screen powers on but remains black), and the other 50% it'll boot into the UI/menu but the live image is black, and there's nothing happening on the histogram (lens cap is off, ND clear).

RMA right?
Offline
User avatar

Derfla

  • Posts: 120
  • Joined: Thu Sep 10, 2020 12:32 pm
  • Real Name: Al Rodriguez

Re: Ursa Mini Pro Black Screen (of death?)

PostFri Apr 16, 2021 2:39 pm

JacobSchuhle wrote:Hi guys, I think I know the answer to this but my UMP will no longer boot properly. About 50% of the time it fails to boot (the screen powers on but remains black), and the other 50% it'll boot into the UI/menu but the live image is black, and there's nothing happening on the histogram (lens cap is off, ND clear).

RMA right?


Sorry to hear about this. Yeah, contacting BMD is probably the best thing to do. Is this the G1 or G2? Please keep us updated. It would be good to know what to do and what the outcome is in cases like this.
Offline

JacobSchuhle

  • Posts: 135
  • Joined: Mon Jul 31, 2017 8:37 pm

Re: Ursa Mini Pro Black Screen (of death?)

PostSat Apr 17, 2021 1:58 pm

Will do! I think I've seen the same issue come up before over the years and I remember it usually being not worth fixing territory... Still it's had a good run, and I've made way more on renting it out than it cost me so I can't be too annoyed. Just luck I had a pocket with me as a backup body!

Return to Cinematography

Who is online

Users browsing this forum: Bing [Bot], Google Feedfetcher, John Griffin and 23 guests