Problem uploading to YouTube...Seems to be Davinci

Get answers to your questions about color grading, editing and finishing with DaVinci Resolve.
  • Author
  • Message
Offline

AthanasiosSgouridis

  • Posts: 16
  • Joined: Wed May 11, 2022 6:56 pm
  • Real Name: Athanasios Sgouridis

Problem uploading to YouTube...Seems to be Davinci

PostFri Aug 05, 2022 2:05 pm

Dear good people
I am trying to create youtube shorts and link them to my long videos and to do that I have to do it on my mobile phone! The problem is that when I try to upload a youtube short from my mobile I get the message
"unable to preview video"
I have tried a lot of export combinations and different aspect ratio's and each time the same message!

I have read in a forum on reddit
https://www.reddit.com/r/NewTubers/comments/viab8l/unable_to_preview_video_issue_with_yourube_shorts/ that a lot of people are having that kind of problem! Is anyone else having the same problems when trying to upload from cell phone? Does davinci knows about this problem and is there a solution?

Thank you all in advance
Thanos

I use the paid version with the latest version of Davinci 18
Offline

oscarhr

  • Posts: 1
  • Joined: Thu Sep 15, 2022 9:26 am
  • Real Name: Oscar Hernandez Rodriguez

Re: Problem uploading to YouTube...Seems to be Davinci

PostThu Sep 15, 2022 9:34 am

Hi Man, same problem here. I have the Pro Version of Davinci Resolve 18. I have to export the video and then use another program to "convert it", just to save it with the exact resolution and fps. I am not changing anything, just using another program to save the file again. A real pain in the a...
I have tried with Adobe Premier and it works without converting. It just happens when exporting with Davinci. And I have tried saving it in .mov .mp4 and many different presets. I get always: "unable to preview video".
So frustrating!
Offline
User avatar

Daz Wood

  • Posts: 440
  • Joined: Mon May 08, 2017 2:59 pm

Re: Problem uploading to YouTube...Seems to be Davinci

PostMon Oct 31, 2022 9:30 am

Are there any updates to this problem yet as I am also having this same message "unable to preview video" in YouTube when trying to add my Short YT videos. It seems to be rejects all files types from Davinci.
Thank you

Daz
Davinci Resolve Studio Version
ASUS Strix GL702ZC 17" laptop. AMD Ryzen 7 1700 (Desktop CPU), 32GB DDR4, Storage 256GB M.2 SSD, 2TB SSD, 4GB RX 580, Win10
Offline

MonsterMMORPG

  • Posts: 11
  • Joined: Fri Oct 28, 2022 6:19 pm
  • Real Name: Furkan Gözükara

Re: Problem uploading to YouTube...Seems to be Davinci

PostThu Nov 24, 2022 7:02 pm

Daz Wood wrote:Are there any updates to this problem yet as I am also having this same message "unable to preview video" in YouTube when trying to add my Short YT videos. It seems to be rejects all files types from Davinci.


I have the same problem. Anyone has found solution?
Offline

tacchan23

  • Posts: 15
  • Joined: Wed Nov 03, 2021 7:46 pm
  • Real Name: Simone Zuccagni

Re: Problem uploading to YouTube...Seems to be Davinci

PostMon Dec 05, 2022 11:19 am

I have this problems since months...
Offline

fabianus

  • Posts: 10
  • Joined: Thu Feb 02, 2023 9:49 am
  • Real Name: Fabian von Berlepsch

Re: Problem uploading to YouTube...Seems to be Davinci

PostThu Feb 02, 2023 9:50 am

same Problem here !
Anybody found a solution to this?
Offline

motordemic

  • Posts: 4
  • Joined: Wed Mar 22, 2023 6:10 pm
  • Real Name: Matthew Bott

Re: Problem uploading to YouTube...Seems to be Davinci

PostFri Apr 21, 2023 8:17 am

Same problem! Hopefully BM will sort it out :(
Offline

CharlieMo

  • Posts: 14
  • Joined: Wed Dec 16, 2020 7:36 am
  • Real Name: Charlie Mozzie

Re: Problem uploading to YouTube...Seems to be Davinci

PostFri May 19, 2023 2:53 pm

I can't believe this is still a problem. BM makes a big fuss about "VERTICAL VIDEO" but who cares if you can't actually upload it because there's something wrong with their codecs...
Offline

Geoff_C

  • Posts: 61
  • Joined: Tue Nov 15, 2022 2:25 pm
  • Real Name: Geoffrey Candy

Re: Problem uploading to YouTube...Seems to be Davinci

PostFri May 19, 2023 6:41 pm

Youtube will clearly have a file specs that must be complide with in order that you can upload. Do the files you prepare meet the required spec? Maybe use a third party tool to check you meet youtube requirements. Mediainfo (free) springs to mind. I can understand yor frustration but seriously doubt it is a BM problem.
DVResolve Studio.(18.1.3)
Sys 1 Gig Z370-HD3, i7 8086K @ 5.0 Ghz 16gb ram, 250gb SSD, 3x2Tb hd plus 1TbSSD for render cache, GTX 4060 8Gb BMIP4k video out. (PS 750W)
Drivers IGPU 31.0.101.2125, nVidia 31.0.15.3742 NLE Edius 8WG, Win 10Pro (22H2)
Offline
User avatar

visualfeast

  • Posts: 562
  • Joined: Sat May 19, 2018 6:51 pm
  • Real Name: BEN JORDAN

Re: Problem uploading to YouTube...Seems to be Davinci

PostFri May 19, 2023 8:28 pm

I've never had YouTube or Vimeo reject a video exported from Resolve. I also suspect settings are incorrect.


Sent from my iPhone using Tapatalk
•Ryzen 5950x/64G/75TB RAID/3080ti/Intensity Pro 4K/2x ProArt PA278CGV/Dell U2415/Shogun 7/HPE LTO-6/Stream Deck XL
•ZBook 17 G3/64G/Quadro M5000M
•Inspiron 16+/32G/RTX3060
Resolve Studio v18.1.2 (x2)/Windows 10 Pro 22H2
Offline

adiosped

  • Posts: 1
  • Joined: Wed Aug 09, 2023 5:29 pm
  • Real Name: Aditya Pednekar

Re: Problem uploading to YouTube...Seems to be Davinci

PostWed Aug 09, 2023 5:36 pm

I am also see the same error when uploading shorts on youtube (ie "unable to preview video")
I tried almost all the different formats and settings for exporting from Davinci resolve studio - Issue gets fixed if I take the exported video from Davinci into other editor like VN or similar software and reexport it.

Though this works, it is an unnecessary step. Please Blackmagic fix this problem for youtube shorts creators. (i'm purchased Davinci resolve studio specifically for making shorts)
Offline

Johansenfoto

  • Posts: 10
  • Joined: Sat Sep 16, 2023 1:02 pm
  • Real Name: Roger Johansen

Re: Problem uploading to YouTube...Seems to be Davinci

PostSat Sep 16, 2023 1:17 pm

Image

Here is probably the problem, DR add this QuickTime TC at files even if exported out as MP4.
And it is still the problem with newest 18.6 Studio version.
Offline

ectoruseff

  • Posts: 24
  • Joined: Tue Aug 15, 2023 7:06 pm
  • Real Name: Ecto Ruseff

Re: Problem uploading to YouTube...Seems to be Davinci

PostThu Sep 21, 2023 6:22 am

visualfeast wrote:I've never had YouTube or Vimeo reject a video exported from Resolve. I also suspect settings are incorrect.


I keep getting this error on YouTube shorts. I've tried all settings I possibly could. Can you share your settings for YT shorts, so I could test them too?
Offline

GenesisClips

  • Posts: 1
  • Joined: Wed Oct 04, 2023 2:31 pm
  • Real Name: Eric Cus

Re: Problem uploading to YouTube...Seems to be Davinci

PostSun Oct 08, 2023 4:26 pm

Please solve this issue, i have to send the clip to capcut and rerender it just so it works. I upload 20 clips a day on youtube and its a pain in the ass.
18.6 DRS is a banger, btw :mrgreen:
Offline

Philipp Nerb

  • Posts: 2
  • Joined: Mon Oct 09, 2023 5:53 pm
  • Real Name: Philipp Nerb

Re: Problem uploading to YouTube...Seems to be Davinci

PostMon Oct 09, 2023 6:03 pm

Good evening,

I seem to facing a similair problem, however cannot find a solution, even after reading through the forum: I am creating a series of videos and export them as mp4. Out of 12, 10 were exported without any problems. Two of the videos - created in the same fashion as the others are unexportable. In NO format, whatsoever. I can see the data (e.g. 7 GB), when I try to open it with Quicktime (yes, I am running on Mac), the data vanishes and I see an empty shell with 0 KB.
Quite frustrating, especialls, since the majority ran smoothly. I did two videos in one day - the first faced no problems, the second just keeps frustrating me.

Any ideas or hints as how to solve this situation? I tried all the different formats on offer by DR (using the lasted 18.6.1), all in vain.

Thank you for any helpful answer!
Offline

Peter Chamberlain

Blackmagic Design

  • Posts: 13800
  • Joined: Wed Aug 22, 2012 7:08 am

Re: Problem uploading to YouTube...Seems to be Davinci

PostWed Oct 11, 2023 6:32 am

.. ive just checked.. and it looks like the problem is related to uploading from Android phones. Is that what you are doing? I can't see reference to that above.

If you upload directly from Mac/Windows or an iPhone, I'm told it's okay.
DaVinci Resolve Product Manager
Offline

Philipp Nerb

  • Posts: 2
  • Joined: Mon Oct 09, 2023 5:53 pm
  • Real Name: Philipp Nerb

Re: Problem uploading to YouTube...Seems to be Davinci

PostWed Oct 11, 2023 10:21 am

Bildschirmfoto 2023-10-11 um 12.18.57.png
Screenshot with finished render, showing file size
Bildschirmfoto 2023-10-11 um 12.18.57.png (226.93 KiB) Viewed 3705 times
Good morning Peter,

I am not quite sure, if I understand the term "a .dra" correctly. However, I send you two screen shots, showing the "finished job" before and after trying to activate the data. Quite obviously the finished data also shows a different icon than the previous videos, that function.

Please excuse, that everything is kept in German.

Thank you for patience.
Best regards.
Offline

Johansenfoto

  • Posts: 10
  • Joined: Sat Sep 16, 2023 1:02 pm
  • Real Name: Roger Johansen

Re: Problem uploading to YouTube...Seems to be Davinci

PostWed Oct 11, 2023 12:14 pm

Yes the problem is with Android phones, but that is not the main case here since DR add a bogus ID under the main codec in a QuickTime TC format even if exported out as MP4.

Just check this screenshot where ID 3 should not been there
imgur.com/a/xfTIeOw

Not sure if this screenshot link will be shown since my last didn't
Offline

Videoneth

  • Posts: 1574
  • Joined: Fri Nov 13, 2020 11:03 pm
  • Real Name: Maxwell Allington

Re: Problem uploading to YouTube...Seems to be Davinci

PostWed Oct 11, 2023 2:36 pm

I had this problem in the past too.

The advantage of uploading a video from the YouTube app from the phone (Android in my case) is being able to select the frame that is going to be the thumbnail for the YouTube short.

You can't do that yet from the desktop with YouTube studio.

I remember trying to change every setting to see if it was the framerate that caused the problem, the resolution of the vertical video (4k vertical, 1080p vertical), the codec, the container format—nothing worked out of Resolve. Like OP, I found all the other people on Reddit and different forums with this problem with Android.

I remember seeing a video from VidIQ (or from another channel, I don't remember) about how they exported their video from Premiere, put it on their phone, uploaded it using the YouTube app, and selected the thumbnail from a frame of the video. I don't remember if they used an iPhone, but they were using Premiere for sure.
Windows 10
18.6.5
nVidia 3090 - 537.42
Offline

nikolakakis

  • Posts: 1
  • Joined: Mon Oct 23, 2023 6:32 pm
  • Real Name: Manolis Nikolakakis

Re: Problem uploading to YouTube...Seems to be Davinci

PostMon Oct 23, 2023 6:41 pm

I am a brand new user of DR Studio. I do not have any problem with Premiere, now in order to upload to Youtube from Android, which is the only way to choose a frame as a thumbnail, I need to export to a lossless format from Davinci and then export it with Handbrake or Media Encoder as a H265 vertical resolution.
Offline

Rene Mikkelsen

  • Posts: 12
  • Joined: Thu Sep 19, 2019 12:17 pm
  • Real Name: René Mikkelsen

Re: Problem uploading to YouTube...Seems to be Davinci

PostThu Nov 09, 2023 10:07 am

Same problem.
I export from DR with the YT preset - no other changes. Copy it to my phone (Samsung S22) and from there I can succesfully create Facebook and Instagram Reels, but the YT app can't show me the preview.

Sure, this could be a YT issue, but it still sucks to need to use an app like Kinemaster on my phone to convert something DR has made to make it compatible with YT..
The issue has been reported to YT as well, but no response from that side (surprise).
Offline

robwuijster

  • Posts: 79
  • Joined: Mon Feb 22, 2021 2:37 pm
  • Real Name: Rob Wuijster

Re: Problem uploading to YouTube...Seems to be Davinci

PostThu Nov 09, 2023 2:07 pm

Ran into this thread, but have a slightly different issue on top of this.

Every other Short I upload to YT will not be recognized as a Short, but as a regular video.
The only way to fix this, is to re-export the video, and upload it again.
It looks like something goes wrong with the vertical format on export?

It's annoying af.... as it is double the work.

Anyone else seeing this?

rob
Windows 11 ⊕ Resolve Studio 18.1.4 ⊕ ASUS PRIME X670E-Pro ⊕ AMD Ryzen 9-7900X ⊕ Arctic Liquid Cooler II ⊕ 64GB RAM ⊕ OS SSD Samsung 980Pro 2Tb ⊕ Cache SSD Samsung 870 EVO 1Tb ⊕ Video HD WD Blue 4Tb ⊕ Geforce RTX 3060 12Gb ⊕ BenQ SW270C ⊕ Dell U2412M
Offline

Johansenfoto

  • Posts: 10
  • Joined: Sat Sep 16, 2023 1:02 pm
  • Real Name: Roger Johansen

Re: Problem uploading to YouTube...Seems to be Davinci

PostSat Nov 11, 2023 7:44 am

robwuijster wrote:Ran into this thread, but have a slightly different issue on top of this.

Every other Short I upload to YT will not be recognized as a Short, but as a regular video.
The only way to fix this, is to re-export the video, and upload it again.
It looks like something goes wrong with the vertical format on export?
rob


For Shorts the video need to be in MP4 container (1080x1920, max 1 min long), and the problem with DR and export is that the video will be with MP4 container, but will also have MOV container-ID inside the file.
So only solution is to re-encode with a 3rd party encoder for getting rid of the bug from DR.

If you or other read my latest answer in this thread, I have mentioned it many times.
Offline

robwuijster

  • Posts: 79
  • Joined: Mon Feb 22, 2021 2:37 pm
  • Real Name: Rob Wuijster

Re: Problem uploading to YouTube...Seems to be Davinci

PostTue Nov 14, 2023 6:56 pm

Johansenfoto wrote:
robwuijster wrote:Ran into this thread, but have a slightly different issue on top of this.

Every other Short I upload to YT will not be recognized as a Short, but as a regular video.
The only way to fix this, is to re-export the video, and upload it again.
It looks like something goes wrong with the vertical format on export?
rob


For Shorts the video need to be in MP4 container (1080x1920, max 1 min long), and the problem with DR and export is that the video will be with MP4 container, but will also have MOV container-ID inside the file.
So only solution is to re-encode with a 3rd party encoder for getting rid of the bug from DR.

If you or other read my latest answer in this thread, I have mentioned it many times.


Ah.. That might explain things.
And don't be too harsh on us, some of us are not native English speakers, technical or ... a tad dyslexic.. These long threads can be hard to follow..
Windows 11 ⊕ Resolve Studio 18.1.4 ⊕ ASUS PRIME X670E-Pro ⊕ AMD Ryzen 9-7900X ⊕ Arctic Liquid Cooler II ⊕ 64GB RAM ⊕ OS SSD Samsung 980Pro 2Tb ⊕ Cache SSD Samsung 870 EVO 1Tb ⊕ Video HD WD Blue 4Tb ⊕ Geforce RTX 3060 12Gb ⊕ BenQ SW270C ⊕ Dell U2412M
Offline

Johansenfoto

  • Posts: 10
  • Joined: Sat Sep 16, 2023 1:02 pm
  • Real Name: Roger Johansen

Re: Problem uploading to YouTube...Seems to be Davinci

PostThu Nov 16, 2023 12:20 pm

robwuijster wrote:
Johansenfoto wrote:
robwuijster wrote:
Ah.. That might explain things.
And don't be too harsh on us, some of us are not native English speakers, technical or ... a tad dyslexic.. These long threads can be hard to follow..


Hehe I'm not neither a native english speaker/writer.
Offline

Johansenfoto

  • Posts: 10
  • Joined: Sat Sep 16, 2023 1:02 pm
  • Real Name: Roger Johansen

Re: Problem uploading to YouTube...Seems to be Davinci

PostThu Nov 16, 2023 3:18 pm

I have just made a video showing this problem, and I post it here so more people will see it and also maybe Black Magic will pick up the issue and fix it.

Offline

ectoruseff

  • Posts: 24
  • Joined: Tue Aug 15, 2023 7:06 pm
  • Real Name: Ecto Ruseff

Re: Problem uploading to YouTube...Seems to be Davinci

PostWed Nov 29, 2023 2:38 pm

Is there no update from BMD on this?
Offline

CougerJoe

  • Posts: 312
  • Joined: Wed Sep 18, 2019 5:15 am
  • Real Name: bob brady

Re: Problem uploading to YouTube...Seems to be Davinci

PostThu Nov 30, 2023 12:13 am

Johansenfoto wrote:
For Shorts the video need to be in MP4 container (1080x1920


That doesn't seem to be true, It may display in that resolution as a short but you don't need to upload at that resolution, but for now until they figure out their problem they may as well to not confuse things. The first short I saw after reading this is:

https://www.youtube.com/shorts/xWXD8YqfzDM

It's resolution is 2160x3000 as can be seen by the non short formatted version

Offline

SPIKER_67

  • Posts: 4
  • Joined: Sun Oct 15, 2023 4:00 am
  • Real Name: Michael DePaolo

Re: Problem uploading to YouTube...Seems to be Davinci

PostSun Dec 17, 2023 2:10 am

Johansenfoto wrote:I have just made a video showing this problem, and I post it here so more people will see it and also maybe Black Magic will pick up the issue and fix it.


Thank you for spelling it out. I've been studying on how to use 'ffmpeg' to delete that code, but to be honest, I'm not that advanced yet. This is a real problem, that a lot of people are having trouble with, and have been voicing their concerns about, so I hope the BM people can eventually get this straightened out.
Offline

Videoneth

  • Posts: 1574
  • Joined: Fri Nov 13, 2020 11:03 pm
  • Real Name: Maxwell Allington

Re: Problem uploading to YouTube...Seems to be Davinci

PostMon Dec 18, 2023 9:43 pm

SPIKER_67 wrote:
Johansenfoto wrote:I have just made a video showing this problem, and I post it here so more people will see it and also maybe Black Magic will pick up the issue and fix it.


Thank you for spelling it out. I've been studying on how to use 'ffmpeg' to delete that code, but to be honest, I'm not that advanced yet. This is a real problem, that a lot of people are having trouble with, and have been voicing their concerns about, so I hope the BM people can eventually get this straightened out.


Code: Select all
ffmpeg -i input.mp4 -map_metadata -1 -c copy output.mp4


(It's the same for a .mov file)

I'm on Windows, so what I did is to open the folder with the file, write "cmd" in the address bar of the folder, and just write this code (change the names of the input and output).

It effectively removes these metadata (the "other" seen in MediaInfo in the video of Joahnsenfoto).
And it won't transcode anything. It just makes a new file without these metadata.

I personally didn't test this method to upload a short from my phone yet.
Last edited by Videoneth on Sat Jan 06, 2024 9:54 pm, edited 1 time in total.
Windows 10
18.6.5
nVidia 3090 - 537.42
Offline

SPIKER_67

  • Posts: 4
  • Joined: Sun Oct 15, 2023 4:00 am
  • Real Name: Michael DePaolo

Re: Problem uploading to YouTube...Seems to be Davinci

PostFri Dec 29, 2023 8:09 am

That works! It removes, "other", and uploads as a short from my android without the annoying, "unable to preview video" pop up. Now, I do not have to re encode using Handbrake, or a similar program.

Thank you!!!! :)
Offline

Videoneth

  • Posts: 1574
  • Joined: Fri Nov 13, 2020 11:03 pm
  • Real Name: Maxwell Allington

Re: Problem uploading to YouTube...Seems to be Davinci

PostFri Jan 05, 2024 7:26 pm

The only problem is that the video are not HD when uploading them from the Android YouTube app
Windows 10
18.6.5
nVidia 3090 - 537.42
Online
User avatar

carlomacchiavello

  • Posts: 2565
  • Joined: Tue Aug 28, 2012 6:04 pm
  • Location: italy

Problem uploading to YouTube...Seems to be Davinci

PostSat Jan 06, 2024 9:10 pm

Seems a bit complex but did from YouTube to verify that you upload short from phone
Inviato dal mio iPhone utilizzando Tapatalk
Offline

ectoruseff

  • Posts: 24
  • Joined: Tue Aug 15, 2023 7:06 pm
  • Real Name: Ecto Ruseff

Re: Problem uploading to YouTube...Seems to be Davinci

PostTue Jan 09, 2024 11:14 am

Videoneth wrote:
SPIKER_67 wrote:
Johansenfoto wrote:I have just made a video showing this problem, and I post it here so more people will see it and also maybe Black Magic will pick up the issue and fix it.


Thank you for spelling it out. I've been studying on how to use 'ffmpeg' to delete that code, but to be honest, I'm not that advanced yet. This is a real problem, that a lot of people are having trouble with, and have been voicing their concerns about, so I hope the BM people can eventually get this straightened out.


Code: Select all
ffmpeg -i input.mp4 -map_metadata -1 -c copy output.mp4


(It's the same for a .mov file)

I'm on Windows, so what I did is to open the folder with the file, write "cmd" in the address bar of the folder, and just write this code (change the names of the input and output).

It effectively removes these metadata (the "other" seen in MediaInfo in the video of Joahnsenfoto).
And it won't transcode anything. It just makes a new file without these metadata.

I personally didn't test this method to upload a short from my phone yet.


I tested this FFMPEG command, and it worked. It doesn't cause issues anymore.
I wonder why BM is taking so long to fix this issue!
Offline

ectoruseff

  • Posts: 24
  • Joined: Tue Aug 15, 2023 7:06 pm
  • Real Name: Ecto Ruseff

Re: Problem uploading to YouTube...Seems to be Davinci

PostTue Jan 09, 2024 1:05 pm

I created a python script that would automate this process. Thanks to all the above comments.

A brief description and tutorial is also written in README.
Enjoy ;-)

Python Script: https://github.com/sayyid5416/Little-python-projects?tab=readme-ov-file#davinci-resolve-video-metadata-fix
Offline

SPIKER_67

  • Posts: 4
  • Joined: Sun Oct 15, 2023 4:00 am
  • Real Name: Michael DePaolo

Re: Problem uploading to YouTube...Seems to be Davinci

PostFri Jan 12, 2024 2:07 am

Videoneth wrote:The only problem is that the video are not HD when uploading them from the Android YouTube app


I believe a short will only appear on YouTube as an SD, BUT, I have seen some guys showing how they upload 4K shorts. The way I look at it the screen is so small, who cares....
Offline

GamerKitty Euphoric

  • Posts: 60
  • Joined: Mon May 08, 2023 8:19 pm
  • Real Name: Kat Krueger

Re: Problem uploading to YouTube...Seems to be Davinci

PostMon Jan 15, 2024 8:59 pm

Videoneth wrote:
SPIKER_67 wrote:
Johansenfoto wrote:I have just made a video showing this problem, and I post it here so more people will see it and also maybe Black Magic will pick up the issue and fix it.


Thank you for spelling it out. I've been studying on how to use 'ffmpeg' to delete that code, but to be honest, I'm not that advanced yet. This is a real problem, that a lot of people are having trouble with, and have been voicing their concerns about, so I hope the BM people can eventually get this straightened out.


Code: Select all
ffmpeg -i input.mp4 -map_metadata -1 -c copy output.mp4


(It's the same for a .mov file)

I'm on Windows, so what I did is to open the folder with the file, write "cmd" in the address bar of the folder, and just write this code (change the names of the input and output).

It effectively removes these metadata (the "other" seen in MediaInfo in the video of Joahnsenfoto).
And it won't transcode anything. It just makes a new file without these metadata.

I personally didn't test this method to upload a short from my phone yet.


I don't understand how to do this?
Offline

SPIKER_67

  • Posts: 4
  • Joined: Sun Oct 15, 2023 4:00 am
  • Real Name: Michael DePaolo

Re: Problem uploading to YouTube...Seems to be Davinci

PostMon Jan 15, 2024 9:22 pm

Thank you for spelling it out. I've been studying on how to use 'ffmpeg' to delete that code, but to be honest, I'm not that advanced yet. This is a real problem, that a lot of people are having trouble with, and have been voicing their concerns about, so I hope the BM people can eventually get this straightened out.[/quote]

Code: Select all
ffmpeg -i input.mp4 -map_metadata -1 -c copy output.mp4


(It's the same for a .mov file)

I'm on Windows, so what I did is to open the folder with the file, write "cmd" in the address bar of the folder, and just write this code (change the names of the input and output).

It effectively removes these metadata (the "other" seen in MediaInfo in the video of Joahnsenfoto).
And it won't transcode anything. It just makes a new file without these metadata.

I personally didn't test this method to upload a short from my phone yet.[/quote]

I don't understand how to do this?[/quote]

For some reason I'm not allowed to post urls here...even though they clearly have a url function...whatever..anyway..first go to YouTube, and search for, "How To Install ffmpeg". There's a bunch of vids..once you have it installed, just follow Videoneth's instructions. If you already have ffmpeg installed, and have tried to follow his instructions, and still can't get it to work, I'll help you out.
Offline

Noerde

  • Posts: 132
  • Joined: Tue Mar 30, 2021 12:37 pm
  • Real Name: Panu Artimo

Re: Problem uploading to YouTube...Seems to be Davinci

PostMon Jan 15, 2024 11:16 pm

ectoruseff wrote:I created a python script that would automate this process.


I think the same would be easier to do with a batch file in windows, or bash script in linux/macos etc.

As it's only running external program and getting a parameter from command line.

Most people don't have, don't know they have or don't want to install python and some modules just to run ffmpeg.

so the batch file could be ripmetadata.bat:

"c:\Program Files\ffmpeg\ffmpeg" -i %1 -map_metadata -1 -c copy output.mp4

and be called like
c:\data\videos\>ripmetadata original.mp4

bash script would be similar.
Offline

ectoruseff

  • Posts: 24
  • Joined: Tue Aug 15, 2023 7:06 pm
  • Real Name: Ecto Ruseff

Re: Problem uploading to YouTube...Seems to be Davinci

PostTue Jan 16, 2024 8:00 pm

Noerde wrote:
ectoruseff wrote:I created a python script that would automate this process.


I think the same would be easier to do with a batch file in windows, or bash script in linux/macos etc.

As it's only running external program and getting a parameter from command line.

Most people don't have, don't know they have or don't want to install python and some modules just to run ffmpeg.

so the batch file could be ripmetadata.bat:

"c:\Program Files\ffmpeg\ffmpeg" -i %1 -map_metadata -1 -c copy output.mp4

and be called like
c:\data\videos\>ripmetadata original.mp4

bash script would be similar.


Yes maybe idk. I use python, so I went with python. Python file would run automatically after each render, I don't have to run any script myself.
Offline
User avatar

Sir Holmes

  • Posts: 1
  • Joined: Mon Jan 29, 2024 8:00 pm
  • Real Name: Ivan Ovchinnikov

Re: Problem uploading to YouTube...Seems to be Davinci

PostMon Jan 29, 2024 9:31 pm

ectoruseff wrote:I created a python script that would automate this process

Wow, thank you! It worked for me! Here's some QA.

First I've tried to name a video in Deliver settings as yt-short instead of coded in script yt-short.mp4, assuming it'll have .mp4 format after the render anyway. But it doesn't work like this, the File Name should be with .mp4.
I thought it's worth mentioning in README.md and have even made a pull request with according changes.

Noerde wrote:I think the same would be easier to do with a batch file in windows
<...>
so the batch file could be ripmetadata.bat:

"c:\Program Files\ffmpeg\ffmpeg" -i %1 -map_metadata -1 -c copy output.mp4

and be called like
c:\data\videos\>ripmetadata original.mp4

Batch file also works, and here's alternative way to use it. Note that source video in this case should be named input.mp4.
I've created ripmetadata.bat file with the following contents:
Code: Select all
ffmpeg -i input.mp4 -map_metadata -1 -c copy output.mp4

(You don't even have to specify a path to ffmpeg.exe if it's added in Windows global PATH.)
Then putted the file into a folder with a video and ran it. It have also removed metadata.


In the end I think the Python method is more convenient (though may be more complicated in installation) as it decreases unnecessary actions like moving batch files between folders, renaming videos and launching Windows CMD\PowerShell.
Offline

Noerde

  • Posts: 132
  • Joined: Tue Mar 30, 2021 12:37 pm
  • Real Name: Panu Artimo

Re: Problem uploading to YouTube...Seems to be Davinci

PostMon Jan 29, 2024 11:12 pm

Sir Holmes wrote:I've created ripmetadata.bat file with the following contents:
Code: Select all
ffmpeg -i input.mp4 -map_metadata -1 -c copy output.mp4

(You don't even have to specify a path to ffmpeg.exe if it's added in Windows global PATH.)
Then putted the file into a folder with a video and ran it. It have also removed metadata.


In the end I think the Python method is more convenient (though may be more complicated in installation) as it decreases unnecessary actions like moving batch files between folders, renaming videos and launching Windows CMD\PowerShell.


Of course you can put the bat file where ever you like, even on your desktop and then just drag&drop the file to be cleaned on it. The code below is probably good enough for occasional fixes, but miss the protection for many cleaned up files as they all end up getting the same name. Of course the name could be processed from the original but I leave it to someone who is more interested in it :)

clean.bat
Code: Select all
@echo off
set dest_dir=t:\temp
echo Cleaning up metadata...

ffmpeg -i %1 -map_metadata -1 -c copy %dest_dir%\cleaned.mp4
echo All done! File created as %dest_dir%\cleaned.mp4
echo you can now close this window
pause

Return to DaVinci Resolve

Who is online

Users browsing this forum: Bing [Bot], Omar Mohammad and 87 guests