Tracker "Track Forward" not doing anything and DVR hangs

Get answers to your questions about color grading, editing and finishing with DaVinci Resolve.
  • Author
  • Message
Offline

canpoyrazoglu

  • Posts: 14
  • Joined: Fri Nov 23, 2018 7:23 am
  • Real Name: Can Poyrazoğlu

Tracker "Track Forward" not doing anything and DVR hangs

PostFri May 24, 2024 8:59 pm

I have a clip that I had a tracker on, which initially worked perfectly. Then I've decided to change the speed of the clip (it's a timelapse). Since the tracking got messed up, I removed the tracker in Fusion completely, and created a new one just like I always do. In this new fresh tracker, I set my tracking point, then I hit Track Forward in the beginning of the clip as normally.

Tracking should start, yet NOTHING is happening. It hangs on that frame. The UI isn't technically unresponsive but trying to anything results in the attached warning box. Hitting Yes or No doesn't matter, Resolve still is not doing anything and doesn't consume any CPU (when it does actual tracking, it consumes 900% CPU). Waiting also doesn't help.

What happened to my clip where I had perfect tracking? All I did was change the speed (from 1500% down to 800%) and re-track EXACTLY the same way by deleting the tracker and adding a new one. Restarted Resolve countless of times, and I'm about to go crazy.
Attachments
Screenshot 2024-05-24 at 23.57.50.jpg
Screenshot 2024-05-24 at 23.57.50.jpg (108.38 KiB) Viewed 482 times
Screenshot 2024-05-24 at 23.56.41.jpg
Screenshot 2024-05-24 at 23.56.41.jpg (102.63 KiB) Viewed 482 times
Offline

Jim Simon

  • Posts: 31237
  • Joined: Fri Dec 23, 2016 1:47 am

Re: Tracker "Track Forward" not doing anything and DVR hangs

PostFri May 24, 2024 9:07 pm

Try creating a Render in Place of the clip with the Speed Change. Gives Fusion something solid to work on.
My Biases:

You NEED training.
You NEED a desktop.
You NEED a calibrated (non-computer) display.
Offline

canpoyrazoglu

  • Posts: 14
  • Joined: Fri Nov 23, 2018 7:23 am
  • Real Name: Can Poyrazoğlu

Re: Tracker "Track Forward" not doing anything and DVR hangs

PostSat May 25, 2024 6:31 am

Jim Simon wrote:Try creating a Render in Place of the clip with the Speed Change. Gives Fusion something solid to work on.



Thank you Jim, that worked perfectly!

However, for future understanding, I'd love to know why it happens in the first place? e.g. is it a known bug that happens with Fusion/tracker/keyframes etc. on speed change? Just wanting to know it so I can avoid it.
Offline
User avatar

Uli Plank

  • Posts: 22446
  • Joined: Fri Feb 08, 2013 2:48 am
  • Location: Germany and Indonesia

Re: Tracker "Track Forward" not doing anything and DVR hangs

PostSat May 25, 2024 9:16 am

You are generating synthetic frames with a speed change, a pretty demanding process. Together with tracking, which is also not a trivial task, your system may be challenged too hard. A RiP is separating the tasks.
Now that the cat #19 is out of the bag, test it as much as you can and use the subforum.

Studio 18.6.6, MacOS 13.6.7, 2017 iMac, 32 GB, Radeon Pro 580
MacBook M1 Pro, 16 GPU cores, 32 GB RAM
Sonoma 14.5 with 19b3 (sandbox)
SE, UltraStudio Monitor G3
Offline

Hendrik Proosa

  • Posts: 3143
  • Joined: Wed Aug 22, 2012 6:53 am
  • Location: Estonia

Re: Tracker "Track Forward" not doing anything and DVR hangs

PostSun May 26, 2024 7:29 pm

Uli Plank wrote:You are generating synthetic frames with a speed change, a pretty demanding process. Together with tracking, which is also not a trivial task, your system may be challenged too hard. A RiP is separating the tasks.

If problem were that retime is so challenging, it would hang on the first frame of retimed clip playback. It doesn’t, as far as I read here. Tracking isn’t a freeze-worthy bottleneck with any stretch of imagination. Imho it is a misbehavior or direct bug, it has been reported in different variants for long time.
I do stuff
Offline
User avatar

Uli Plank

  • Posts: 22446
  • Joined: Fri Feb 08, 2013 2:48 am
  • Location: Germany and Indonesia

Re: Tracker "Track Forward" not doing anything and DVR hangs

PostSun May 26, 2024 11:49 pm

A crash should not happen at all. Any crash not related to defective hardware is a bug, IMHO. This one might be pointing to a memory issue.
The suggestion was only a workaround.
Now that the cat #19 is out of the bag, test it as much as you can and use the subforum.

Studio 18.6.6, MacOS 13.6.7, 2017 iMac, 32 GB, Radeon Pro 580
MacBook M1 Pro, 16 GPU cores, 32 GB RAM
Sonoma 14.5 with 19b3 (sandbox)
SE, UltraStudio Monitor G3
Offline
User avatar

Sean Nelson

  • Posts: 800
  • Joined: Sun Feb 07, 2021 9:48 pm
  • Location: Vancouver, Canada
  • Real Name: Sean Nelson

Re: Tracker "Track Forward" not doing anything and DVR hangs

PostMon May 27, 2024 2:56 am

I've had some issues with Fusion rendering when I lengthened a Fusion clip on the Edit page and forgot to adjust the "Global In/Out" parameter in a Fusion media node's Inspector panel. When Fusion gets to frames beyond the Global "out" value, there's no input for it from that node and that seems to cause some problems.
DR Studio 18.6.4 Build 6, Win10Pro x64 22H2/19045.3570
Asus C246 Pro Motherboard, Xeon E-2278G@3.4GHz, 64GB ECC RAM
GeForce 3060 12GB, "Studio" driver 512.15
OS,Library: 1TB NVMe SSD - Project,Cache: 1TB NVMe SSD

Return to DaVinci Resolve

Who is online

Users browsing this forum: Bruce Phung, franciscovaldez, shinjin and 217 guests