Disabling node crashes Davinci

Get answers to your questions about color grading, editing and finishing with DaVinci Resolve.
  • Author
  • Message
Offline
User avatar

dotkomrade

  • Posts: 42
  • Joined: Tue Sep 18, 2018 6:29 am
  • Real Name: Matthew Tapson

Disabling node crashes Davinci

PostSat Jun 01, 2019 8:55 am

I have a weird and frustrating problem that I haven't seen anyone else comment about.

If I toggle a node on and off using either the disable button on my micro panel or the keyboard shortcut, the software regularly hangs. It doesn't happen on every project, and it usually doesn't start happening in a project at first, but once the problem begins it occurs almost every time I toggle a node off and on. If I disable a node and then use undo/redo, the same crash happens.

The issue usually begins in a project when I'm toggling a node on and off quickly. Thereafter, it is pretty random. DR might crash as soon as I disable a node, or it might happen after 2 or three presses. Restarting the machine doesn't help. It happens on any type of footage - I'm usually working on Red, Arri, BM Raw, and MOVs from eg GH4/5. Node tree complexity doesn't seem to make any difference. Usually working in ACES.

It started happening in the last version of 15 and is still happening on 16b3. I uninstalled 15 and updated to 16 using the method recommended on mixinglight.

Anyone else seeing this issue? Thanks in advance.
Windows 10 Pro, i9-9900K, Radeon VII, 64Gb Ram, Decklink Mini 4K, Eizo CG247X
Resolve Studio 17b04
Offline

andi winter

  • Posts: 50
  • Joined: Fri Oct 31, 2014 1:06 pm

Re: Disabling node crashes Davinci

PostSat Jun 01, 2019 12:13 pm

i know what you are talking about! so frustrating! of course i have to toggle nodes on and off very often. and yes, sometimes it hangs and crashes. same goes for node labelling.

it is happening as you said when starting a project and turn off and on a node quickly. also every format, i also work mostly in aces.

centos bmd edition linux, tripple pascal titan x
Offline

Raphaël Thiollier

  • Posts: 16
  • Joined: Tue Sep 11, 2012 11:51 am

Re: Disabling node crashes Davinci

PostTue Jun 04, 2019 11:18 am

Same issue for me since Resolve 15.
It occurs randomly, but only after some compound node are added to the color pipeline… this is the only common factor for me (I use a lot compound nodes …)

And in fact, when it occurs to a project, it occurs on a regular base, slowing down my workflow a lot.

Hope blackmagic team finds the issue and patches it.

Best
www.raphaelthiollier.com
Offline
User avatar

dotkomrade

  • Posts: 42
  • Joined: Tue Sep 18, 2018 6:29 am
  • Real Name: Matthew Tapson

Re: Disabling node crashes Davinci

PostWed Jun 05, 2019 6:33 am

Glad I'm not the only one. Rohit has kindly offered to take a look at one of my projects so if I hear anything I'll post it here.
Windows 10 Pro, i9-9900K, Radeon VII, 64Gb Ram, Decklink Mini 4K, Eizo CG247X
Resolve Studio 17b04
Offline

Raphaël Thiollier

  • Posts: 16
  • Joined: Tue Sep 11, 2012 11:51 am

Re: Disabling node crashes Davinci

PostFri Jun 07, 2019 12:19 pm

UPDATE

After some tests on the project I'm working on (so many crashes, I had to find a solution…), I found the guilty but not the solution. It's a GPU error I think (FYI: my compute GPU is a 2080ti) because, as soon as I disable a Noise Reduction node, the issue is reduced. Not solved! Still some random crashes, but more rare.
I learned to do a Ctrl+S just before Ctrl+D (easy!) everytime now ;-)
Yes, I'm on windows 10 (but others have the same issue on Linux it seems.

Have a good day
www.raphaelthiollier.com
Offline

Rogurt

  • Posts: 54
  • Joined: Sat Nov 10, 2018 9:47 am
  • Real Name: Roger William

Re: Disabling node crashes Davinci

PostThu May 06, 2021 7:46 pm

I am having the same problem. For me it occurs when viewing multiple clips in split view. The very second I hit ALT-D resolve crashes. With only one clip in viewer I can ALT-D as often and fast as I want to - no crashing...
AMD Ryzen 9 3950X @stock water cooled
AsRock Taichi x370 mainboard, latest Chipset Drivers (NVidia), latest Bios
G.Skill TridentZ DDR4 4 x 16 GB PC4-28800
1TB System SSD + 1 TB Nvme m2
NVidia RTX2070, 461.72 studio driver
Win10.0.19042 Resolve 17.1.1

Return to DaVinci Resolve

Who is online

Users browsing this forum: Asher123, Google [Bot], Google Feedfetcher, Greg Agiannidis, panos_mts, shenrods and 80 guests