Speed Editor in 17.2 Studio

Get answers to your questions about color grading, editing and finishing with DaVinci Resolve.
  • Author
  • Message
Offline

dirk-pel

  • Posts: 118
  • Joined: Wed Aug 29, 2018 7:37 am
  • Location: Karlsruhe, Germany, Dutch origin.
  • Real Name: dirk pel

Speed Editor in 17.2 Studio

PostWed May 12, 2021 5:11 pm

Until now I use the Speed Editor without any problem under Bluetooth or with a USB-connection.
After updating to 17.2 the Bluetooth isn't working any more, only via USB it's OK.
Under Bluetooth both leds are on but nothing more happens.
Rebooting etc. changed nothing. Of course I can work with the USB but don't understand why this Bluetooth connecting is out of function.
In the pC I see that the Bluetooth Keyboard is on.

Thanks for the fantastic soft.

Dirk PEL
Intel i7-8700K, 32 GByte 3000MHz, WIN10-Pro, GeForce GTX 1070 OC, BM Intensity pro 4K, Eizo CS2420, Davinci Resolve 17.2.1 Studio, Micropanel, Speed Editor
Offline
User avatar

Sergey Mirontsev

  • Posts: 235
  • Joined: Sun Mar 12, 2017 9:18 am
  • Location: Moscow, Russia

Re: Speed Editor in 17.2 Studio

PostWed May 12, 2021 6:02 pm

dirk-pel wrote:Until now I use the Speed Editor without any problem under Bluetooth or with a USB-connection.
After updating to 17.2 the Bluetooth isn't working any more, only via USB it's OK.
Under Bluetooth both leds are on but nothing more happens.
Rebooting etc. changed nothing. Of course I can work with the USB but don't understand why this Bluetooth connecting is out of function.
In the pC I see that the Bluetooth Keyboard is on.

Thanks for the fantastic soft.

Dirk PEL

Just delete the device from Bluetooth and Add it again. Will work.
Blackmagic Design Certified Master Trainer

Blackmagic Pocket Cinema Camera (Samyang 12mm Cine, 35mm Cine)
DaVinci Resolve Studio 17.2.10012
Speed Editor 1.3
Windows 10 Pro 21H1, i7-7700, 32Gb RAM, SSD, GeForce GTX 1080 Ti 11Gb (462.59 Studio)
Offline

consean

  • Posts: 2
  • Joined: Fri Jan 15, 2021 7:29 am
  • Real Name: mark rowlands

Re: Speed Editor in 17.2 Studio

PostWed May 12, 2021 6:30 pm

Just delete the device from Bluetooth and Add it again. Will work.


I had the same problem and followed above advice. the editor now works but I can not see any battery indicator in resolve as I could before. no way to see battery life left.
Offline
User avatar

Pecusx

  • Posts: 10
  • Joined: Wed Mar 24, 2021 7:43 pm
  • Location: Poland
  • Real Name: Tomasz Pecko

Re: Speed Editor in 17.2 Studio

PostWed May 12, 2021 7:01 pm

Sergey Mirontsev wrote:Just delete the device from Bluetooth and Add it again. Will work.


Yes ... for one time :)

I must always do this after restart my computer.... and sometimes before next start Resolve.

It's ridiculous....
Resolve 17.1.1 with Speed Editor and Tangent Element-Tk
Intel Core i9-9900KF CPU - 64GB RAM - Windows 10 Pro x64 (Latest Updates)
GigaByte NVIDIA RTX 2070 8 Gig (Latest Studio Driver)
Offline

SkierEvans

  • Posts: 250
  • Joined: Wed Jan 24, 2018 9:59 pm
  • Location: Ottawa, Ontario
  • Real Name: Ron Evans

Re: Speed Editor in 17.2 Studio

PostThu May 13, 2021 1:11 am

I also updated to new firmware for Speed Editor 1.3. Removed pairing from PC and re-paired now everything works just fine.
Threadripper 1920, Gigabyte X399 DESIGNARE EX, 32G RAM, MSI 1080Ti 11G, IP4K, WIN10 Pro 21H1
Resolve Studio 17, EDIUS X, Vegas 18
Offline

mikedkelly

  • Posts: 108
  • Joined: Tue Apr 10, 2018 9:31 pm
  • Real Name: Mike Kelly

Re: Speed Editor in 17.2 Studio

PostThu May 13, 2021 2:33 am

After updating the keyboard firmware, mine works across restarts of Resolve but after a machine restart I need to remove the device from Bluetooth and re-pair. Otherwise the Bluetooth control panel shows it constantly disconnecting and reconnecting.

-----------------------
Resolve Studio 17.2.1
OS: Windows 10 Home x64, 10.0.19042 Build 19042
CPU: Intel i7-8700K
RAM: 32GB
GPU: GTX-1080 8 GB
Driver: Nvidia Studio 462.59
MB: Asus Z390-i Gaming, C: 970 Evo 500 GB, D: 970 Evo 1 TB
Offline

cyberphile

  • Posts: 27
  • Joined: Fri Mar 06, 2020 4:42 pm
  • Real Name: Jeff Gottloeb

Re: Speed Editor in 17.2 Studio

PostThu May 13, 2021 3:05 am

consean wrote:
Just delete the device from Bluetooth and Add it again. Will work.


I had the same problem and followed above advice. the editor now works but I can not see any battery indicator in resolve as I could before. no way to see battery life left.


I have the same experience. I am able to see a battery level in the Windows device settings Bluetooth page still though. I'm not sure I trust the value though. Prior to upgrading, the value shown by Davinci was different than in the device settings Bluetooth page as I recall (the old adage that a man with two watches never knows what time it is).
DR Studio 17.1
GTX 1070 8GB VRAM
Windows 10 Home 64-bit 16GB
Intel(R) Core(TM) i7-8700 CPU @ 3.20GHz, 6 Core(s), 12 Logical Processor(s)
Offline

cyberphile

  • Posts: 27
  • Joined: Fri Mar 06, 2020 4:42 pm
  • Real Name: Jeff Gottloeb

Re: Speed Editor in 17.2 Studio

PostThu May 13, 2021 3:08 am

mikedkelly wrote:After updating the keyboard firmware, mine works across restarts of Resolve but after a machine restart I need to remove the device from Bluetooth and re-pair. Otherwise the Bluetooth control panel shows it constantly disconnecting and reconnecting.


I'm not seeing that behavior. I did do a "factory reset" using the Davinci Control Panels after I upgraded the firmware when Resolve couldn't connect to it via WiFi.
DR Studio 17.1
GTX 1070 8GB VRAM
Windows 10 Home 64-bit 16GB
Intel(R) Core(TM) i7-8700 CPU @ 3.20GHz, 6 Core(s), 12 Logical Processor(s)
Offline

dirk-pel

  • Posts: 118
  • Joined: Wed Aug 29, 2018 7:37 am
  • Location: Karlsruhe, Germany, Dutch origin.
  • Real Name: dirk pel

Re: Speed Editor in 17.2 Studio

PostThu May 13, 2021 11:17 am

I can do what you have written but no possibility to get the Speed Editor on the Bluetooth connection.
This happens after the update to 17.2. I stay for the moment with the USB connection, perhaps there will be a fix for it.
Thanks
Intel i7-8700K, 32 GByte 3000MHz, WIN10-Pro, GeForce GTX 1070 OC, BM Intensity pro 4K, Eizo CS2420, Davinci Resolve 17.2.1 Studio, Micropanel, Speed Editor
Offline

cyberphile

  • Posts: 27
  • Joined: Fri Mar 06, 2020 4:42 pm
  • Real Name: Jeff Gottloeb

Re: Speed Editor in 17.2 Studio

PostThu May 13, 2021 4:54 pm

cyberphile wrote:
consean wrote:
Just delete the device from Bluetooth and Add it again. Will work.


I had the same problem and followed above advice. the editor now works but I can not see any battery indicator in resolve as I could before. no way to see battery life left.


I have the same experience. I am able to see a battery level in the Windows device settings Bluetooth page still though. I'm not sure I trust the value though. Prior to upgrading, the value shown by Davinci was different than in the device settings Bluetooth page as I recall (the old adage that a man with two watches never knows what time it is).


I did some more testing of looking for the battery level in the Resolve Preferences Control Panels. I found the display of the Speed Editor battery level to be intermittent. One time of launching Resolve, it connected rapidly with the SE and the battery level was missing. The next launching of Resolve did not connect initially with the SE so I rebooted the SE (holding the CUT and SMTH CUT buttons until the lights went out). Upon the SE rebooting (and reconnecting to Resolve), the battery level was displayed.
DR Studio 17.1
GTX 1070 8GB VRAM
Windows 10 Home 64-bit 16GB
Intel(R) Core(TM) i7-8700 CPU @ 3.20GHz, 6 Core(s), 12 Logical Processor(s)
Offline

pajamas55

  • Posts: 7
  • Joined: Wed Jul 08, 2020 3:57 pm
  • Real Name: Philip James

Re: Speed Editor in 17.2 Studio

PostFri May 14, 2021 10:16 am

I found after closing my days work and re-opening this morning, again the speed editor is not picked up. It's almost as if the new super fast start up doesn't have time to recognise it.
It's a bit of a pain if you have to disconnect and reconnect bluetooth each time.
Offline

VAsHachiRoku

  • Posts: 10
  • Joined: Tue Jan 05, 2021 4:47 am
  • Real Name: John Plate

Re: Speed Editor in 17.2 Studio

PostSat May 15, 2021 10:22 am

Speed editor battery is visible in the DaVinci Resolve Panels Setup application when plugged in via USB.

If you have windows 10 you can see the battery life from the Bluetooth settings area where you pair it.


Sent from my iPhone using Tapatalk
Offline

Ben Carlson

  • Posts: 129
  • Joined: Tue May 14, 2013 3:07 pm

Re: Speed Editor in 17.2 Studio

PostSat May 15, 2021 1:08 pm

mikedkelly wrote:After updating the keyboard firmware, mine works across restarts of Resolve but after a machine restart I need to remove the device from Bluetooth and re-pair. Otherwise the Bluetooth control panel shows it constantly disconnecting and reconnecting.

Same here - annoying
DR Studio 17.2 Win10Pro 20H2 19042.985 i7-8850H 2.6GHz - 32GB RAM;
nVidia Quadro P2000 4 GB (461.40)
OS,Library,Project: 1TB SSD - Cache & src media files: 500GB NVMe
ATEM TVS (8.5.3), VA 4k (2.5.3)
Mini Monitor & Mini Recorder (Deskt Vid 12.0)
Offline

Tomek Sadowski

  • Posts: 28
  • Joined: Sat Dec 24, 2016 3:40 am
  • Location: Warsaw, Poland

Re: Speed Editor in 17.2 Studio

PostSat May 15, 2021 8:02 pm

Ben Carlson wrote:
mikedkelly wrote:After updating the keyboard firmware, mine works across restarts of Resolve but after a machine restart I need to remove the device from Bluetooth and re-pair. Otherwise the Bluetooth control panel shows it constantly disconnecting and reconnecting.

Same here - annoying


Same here - working after re-pair , next day , does't work.
Windows control panel shows endlessly "paired, connected, paired, connected" - so it's probably problem with updated SE 1.3 firmware, and not with resolve 17.2?

Even in case when I disable and reenable BT without restarting Windows, SE requires BT repairing.

What was changed in 1.3 SE firmware, and it is possible to return to older working version??
Resolve Studio 17.2.1 | Speed Editor 1.3 | Win10Pro 20H2 | i9-9900KS | GTX1070 (462.59) | 32GB RAM
Offline

andreas97

  • Posts: 2
  • Joined: Sat May 15, 2021 1:28 pm
  • Real Name: Andreas Walther

Re: Speed Editor in 17.2 Studio

PostSat May 15, 2021 8:40 pm

Same here - working after re-pair , next day , does't work.
Windows control panel shows endlessly "paired, connected, paired, connected".

Please make an uptdate.

Best regards

Andreas
Offline

mikedkelly

  • Posts: 108
  • Joined: Tue Apr 10, 2018 9:31 pm
  • Real Name: Mike Kelly

Re: Speed Editor in 17.2 Studio

PostMon May 17, 2021 3:14 am

Can we get a confirmation from BM that this is a known issue? After sleep or a restart of my Windows PC, my Speed Editor will not reconnect over Bluetooth. It requires that I remove the device from the Bluetooth control panel and re-pair it. This was after the Resolve 17.2 update and the Speed Editor SE 1.3 firmware update.

-----------------------
Resolve Studio 17.2.1
OS: Windows 10 Home x64, 10.0.19042 Build 19042
CPU: Intel i7-8700K
RAM: 32GB
GPU: GTX-1080 8 GB
Driver: Nvidia Studio 462.59
MB: Asus Z390-i Gaming, C: 970 Evo 500 GB, D: 970 Evo 1 TB
Offline

Richard Dean

  • Posts: 123
  • Joined: Tue Jul 28, 2015 11:27 pm

Re: Speed Editor in 17.2 Studio

PostMon May 17, 2021 5:25 am

On OSX I sometimes have to hit some keys on the speed editor to wake it up.

It has totally changed the way I edit (and even adjust audio levels and audio level keyframes)

Just love the speed editor (using it on edit page).
Offline

Lexvid

  • Posts: 36
  • Joined: Sat Mar 07, 2020 10:49 am
  • Location: United Kingdom
  • Real Name: Dave McGinlay

Re: Speed Editor in 17.2 Studio

PostMon May 17, 2021 8:26 am

andreas97 wrote:Same here - working after re-pair , next day , does't work.
Windows control panel shows endlessly "paired, connected, paired, connected".

Exactly the same thing here too (as I mentioned in a separate post).
Resolve Studio 17.2
Speed Editor 1.3
AMD Ryzen 7 3700X 8-core, 32GB RAM
NVIDIA GTX 2060 Super, 8GB, Studio driver v462.31
Windows 10 (2004 build 19041.985)
Offline

dahya.mistry

  • Posts: 14
  • Joined: Wed Mar 03, 2021 5:29 pm
  • Real Name: Dahya Mistry

Re: Speed Editor in 17.2 Studio

PostTue May 18, 2021 9:49 pm

Tomek Sadowski wrote:
Same here - working after re-pair , next day , does't work.
Windows control panel shows endlessly "paired, connected, paired, connected" - so it's probably problem with updated SE 1.3 firmware, and not with resolve 17.2?

Even in case when I disable and reenable BT without restarting Windows, SE requires BT repairing.

What was changed in 1.3 SE firmware, and it is possible to return to older working version??


Same here - remove Speed editor device in Bluetooth settings in Windows -> Add it again in Windows -> Open DR and it recognises it -> re-start Windows, and DR doesn't recognise it again...sigh :-(
Offline

SkierEvans

  • Posts: 250
  • Joined: Wed Jan 24, 2018 9:59 pm
  • Location: Ottawa, Ontario
  • Real Name: Ron Evans

Re: Speed Editor in 17.2 Studio

PostWed May 19, 2021 12:12 am

I think Speed Editor goes to sleep and if it is not seen by windows it will not work in Resolve. Just seeing it in the paired list does not mean it is active it is just in the list. I touch a few keys and wait a few seconds before loading Resolve and it works fine. Not sure how long it takes before Speed Editor goes to sleep but certainly over night does it. Pressing a few keys makes it seen by Windows and then all is well.
Threadripper 1920, Gigabyte X399 DESIGNARE EX, 32G RAM, MSI 1080Ti 11G, IP4K, WIN10 Pro 21H1
Resolve Studio 17, EDIUS X, Vegas 18
Offline

Ben Carlson

  • Posts: 129
  • Joined: Tue May 14, 2013 3:07 pm

Re: Speed Editor in 17.2 Studio

PostWed May 19, 2021 8:47 am

SkierEvans wrote:I think Speed Editor goes to sleep and if it is not seen by windows it will not work in Resolve. Just seeing it in the paired list does not mean it is active it is just in the list. I touch a few keys and wait a few seconds before loading Resolve and it works fine. Not sure how long it takes before Speed Editor goes to sleep but certainly over night does it. Pressing a few keys makes it seen by Windows and then all is well.

For me, this is the pre-17.2 behaviour...since 17.2 it is necessary to systematically remove/add the device after each Windows restart
DR Studio 17.2 Win10Pro 20H2 19042.985 i7-8850H 2.6GHz - 32GB RAM;
nVidia Quadro P2000 4 GB (461.40)
OS,Library,Project: 1TB SSD - Cache & src media files: 500GB NVMe
ATEM TVS (8.5.3), VA 4k (2.5.3)
Mini Monitor & Mini Recorder (Deskt Vid 12.0)
Offline

Lexvid

  • Posts: 36
  • Joined: Sat Mar 07, 2020 10:49 am
  • Location: United Kingdom
  • Real Name: Dave McGinlay

Re: Speed Editor in 17.2 Studio

PostWed May 19, 2021 12:40 pm

To help fix this problem, perhaps people could share the Bluetooth info requested by Rohit Singhal in post #14 on this thread: viewtopic.php?f=21&t=141276
Resolve Studio 17.2
Speed Editor 1.3
AMD Ryzen 7 3700X 8-core, 32GB RAM
NVIDIA GTX 2060 Super, 8GB, Studio driver v462.31
Windows 10 (2004 build 19041.985)

Return to DaVinci Resolve

Who is online

Users browsing this forum: cmichaelsrun, drkfuture1, Google [Bot], GordRocks, lennart, metermick, Steve Fishwick and 80 guests