"Undo" doesn't work in Resolve

Get answers to your questions about color grading, editing and finishing with DaVinci Resolve.
  • Author
  • Message
Offline

Will Vazquez

  • Posts: 94
  • Joined: Thu Mar 30, 2017 7:40 pm

"Undo" doesn't work in Resolve

PostThu Oct 31, 2019 10:23 pm

I'm not sure if I'm doing something wrong, but my "undo" menu function doesn't work, not even if I use the keystrokes. It doesn't undo anything. Is this normal? I'm on a Mac... for now. This is freaking me out.
Offline

Tom Early

  • Posts: 2002
  • Joined: Wed Jul 17, 2013 11:01 am

Re: "Undo" doesn't work in Resolve

PostFri Nov 01, 2019 12:48 am

MBP2016, MacOS 11.2.3, 2.9 GHz Intel Core i7, 16 GB 2133 MHz LPDDR3,
Radeon Pro 460 4096 MB, Resolve Studio 16.2.8/17.2.1
Output: UltraStudio 4K Mini, Desktop Video 12.0
2nd GUI: 1920x1080, mostly using Dual Screen mode, Full Screen Timeline turned ON
Offline

Will Vazquez

  • Posts: 94
  • Joined: Thu Mar 30, 2017 7:40 pm

Re: "Undo" doesn't work in Resolve

PostFri Nov 01, 2019 9:23 pm

Tom Early wrote:https://forum.blackmagicdesign.com/viewtopic.php?f=21&t=90190


There's no info about "undo" in that link". Anyway, I'm done with Mac, I just built a new custom PC and everything works perfectly. I think that Resolve works A LOT better on Windows than Mac.
Offline
User avatar

Mark Foster

  • Posts: 1080
  • Joined: Tue Oct 27, 2015 10:59 am
  • Location: austria - no kangaroos +g*

Re: "Undo" doesn't work in Resolve

PostFri Nov 01, 2019 10:21 pm

Will Vazquez wrote:
..... I think that Resolve works A LOT better on Windows than Mac.


no no no
cMP 5.1 2x3,46/96GB/2x2TB 860pro/4x4TB HGST/SSD7101A 4x2TB 970evoplus/HP1344/BMD4k/Radeon VII
macOS 11.2.3

BMPCC 6k pro (7.3.1)
BMPCC 4k (7.3)+ MB speedbooster ultra 0.71 (3.60)
resolve studio 17.3.1
desktop video 12.1
intensity pro 4k
Offline

Will Vazquez

  • Posts: 94
  • Joined: Thu Mar 30, 2017 7:40 pm

Re: "Undo" doesn't work in Resolve

PostFri Nov 01, 2019 11:16 pm

Mark Foster wrote:
no no no


Have you ran Resolve on a high end Windows machine? Or is it just being in the cult of Mac thing?
Offline

Tom Early

  • Posts: 2002
  • Joined: Wed Jul 17, 2013 11:01 am

Re: "Undo" doesn't work in Resolve

PostFri Nov 01, 2019 11:24 pm

Will Vazquez wrote:There's no info about "undo" in that link".


that's not why I posted it. It says about how to submit bug reports properly. You need a lot more detail, I mean if this was a common bug in Resolve then the forum would be flooded by now. Otherwise it won't get fixed, simple as that. I'd also suggest installing a prior version of Resolve (prior to whatever version you have now, but then you haven't even said that much) and seeing if that works, then installing the current version again.
MBP2016, MacOS 11.2.3, 2.9 GHz Intel Core i7, 16 GB 2133 MHz LPDDR3,
Radeon Pro 460 4096 MB, Resolve Studio 16.2.8/17.2.1
Output: UltraStudio 4K Mini, Desktop Video 12.0
2nd GUI: 1920x1080, mostly using Dual Screen mode, Full Screen Timeline turned ON
Offline

Will Vazquez

  • Posts: 94
  • Joined: Thu Mar 30, 2017 7:40 pm

Re: "Undo" doesn't work in Resolve

PostSat Nov 02, 2019 1:04 am

Tom Early wrote:
Will Vazquez wrote:There's no info about "undo" in that link".


that's not why I posted it. It says about how to submit bug reports properly. You need a lot more detail, I mean if this was a common bug in Resolve then the forum would be flooded by now. Otherwise it won't get fixed, simple as that. I'd also suggest installing a prior version of Resolve (prior to whatever version you have now, but then you haven't even said that much) and seeing if that works, then installing the current version again.


Thanks Tom. I was mostly seeing if undo bug was affecting other users or just me with my configuration. But since I posted I finally finished my PC build and I'm not going back to the old 5,1 clunker Mac. No problems with Windows 10 and Ryzen 3700x. What a liberating experience.
Offline

Will Vazquez

  • Posts: 94
  • Joined: Thu Mar 30, 2017 7:40 pm

Re: "Undo" doesn't work in Resolve

PostMon Nov 04, 2019 7:34 pm

Well, now the Undo doesn't work in Resolve on my Windows version. I've noticed in editing, when I use the blade to cut a clip, the shift+delete. If I try to undo that cut, it does nothing. Undo doesn't work . This is a major bug.
Offline

Jim Simon

  • Posts: 18401
  • Joined: Fri Dec 23, 2016 1:47 am

Re: "Undo" doesn't work in Resolve

PostMon Nov 04, 2019 7:42 pm

Shift+Delete isn't a default shortcut.

What specific operation are you performing with that custom shortcut?
Offline

Tom Early

  • Posts: 2002
  • Joined: Wed Jul 17, 2013 11:01 am

Re: "Undo" doesn't work in Resolve

PostMon Nov 04, 2019 8:08 pm

Do you have Live Save turned on? Does Undo not work for other operations?
MBP2016, MacOS 11.2.3, 2.9 GHz Intel Core i7, 16 GB 2133 MHz LPDDR3,
Radeon Pro 460 4096 MB, Resolve Studio 16.2.8/17.2.1
Output: UltraStudio 4K Mini, Desktop Video 12.0
2nd GUI: 1920x1080, mostly using Dual Screen mode, Full Screen Timeline turned ON
Offline

mdegans

  • Posts: 66
  • Joined: Tue Oct 01, 2019 8:55 pm
  • Real Name: Michael de Gans

Re: "Undo" doesn't work in Resolve

PostMon Nov 04, 2019 8:23 pm

Resolve won't undo for me either. Specifically, curve edits are lost in the ether, but I haven't been using 16.1 for long so other thing could be broken as well.

16.1 Resolve Studio Windows

Edit: with more testing, it seems a lot more is broken with undo, like the entire color page at least. Was 16.1 tested, like at all?
Offline

Will Vazquez

  • Posts: 94
  • Joined: Thu Mar 30, 2017 7:40 pm

Re: "Undo" doesn't work in Resolve

PostMon Nov 04, 2019 9:45 pm

Jim Simon wrote:Shift+Delete isn't a default shortcut.

What specific operation are you performing with that custom shortcut?


Hey Jim,

Shift+backspace is what I meant. If you click on a clip in the timeline, and shift+backspace, it will delete the clip and eliminate the gap. But, if I undo it, it does nothing.
Offline

Will Vazquez

  • Posts: 94
  • Joined: Thu Mar 30, 2017 7:40 pm

Re: "Undo" doesn't work in Resolve

PostMon Nov 04, 2019 9:47 pm

Tom Early wrote:Do you have Live Save turned on? Does Undo not work for other operations?


No I do not have the live save on. The undo function does work for other things, just not for shift+backspace. It's horrifying. Just when I was falling in love with Resolve.
Offline

Will Vazquez

  • Posts: 94
  • Joined: Thu Mar 30, 2017 7:40 pm

Re: "Undo" doesn't work in Resolve

PostMon Nov 04, 2019 9:57 pm

I just tested and it works now, so the undo is inconsistent. AAAAAAAhhhhhhhh
Offline

mdegans

  • Posts: 66
  • Joined: Tue Oct 01, 2019 8:55 pm
  • Real Name: Michael de Gans

Re: "Undo" doesn't work in Resolve

PostMon Nov 04, 2019 9:58 pm

FWIW I do have live save on. Reverting to my last save was how I've been doing critical undos, but it's silly to have to do that.

I just updated to 16.1.1 and the problem still exists. I make adjustments to a curve, try to undo it, either with the shortcut or the menu, and nothing happens. It's infuriating.
Offline

mdegans

  • Posts: 66
  • Joined: Tue Oct 01, 2019 8:55 pm
  • Real Name: Michael de Gans

Re: "Undo" doesn't work in Resolve

PostMon Nov 04, 2019 10:02 pm

Will Vazquez wrote:
Tom Early wrote:Just when I was falling in love with Resolve.


I bought it to edit vacation footage. I'm regretting not using an earlier version. Apparently 15 wasn't a disaster and a half.
Offline

Will Vazquez

  • Posts: 94
  • Joined: Thu Mar 30, 2017 7:40 pm

Re: "Undo" doesn't work in Resolve

PostMon Nov 04, 2019 11:02 pm

mdegans wrote:FWIW I do have live save on. Reverting to my last save was how I've been doing critical undos, but it's silly to have to do that.

I just updated to 16.1.1 and the problem still exists. I make adjustments to a curve, try to undo it, either with the shortcut or the menu, and nothing happens. It's infuriating.


Thanks for the tip. I'll turn on Live Save. I hope that the Blackmagic folks are reading this thread. I sent an email to support about the undo bug but haven't heard back.
Offline

mdegans

  • Posts: 66
  • Joined: Tue Oct 01, 2019 8:55 pm
  • Real Name: Michael de Gans

Re: "Undo" doesn't work in Resolve

PostTue Nov 05, 2019 12:07 am

Will Vazquez wrote:
mdegans wrote:FWIW I do have live save on. Reverting to my last save was how I've been doing critical undos, but it's silly to have to do that.

I just updated to 16.1.1 and the problem still exists. I make adjustments to a curve, try to undo it, either with the shortcut or the menu, and nothing happens. It's infuriating.


Thanks for the tip. I'll turn on Live Save. I hope that the Blackmagic folks are reading this thread. I sent an email to support about the undo bug but haven't heard back.

I have a feeling they read the forum. In my case the problem may be related to a shared node. I double checked it was unlocked but edits would still not undo. Undoing seemed to make everything refresh, but the actual edit wasn't undone. It seems to be working again for other nodes.

Anything specific that you're doing that won't undo?
Offline

Will Vazquez

  • Posts: 94
  • Joined: Thu Mar 30, 2017 7:40 pm

Re: "Undo" doesn't work in Resolve

PostTue Nov 05, 2019 12:51 am

mdegans wrote:Anything specific that you're doing that won't undo?


Where I've experienced the undo not working, is if I cut a clip up on the timeline and delete a portion of it, and then undo, it doesn't work. It is intermittent though. Sometimes it works, and sometimes it doesn't. I love Resolve and Blackmagic, but don't understand how that simple undo feature is buggy. But then again, it's amazing that the software is so robust and fast and they added so many incredible features.

So far the undo bug hasn't popped up with a client around. C'mon Blackmagic, fix it before you make me look bad in front of a client. :)
Offline

Peter Chamberlain

Blackmagic Design

  • Posts: 10771
  • Joined: Wed Aug 22, 2012 7:08 am

Re: "Undo" doesn't work in Resolve

PostTue Nov 05, 2019 12:56 am

What does the undo list show as steps to undo?
DaVinci Resolve Product Manager
Offline

Will Vazquez

  • Posts: 94
  • Joined: Thu Mar 30, 2017 7:40 pm

Re: "Undo" doesn't work in Resolve

PostTue Nov 05, 2019 2:10 am

Peter Chamberlain wrote:What dies the undo list show as steps to undo?


I never checked the undo history when it was happening. I actually just learned now from you that there is such a function. Good to know.

The strange thing is that it doesn't happen always.
Offline

mdegans

  • Posts: 66
  • Joined: Tue Oct 01, 2019 8:55 pm
  • Real Name: Michael de Gans

Re: "Undo" doesn't work in Resolve

PostTue Nov 05, 2019 2:27 am

Will Vazquez wrote:
Peter Chamberlain wrote:What dies the undo list show as steps to undo?


I never checked the undo history when it was happening. I actually just learned now from you that there is such a function. Good to know.


Ditto. When this current render is done, and if it happens again, I will post it. For some reason, as Will reports, it's not doing it anymore. Spline edits undo now.
Offline

Jim Simon

  • Posts: 18401
  • Joined: Fri Dec 23, 2016 1:47 am

Re: "Undo" doesn't work in Resolve

PostTue Nov 05, 2019 1:59 pm

Will Vazquez wrote:If you click on a clip in the timeline, and shift+backspace, it will delete the clip and eliminate the gap. But, if I undo it, it does nothing.


OK.

I have that working here just fine in 16.1.1 for Windows.
Offline

Will Vazquez

  • Posts: 94
  • Joined: Thu Mar 30, 2017 7:40 pm

Re: "Undo" doesn't work in Resolve

PostTue Nov 05, 2019 2:46 pm

Jim Simon wrote:
Will Vazquez wrote:If you click on a clip in the timeline, and shift+backspace, it will delete the clip and eliminate the gap. But, if I undo it, it does nothing.


OK.

I have that working here just fine in 16.1.1 for Windows.


Yes, I'm running same version, but it has happened on both Mac and Windows. I'm not making this up and I'm not the only one having a problem with undo not functioning at times as others have reported here. The undo bug is intermittent. I've seen the issue especially when working on 30 minute long timelines, and toward the end. Let's hope it gets fixed.
Offline

Shrinivas Ramani

Blackmagic Design

  • Posts: 1757
  • Joined: Wed Sep 20, 2017 10:19 am

Re: "Undo" doesn't work in Resolve

PostWed Nov 06, 2019 6:17 am

Will

I'm assuming that when you say Undo doesn't work, that you hit the hotkey for undo - and nothing happens.

To rule out hotkey issues, if you are using custom key mappings, can you check if the issue happens with the default DaVinci keymapping? If you are using another input device, can you check if this happens from the keyboard?

You can keep the Undo history window open as Peter mentions above - and verify from there if the undo was applied. If the default hotkey fails, can you check if invoking Undo from the Edit menu works?

Once we know what works in your system and what doesn't, we can look to narrow down the issue.
Offline
User avatar

Jamie LeJeune

  • Posts: 1472
  • Joined: Tue Feb 26, 2013 4:33 am
  • Location: San Francisco

Re: "Undo" doesn't work in Resolve

PostWed Nov 06, 2019 6:43 am

Will Vazquez wrote:Yes, I'm running same version, but it has happened on both Mac and Windows. I'm not making this up and I'm not the only one having a problem with undo not functioning at times as others have reported here. The undo bug is intermittent. I've seen the issue especially when working on 30 minute long timelines, and toward the end. Let's hope it gets fixed.
Do you have any iZotope audio plugins applied to the clips? I've noticed with iZotope plugins like Dialogue Denoise that respond dynamically to the audio content of the clip, the plugin is actually setting values as the clips plays, and those values are recorded in the undo history in Resolve. So, it's kinda breaks the undo as it gets filled up with all value changes applied by iZotope and makes it seem that the undo function is broken.
www.cinedocs.com
http://www.imdb.com/name/nm4601572/
Offline

Will Vazquez

  • Posts: 94
  • Joined: Thu Mar 30, 2017 7:40 pm

Re: "Undo" doesn't work in Resolve

PostWed Nov 06, 2019 12:15 pm

Shrinivas Ramani wrote:Will

I'm assuming that when you say Undo doesn't work, that you hit the hotkey for undo - and nothing happens.

To rule out hotkey issues, if you are using custom key mappings, can you check if the issue happens with the default DaVinci keymapping? If you are using another input device, can you check if this happens from the keyboard?

You can keep the Undo history window open as Peter mentions above - and verify from there if the undo was applied. If the default hotkey fails, can you check if invoking Undo from the Edit menu works?

Once we know what works in your system and what doesn't, we can look to narrow down the issue.


When the "undo" bug pops up, it is not due to the keyboard. The undo function doesn't work from the edit menu either. And like I said, this happens in both Mac and PC. Next time it happens, I will take careful notes and even film the screen so as to demonstrate. I am using default keymapping. Thanks.
Offline

Will Vazquez

  • Posts: 94
  • Joined: Thu Mar 30, 2017 7:40 pm

Re: "Undo" doesn't work in Resolve

PostWed Nov 06, 2019 12:26 pm

Jamie LeJeune wrote: Do you have any iZotope audio plugins applied to the clips? I've noticed with iZotope plugins like Dialogue Denoise that respond dynamically to the audio content of the clip, the plugin is actually setting values as the clips plays, and those values are recorded in the undo history in Resolve. So, it's kinda breaks the undo as it gets filled up with all value changes applied by iZotope and makes it seem that the undo function is broken.


I do have a couple of iZotope plug-ins installed, but haven't had them applied on the timelines where the "undo" bug has occurred.

I've been using Resolve for grading for years, but only recently started using it for editing as I shot tons of BRAW footage for a client that I have been creating over 5 hours of content for. The majority of the editing experience has been great and I'm impressed with the speed and power of editing in Resolve. Except for the 6 to 8 times that I've experience the "undo" bug, Resolve has been a pleasure to edit on.
Offline

mdegans

  • Posts: 66
  • Joined: Tue Oct 01, 2019 8:55 pm
  • Real Name: Michael de Gans

Re: "Undo" doesn't work in Resolve

PostThu Nov 07, 2019 11:16 pm

I think I figured it out. For me Undo doesn't work with shared nodes, even when unlocked. I don't know if this is expected behavior or not. When pressing undo the thumbnails flash as if they're updated, but a curve, adjustment, for example, is not reverted.
Offline

timberthrax

  • Posts: 48
  • Joined: Wed Nov 07, 2018 4:26 pm
  • Real Name: Sam Garfield

Re: "Undo" doesn't work in Resolve

PostThu Dec 05, 2019 12:57 am

Jamie LeJeune wrote:Do you have any iZotope audio plugins applied to the clips? I've noticed with iZotope plugins like Dialogue Denoise that respond dynamically to the audio content of the clip, the plugin is actually setting values as the clips plays, and those values are recorded in the undo history in Resolve. So, it's kinda breaks the undo as it gets filled up with all value changes applied by iZotope and makes it seem that the undo function is broken.


I have been having mysterious undo issues as well and this was the problem for me. The workaround for voice de-noise or other ones that make adjustments on the fly is to turn off adaptive mode and use the "learn" mode instead.

Image

Image

Thanks for helping me figure it out! :)

It would be great to be able to keep plugins from spamming the undo box somehow. Is there something we could type into that mysterious advanced box in the settings? Maybe Peter knows of a way.
Offline

weccleston

  • Posts: 4
  • Joined: Tue Aug 25, 2020 1:13 pm
  • Real Name: James W Eccleston

Re: "Undo" doesn't work in Resolve

PostTue Aug 25, 2020 1:14 pm

Same issue for me as above, undo doesn't work for Shared nodes. 16.2.3 Mac
Offline
User avatar

dev_willis

  • Posts: 105
  • Joined: Sun May 03, 2020 5:14 pm
  • Location: Lebanon, TN
  • Real Name: David Willis

Re: "Undo" doesn't work in Resolve

PostFri Sep 25, 2020 12:35 pm

Same issue. Undo definitely does not work at all with shared nodes on the Color page. But it's more than just that. I've found it to be inconsistent and unreliable on the edit and Fairlight pages as well. Sometimes "undoing" will jump back multiple steps, especially when making changes to the same control, and sometimes redo does not re-do the same steps that undo just undid. E.g., I might adjust the contrast under the color wheels and then adjust the pivot as well. If I undo that it undoes both my pivot and my contrast changes together. Then when I redo it only redoes the contrast change. Or sometimes I'll change a color wheel's value a few times in a row and I want to step backward and forward through those changes to see the differences but undo goes all the way back to the very first change and then won't redo at all. This type of situation comes up pretty often. I commonly use undo/redo to A/B changes in lots of software but this practice doesn't work well in Resolve because of this inconsistent behavior.

I just learned about the history list. Moving forward, I'll start paying attention to what it says when this pops up. Currently, everything there is greyed out, including the "Open History Window" option, and the short list of actions shown are not current and is not being updated. However, the undo/redo actions are, for the moment, working properly. So it seems that history list doesn't necessarily having any bearing on the actual history.
  • Windows 10 21H1, Resolve Studio 17.3, Nvidia Studio Driver 471.68
  • Threadripper 3960X, RTX 3090 FE, 64GB RAM, 3x 980PRO SSDs
  • Threadripper 1920X, GTX 1070 Ti, 32GB RAM, 3x 960PRO SSDs
  • TrueNAS Mini XL+ 64TB media server
  • Mac Mini M1 project server
Offline

Peter Cave

  • Posts: 2631
  • Joined: Thu Aug 23, 2012 6:45 am
  • Location: Melbourne, Australia

Re: "Undo" doesn't work in Resolve

PostSat Sep 26, 2020 3:26 am

From the User Manual:

"Because DaVinci Resolve integrates so much functionality in one application, there are three separate sets of undo “stacks” to help you manage your work.
‚
The Media, Edit and Fairlight pages share the same multiple-undo stack, which lets you backtrack out of changes made in the Media Pool, the Timeline, the Metadata Editor, and the Viewers.
Each clip in the Fusion page has its own undo stack, so that you can undo changes you make to the composition of each clip, independently.
Each clip in the Color page has its own undo stack, so that you can undo changes you make to grades in each clip, independently."

To see the History List you must be on the Edit Page. This list does NOT contain Fusion or Colour Page history. You must be on the Colour Page to use the Colour Page undo stack plus it has no list available. The same applies to the Fusion Page.
Resolve 16.2.6 AND Resolve 17.3.1
Mac OSX 10.14.6, Hackintosh i7 8700 32GB RAM, Radeon RX 580 8GB
Decklink Studio 2, FSI LM1770 Monitor
Offline
User avatar

dev_willis

  • Posts: 105
  • Joined: Sun May 03, 2020 5:14 pm
  • Location: Lebanon, TN
  • Real Name: David Willis

Re: "Undo" doesn't work in Resolve

PostWed Sep 30, 2020 1:14 pm

Peter Cave wrote:To see the History List you must be on the Edit Page. This list does NOT contain Fusion or Colour Page history. You must be on the Colour Page to use the Colour Page undo stack plus it has no list available. The same applies to the Fusion Page.

Oh, okay. That's confusing but I understand now. I would never have guessed that an "undo" function would be something I needed to read a user manual to understand lol

While I'm here, I just ran into another example of screwy undo behavior on the color page. In the sharpen panel, with channels locked together, when I enter a value under "Radius" for one of the channels the same value is set for the other two channels, as expected. But if I undo this change, the channels don't go back to the previous value and they don't even keep the same value. E.g., starting from the default .5, I entered .45 for the red channel and the green and blue channels both changed to .45. But after undoing this change they were set to .5, .47 and .48 respectively even though the lock is still on and those channels were never set to those values. Using undo after resetting a control produces similarly inexplicable behavior.
  • Windows 10 21H1, Resolve Studio 17.3, Nvidia Studio Driver 471.68
  • Threadripper 3960X, RTX 3090 FE, 64GB RAM, 3x 980PRO SSDs
  • Threadripper 1920X, GTX 1070 Ti, 32GB RAM, 3x 960PRO SSDs
  • TrueNAS Mini XL+ 64TB media server
  • Mac Mini M1 project server
Offline

George Leon

  • Posts: 149
  • Joined: Sat Mar 26, 2016 1:13 pm

Re: "Undo" doesn't work in Resolve

PostSat Jul 24, 2021 7:09 pm

Undo/Redo are completely broken for me on Resolve 17.2.2 (Windows x64) as well, on both the Edit and Color page. Sometimes it works completely fine (including multiple Undos/Redos). Often I can Undo only a single step on the Color Page, and cannot redo it. And sometimes neither do anything.

Usually when it breaks, the undo steps are listed in the history, but grayed out. I don't know why they're grayed out. And usually once Undo doesn't work (or only with one step), it stays like that until you reload Resolve.

Example: I just deleted a bunch of clips & timelines in the media pool, and accidentally a clip I need. Undo worked for a single step, but the deletions happened over several steps. They are all listed in the Undo history, this time with nothing grayed out, but I still can't go back more than the first deletion step. I can click earlier steps in UI, but nothing happens:

history.jpg
history.jpg (104.53 KiB) Viewed 1538 times


Live save isn't a workaround, because it is always saving every change, so 9/10 times, when you 'Revert to last saved version' it already saved what you just accidentally did! I've lost a few things that way that took time to rebuild, and/or I have to find & load a project backup (and hope it isn't too old).

This is a horrible experience.

EDIT: it would be much more useful if 'Revert to last saved version' reverted to the last _manually_ saved version, rather than the live saved version (if live save is enabled). Otherwise you're usually not reverting any changes.
Offline
User avatar

Marc Wielage

  • Posts: 7630
  • Joined: Fri Oct 18, 2013 2:46 am
  • Location: Hollywood, USA

Re: "Undo" doesn't work in Resolve

PostSat Jul 24, 2021 11:01 pm

George Leon wrote:Undo/Redo are completely broken for me on Resolve 17.2.2 (Windows x64) as well, on both the Edit and Color page. Sometimes it works completely fine (including multiple Undos/Redos). Often I can Undo only a single step on the Color Page, and cannot redo it. And sometimes neither do anything.

One tricky thing about Undo/Redo in Resolve is that it's saved for every shot, every node, and every Edit function -- it's different depending on what node you're in. You can make a change in Shot #3, move on to Shot #10, then go back to Shot #3 and Resolve will remember the last thing you changed in Shot #3 and let you undo it. As the manual says:

Because DaVinci Resolve integrates so much functionality in one application, there are three separate sets of undo “stacks” to help you manage your work.
– The Media, Edit and Fairlight pages share the same multiple-undo stack, which lets you backtrack out of changes made in the Media Pool, the Timeline, the Metadata Editor, and the Viewers.
– Each clip in the Fusion page has its own undo stack, so that you can undo changes you make to the composition of each clip, independently.
– Each clip in the Color page has its own undo stack, so that you can undo changes you make to grades in each clip, independently.


So as you see, Undo/Redo is not so simple in Resolve, since there's a lot of "it depends" going on. When you wrap your head around what Resolve is doing, the Undos can work in most situations. If I'm about to do a really destructive operation, I might export a copy of the current session just as a double-secret backup. It's extremely rare (like never) that I have to use it, but at least it's there. Another thing I'll do is, if I'm going to do a sweeping change of a specific timeline, like a big global color change, I might make a duplicate of the timeline first and then make the change to the duplicate as an experiment. I can always revert back or just delete the duplicate if it fails.

For color, I tend to put just one function in each node, and Undo generally works for me, particularly when I try an adjustment or a look that goes too far, or goes in the wrong direction. Undo gets me back to where I started, and then I try something else. There is a logic to how it works, and it can be extremely useful (and can save you under the right circumstances).
marc wielage, csi • VP/color & workflow • chroma | hollywood
Offline
User avatar

Jamie LeJeune

  • Posts: 1472
  • Joined: Tue Feb 26, 2013 4:33 am
  • Location: San Francisco

Re: "Undo" doesn't work in Resolve

PostSun Jul 25, 2021 12:58 am

Marc Wielage wrote:every shot, every node
In Resolve undo is clip by clip, but not node by node
www.cinedocs.com
http://www.imdb.com/name/nm4601572/
Offline
User avatar

Marc Wielage

  • Posts: 7630
  • Joined: Fri Oct 18, 2013 2:46 am
  • Location: Hollywood, USA

Re: "Undo" doesn't work in Resolve

PostSun Jul 25, 2021 7:17 am

Jamie LeJeune wrote:
Marc Wielage wrote:every shot, every node
In Resolve undo is clip by clip, but not node by node

It depends on how you look at it. It remembers what changes you've done in each clip, and you can see -- node by node -- what changes were done. It's a miracle it works as well as it does.

I still have PTSD nightmares from using daVinci 2K -- the hardware-only ancestor of Resolve that was used in post up until 2009 -- where we had an Undo button that didn't actually do anything. From my perspective, I'm deliriously happy that since Resolve came out, we've had a functional Undo button at all. The glass is half-full.
marc wielage, csi • VP/color & workflow • chroma | hollywood
Offline

Jim Simon

  • Posts: 18401
  • Joined: Fri Dec 23, 2016 1:47 am

Re: "Undo" doesn't work in Resolve

PostSun Jul 25, 2021 3:21 pm

If I make a change to nodes 1 and 2 in sequence, I am unable to Undo the change in node 1 without first Undoing the change in node 2.

I think that's what Jamie meant.

Would be nice if we could, though.
Offline
User avatar

Jamie LeJeune

  • Posts: 1472
  • Joined: Tue Feb 26, 2013 4:33 am
  • Location: San Francisco

Re: "Undo" doesn't work in Resolve

PostSun Jul 25, 2021 9:12 pm

Jim Simon wrote:If I make a change to nodes 1 and 2 in sequence, I am unable to Undo the change in node 1 without first Undoing the change in node 2.

I think that's what Jamie meant.

Would be nice if we could, though.
Yes, thank you Jim, that's what I meant. While the Color page does have a separate undo stack from the Edit Page, it's not a separate stack per node.
Marc Wielage wrote: I still have PTSD nightmares from using daVinci 2K -- the hardware-only ancestor of Resolve that was used in post up until 2009 -- where we had an Undo button that didn't actually do anything. From my perspective, I'm deliriously happy that since Resolve came out, we've had a functional Undo button at all. The glass is half-full.
No undo at all would be a challenge! Yes, I am also super thankful to have all the advancements BMD has added to Resolve.
www.cinedocs.com
http://www.imdb.com/name/nm4601572/
Offline
User avatar

Marc Wielage

  • Posts: 7630
  • Joined: Fri Oct 18, 2013 2:46 am
  • Location: Hollywood, USA

Re: "Undo" doesn't work in Resolve

PostSun Jul 25, 2021 10:26 pm

Jim Simon wrote:If I make a change to nodes 1 and 2 in sequence, I am unable to Undo the change in node 1 without first Undoing the change in node 2.

That is true, though it does store virtually all of the node changes within in each shot. One thing I concede is that there's no History for Color changes: you only get the Edit History list on the Edit Page (and I think the Media Page). It might be nice to have a "color change history" on the Color Page, and that way you could pick through the changes you wanted and bypass the ones you didn't want.

Me, I'm still thrilled we have an Undo at all, so again, I think it's a "glass half-full" thing. One thing I often recommend to colorists is when they're not sure about a change they're making, make the change in a separate node. That way, if the change proves to have negative results, they can bypass that node later on -- which is kind of the same thing as an Undo.
marc wielage, csi • VP/color & workflow • chroma | hollywood
Offline

George Leon

  • Posts: 149
  • Joined: Sat Mar 26, 2016 1:13 pm

Re: "Undo" doesn't work in Resolve

PostMon Jul 26, 2021 1:04 pm

yes I was aware of the separate stacks, and see this in practice.

yet none of this explains why Undo on the same page (eg. Color) regularly breaks, even though it initially works when first loading the app. including my example, where I deleted four items in the Media Pool, all one after the other (without leaving the page) and then couid undo only one.

there are serious bugs in the Undo system and need to be looked at. if I can't trust Undo to undo a recent step, or several steps on the same page (and it frequently fails to do that), then it causes more frustration then it solves.
Offline

DJ Full

  • Posts: 1
  • Joined: Tue Aug 10, 2021 6:39 pm
  • Real Name: Maciej Błyszczak

Re: "Undo" doesn't work in Resolve

PostTue Aug 10, 2021 7:38 pm

In my case (Resolve 17.2.2 build 4) it seems it also doesn't work with shared nodes.
Let's say I create a shared node, unlock it, then add 6 control points on color curve.
Then I undo 6 times. Nothing happens. But the 7th undo undoes the creation of shared node.

So it DOES remember the undo history. It just has an "undo lock" even if a shared node is unlocked.
Also, I see the first undo in stack tries to undo a curve point, but it only moves it 1 pixel and stops.

MESS
Offline

digitalray78

  • Posts: 17
  • Joined: Sat Jul 24, 2021 11:46 pm
  • Location: Munich, Germany
  • Real Name: Ralph Rauschert

Re: "Undo" doesn't work in Resolve

PostTue Aug 17, 2021 4:26 pm

i'm just experiencing problems with the undo as well.

i'm on the color page, beginner's guide Lesson 11 Black/white, Page 337 to be exact.

Second Node is selected and when i click Color > Reset > All Grades and Nodes (like in the yellow TIP Box), all is gone and an undo doesn't do anything. The whole history is greyed out.
i tried several times to hit undo and repeated the whole process 2 times but i didn't get back the 2 nodes.

Just after writing this post entry and going back to Resolve like 5 minutes after, hitting undo works and brings back the two nodes, that i reset before.
Windows 10 64bit, Resolve Studio, Speed Editor
Senior Video Editor and Quality Assurance for TV, Cinema, Streaming Platforms, int. Movies and Series and Commercial Producer
Offline

Jim Simon

  • Posts: 18401
  • Joined: Fri Dec 23, 2016 1:47 am

Re: "Undo" doesn't work in Resolve

PostTue Aug 17, 2021 8:15 pm

Marc Wielage wrote:It might be nice to have a "color change history" on the Color Page, and that way you could pick through the changes you wanted and bypass the ones you didn't want.
You got my vote. File the FR.

Return to DaVinci Resolve

Who is online

Users browsing this forum: Google [Bot], marleyboat and 73 guests