Speed Editor keyboard: some keys not working

Get answers to your questions about color grading, editing and finishing with DaVinci Resolve.
  • Author
  • Message
Offline

Cable111

  • Posts: 6
  • Joined: Wed Apr 10, 2019 1:32 am
  • Real Name: Stephen O'Keefe

Speed Editor keyboard: some keys not working

PostTue Sep 14, 2021 3:23 pm

I am running the latest version of Resolve Studio, 17.3.1 on a PC running the latest version of Windows 10. While I have had the speed editor for several months, I finally tried it out with Studio. The keyboard is not working correctly. I found an old thread that describes exactly the same problem with earlier versions of DaVinci Resolve 17, but never saw a solution:

viewtopic.php?f=36&t=128079

Is my speed editor broken or is this a software issue?

Thanks for any help
Last edited by Cable111 on Sat Sep 18, 2021 7:07 pm, edited 1 time in total.
Resolve Studio 17.3.1
Dell XPS 8900 i7-6700, 32 GB RAM, 1 internal Samsung 850 Evo SSD, 1 external Samsung 850 Evo SSD, RTX 2070/8 GB, Win10 Home, BenQ SW271, DeckLink Mini Monitor 4K, Atomos SUMO19M
Offline
User avatar

Charles Bennett

  • Posts: 3482
  • Joined: Sat Nov 05, 2016 11:55 am
  • Location: United Kingdom

Re: Speed Editor keyboard not working

PostTue Sep 14, 2021 7:26 pm

Is it charged, and have you loaded the latest firmware? Working great here on Studio 17.3.1.
Resolve Studio 17.4
Dell XPS 8700 i7-4790 4 core, 24GB RAM, 2 x internal Samsung Evo SSDs, GTX1060/6GB (472.12 Studio), Win10 Home 19043, Speed Editor, PreSonus Faderport 1, Eizo ColorEdge CS230 + BenQ GW2270 (both calibrated)
Offline

Cable111

  • Posts: 6
  • Joined: Wed Apr 10, 2019 1:32 am
  • Real Name: Stephen O'Keefe

Re: Speed Editor keyboard not working

PostThu Sep 16, 2021 5:58 pm

The SE is charged, but regardless, I am using it connected via the USB-C port. I have not been able to get the Bluetooth connection to work either, but one problem at a time.

The firmware is 1.4 and I see no other updates. I have tried rebooting, resetting to the factory defaults, and uninstalling and reinstalling both the drivers and DR 17. I am seeing the same issues reported in the other thread from earlier this year.
Resolve Studio 17.3.1
Dell XPS 8900 i7-6700, 32 GB RAM, 1 internal Samsung 850 Evo SSD, 1 external Samsung 850 Evo SSD, RTX 2070/8 GB, Win10 Home, BenQ SW271, DeckLink Mini Monitor 4K, Atomos SUMO19M
Offline

Peter Chamberlain

Blackmagic Design

  • Posts: 11068
  • Joined: Wed Aug 22, 2012 7:08 am

Re: Speed Editor keyboard not working

PostFri Sep 17, 2021 4:17 am

Best you contact your local BMD support office, from the web page list.
https://www.blackmagicdesign.com/company/offices
DaVinci Resolve Product Manager
Offline

Cable111

  • Posts: 6
  • Joined: Wed Apr 10, 2019 1:32 am
  • Real Name: Stephen O'Keefe

Re: Speed Editor keyboard not working

PostSat Sep 18, 2021 3:47 am

Thank you. I will reach out to customer support for an RMA.

Just an FYI, I have gotten the Bluetooth connection to work, but that has not changed the behavior of the keyboard. I also tested the keyboard on a laptop with a new install of DaVinci Resolve, and again, the behavior did not change, either wired or wirelessly. I can only assume that the keyboard is faulty.
Resolve Studio 17.3.1
Dell XPS 8900 i7-6700, 32 GB RAM, 1 internal Samsung 850 Evo SSD, 1 external Samsung 850 Evo SSD, RTX 2070/8 GB, Win10 Home, BenQ SW271, DeckLink Mini Monitor 4K, Atomos SUMO19M
Offline

Nick2021

  • Posts: 81
  • Joined: Thu May 13, 2021 3:19 am
  • Real Name: Nick Zentena

Re: Speed Editor keyboard not working

PostSat Sep 18, 2021 5:37 am

Works fine here. Which page are you on?

There is a problem with the BT Windows driver not reading the battery correctly. Mine always shows 0%. Resolve itself reads it correctly at 99%

The issue means if you try using it with BT windows drops it. You also need to plug it in before you open the program.

Did you plug it in before opening the application or after?
Offline

Cable111

  • Posts: 6
  • Joined: Wed Apr 10, 2019 1:32 am
  • Real Name: Stephen O'Keefe

Re: Speed Editor keyboard not working

PostSat Sep 18, 2021 6:48 pm

I have used the SE keyboard wired or with a BT connection only. i have had it plugged in prior to launching Resolve and tested plugging it in after launching.

Once I was able to get my computer to connect via BT, I have not had any drops. I can see the SE keyboard in the Windows list of BT devices, the DaVinci Control Panels app and Resolve and all show the same level of charge. This was true on both the desktop and the laptop on which I tried the device.

The issue is that some keys work but many don't. Or in the case of the jog and scroll keys, the jog works, but once I switch to scroll, I cannot switch back to jog unless I hit the snap key. The source key does not work, but the timeline key does. The trim out key works but as trim in and the trim in key does not work. The transition key works, but not the double tap for title. The most important issue, by far, is the failure of the source key to switch over from the timeline, but the others are not acceptable.

To be clear, I am using this on the Cut page. I have used the SE on the Edit page, but the testing was done on the Cut page where all the keys should work.
Resolve Studio 17.3.1
Dell XPS 8900 i7-6700, 32 GB RAM, 1 internal Samsung 850 Evo SSD, 1 external Samsung 850 Evo SSD, RTX 2070/8 GB, Win10 Home, BenQ SW271, DeckLink Mini Monitor 4K, Atomos SUMO19M
Offline
User avatar

Charles Bennett

  • Posts: 3482
  • Joined: Sat Nov 05, 2016 11:55 am
  • Location: United Kingdom

Re: Speed Editor keyboard: some keys not working

PostSat Sep 18, 2021 9:18 pm

It's very possible you have a defective unit as all my buttons and the scroll wheel functions are working as they should in the Cut page.

As to titles, double clicking the Trans/Title key does not insert a title box on the timeline.
You add a text box by clicking on the Title menu at the top of the page and dragging the selection to the timeline, just as you would in the Edit page, and type in the title and make adjustments in the Inspector window.
Double clicking and holding down the Trans/Title key enables you to scroll through the different fonts using the scroll wheel, nothing more.
Resolve Studio 17.4
Dell XPS 8700 i7-4790 4 core, 24GB RAM, 2 x internal Samsung Evo SSDs, GTX1060/6GB (472.12 Studio), Win10 Home 19043, Speed Editor, PreSonus Faderport 1, Eizo ColorEdge CS230 + BenQ GW2270 (both calibrated)
Offline
User avatar

Charles Bennett

  • Posts: 3482
  • Joined: Sat Nov 05, 2016 11:55 am
  • Location: United Kingdom

Re: Speed Editor keyboard: some keys not working

PostSat Sep 18, 2021 9:37 pm

A quick check on the Source/Timeline function is to try the keyboard shortcut Q. Does that switch between them? If not something else is going on.

You could also try re-setting the SE by pressing the CUT, SMTH CUT, SOURCE, and TIMELINE buttons together and then letting them go.
Resolve Studio 17.4
Dell XPS 8700 i7-4790 4 core, 24GB RAM, 2 x internal Samsung Evo SSDs, GTX1060/6GB (472.12 Studio), Win10 Home 19043, Speed Editor, PreSonus Faderport 1, Eizo ColorEdge CS230 + BenQ GW2270 (both calibrated)
Offline

Cable111

  • Posts: 6
  • Joined: Wed Apr 10, 2019 1:32 am
  • Real Name: Stephen O'Keefe

Re: Speed Editor keyboard: some keys not working

PostTue Sep 21, 2021 3:10 am

Thank you for your suggestions. Unfortunately, I had tried resetting the SE by pressing the 4 buttons and by using the factory reset in Control Panels app. Neither had any effect. Q on my full keyboard does switch between the timeline and source.

As for the title, if I hold down the trans key, I can scroll through the various transitions; however, when I have a title, double clicking and holding the key down does not scroll through the fonts. Thanks for pointing out that just double clicking does not insert a title box. I should have checked but the other issues had worn out my patience.

And I can't believe I forgot to mention that the stop/play button doesn't work either.

Thank you again for the help. I hope that replacing/repairing the unit will fix the problem.
Resolve Studio 17.3.1
Dell XPS 8900 i7-6700, 32 GB RAM, 1 internal Samsung 850 Evo SSD, 1 external Samsung 850 Evo SSD, RTX 2070/8 GB, Win10 Home, BenQ SW271, DeckLink Mini Monitor 4K, Atomos SUMO19M

Return to DaVinci Resolve

Who is online

Users browsing this forum: blackproaus, Google [Bot], Google Feedfetcher, JimCricket, MarvinBarre, Peter Cave and 67 guests