Bug: Parts of image disappearing when changing sliders

Get answers to your questions about color grading, editing and finishing with DaVinci Resolve.
  • Author
  • Message
Offline

TCP786

  • Posts: 135
  • Joined: Thu Sep 16, 2021 7:05 am
  • Real Name: Cody Predum

Bug: Parts of image disappearing when changing sliders

PostWed Sep 22, 2021 10:28 am

While I was in the process of working on a composite in the Fusion page, I was changing a color value in a background node via the sliders in the inspector, and a majority of the image I was working with simply disappeared. I know it had nothing to do with the values I was selecting in the sliders, because I could get it to "un-bug" by changing and unchanging a different value in a later downstream node. I also saw the same issue when I was changing values in other nodes such as a blur node. This is super obnoxious, since it basically makes it impossible for me to adjust the color of that image while seeing it in context.

I have a video of this, but I can't post a YouTube link or attach a video file.

Has anyone else run into this? And/or does anyone have any better ideas for a work-around that makes it less difficult to do this the way I should be able to?
Offline
User avatar

TheBloke

  • Posts: 1405
  • Joined: Sat Nov 02, 2019 11:49 pm
  • Real Name: Tom Jobbins

Re: Bug: Parts of image disappearing when changing sliders

PostWed Sep 22, 2021 1:32 pm

Sounds like you're running into the regular annoyance of the Auto Proxy feature. This is a feature intended to make the operation of controls more interactive, by downscaling the image whenever a control, such as a slider, is operated.

A good idea in principle, but in practice it often just makes images look horribly blurry. Worse, it defaults to on and, even worse, in Resolve its existence is hidden. In Fusion Studio there's a nice set of buttons under the timeline where the feature can be clearly seen, and disabled:
Fusion Studio:
Image

For reasons that are not obvious to me, these buttons are hidden in Resolve behind a right-click menu. You are far from the first person to wonder why on earth images start looking like crap when controls are operated.

Simple solution:
- Right-click next to the play/rewind/forward buttons
- Untick Auto Proxy

Image
Resolve Studio 17.4 and Fusion Studio 17.4 on macOS 11.5.2

Hackintosh:: X299, Intel i9-10980XE @ 4.6 Ghz, 128GB RAM, AMD 6900XT 16GB
Monitors: 1 x 3840x2160 & 3 x 1920x1200
Audio: Behringer UMC404HD
Blackmagic Speed Editor
Offline

TCP786

  • Posts: 135
  • Joined: Thu Sep 16, 2021 7:05 am
  • Real Name: Cody Predum

Re: Bug: Parts of image disappearing when changing sliders

PostWed Sep 22, 2021 7:03 pm

Hey, thanks for the reply. I will see if that makes a difference next time I run into the issue (it doesn't happen consistently). However, what you're describing doesn't sound like what I'm seeing. I don't see the image being changed so much as I just see a small part of it, almost like there's a mask on it. Here are two screenshots of what I'm seeing. Does this look like what you've seen before with the auto proxy issue?
Attachments
bug01.png
Before the issue
bug01.png (227.86 KiB) Viewed 576 times
bug02.png
After the issue
bug02.png (215 KiB) Viewed 576 times
Offline
User avatar

TheBloke

  • Posts: 1405
  • Joined: Sat Nov 02, 2019 11:49 pm
  • Real Name: Tom Jobbins

Re: Bug: Parts of image disappearing when changing sliders

PostThu Sep 23, 2021 8:34 am

OK yeah maybe that is different. The feature I described would specifically apply as you are moving sliders only - so you drag a slider, and the image gets blurry/affected. But it would never happen when you're not actively touching the controls.

If you're seeing problems when not touching any control, then it's definitely different.

The best thing to do would be, if/when you get the problem again, make a screen recording showing:
- A full screen view of Resolve starting on the Edit page
- Show your timeline on Edit showing how your Fusion comp is used there
- Then go into Fusion, and show your full node structure in Fusion
- Then demonstrate the issue happening, showing what you see in the viewer (zoomed out enough so we can see the full image including the frame size in the top right)

Hopefully we can get an idea from that what might be happening. It could be some problem in your flow, or it could be a bug. Can't really say at this stage, although based on your initial symptoms it did sound more like a bug.

Also: detail your hardware specs and OS, and give details of your footage (resolution, codec, etc.)
Resolve Studio 17.4 and Fusion Studio 17.4 on macOS 11.5.2

Hackintosh:: X299, Intel i9-10980XE @ 4.6 Ghz, 128GB RAM, AMD 6900XT 16GB
Monitors: 1 x 3840x2160 & 3 x 1920x1200
Audio: Behringer UMC404HD
Blackmagic Speed Editor
Offline

TCP786

  • Posts: 135
  • Joined: Thu Sep 16, 2021 7:05 am
  • Real Name: Cody Predum

Re: Bug: Parts of image disappearing when changing sliders

PostThu Sep 23, 2021 8:51 am

I think I mentioned that I do have a video already, but wasn't able to post it. It doesn't include everything you asked for, but I will get one that does shortly. When I tried to add a video file (I tried .mkv, .mov, and .mp4) it said the filetype was not allowed as an attachment; I also tried uploading it to YouTube and putting the link in my post, but I was also told that I couldn't include URLs in a post. Maybe it's because I just joined the forum, but as soon as I know of a way I can share the video, I will.
Offline
User avatar

TheBloke

  • Posts: 1405
  • Joined: Sat Nov 02, 2019 11:49 pm
  • Real Name: Tom Jobbins

Re: Bug: Parts of image disappearing when changing sliders

PostThu Sep 23, 2021 8:52 am

Yeah new posters can't include links. Just put it in code tags, and/or put a space at the start like
Code: Select all
h ttps://youtube.com/blah
Resolve Studio 17.4 and Fusion Studio 17.4 on macOS 11.5.2

Hackintosh:: X299, Intel i9-10980XE @ 4.6 Ghz, 128GB RAM, AMD 6900XT 16GB
Monitors: 1 x 3840x2160 & 3 x 1920x1200
Audio: Behringer UMC404HD
Blackmagic Speed Editor
Offline

TCP786

  • Posts: 135
  • Joined: Thu Sep 16, 2021 7:05 am
  • Real Name: Cody Predum

Re: Bug: Parts of image disappearing when changing sliders

PostThu Sep 23, 2021 11:50 pm

Well, I tried to get another video including the specific things you were asking about, but the bug didn't happen again. Nevertheless, here's the original video that at least shows the problem pretty well. For what it's worth, at least I don't have to reveal to you that my timeline is as much of a mess as my node tree. Haha.

h ttps://www.youtube.com/watch?v=gn8X1HKzjgQ
Offline

TCP786

  • Posts: 135
  • Joined: Thu Sep 16, 2021 7:05 am
  • Real Name: Cody Predum

Re: Bug: Parts of image disappearing when changing sliders

PostFri Sep 24, 2021 3:14 am

Here's a better video that includes everything you originally asked for:

Offline

TCP786

  • Posts: 135
  • Joined: Thu Sep 16, 2021 7:05 am
  • Real Name: Cody Predum

Re: Bug: Parts of image disappearing when changing sliders

PostFri Sep 24, 2021 4:02 am

Oh yeah, the part that's the most obnoxious is that once the bug pops up, it affects every frame of the composition I'm working on. This might be useful info for debugging though, since I actually think it suggests that the bug is in the planar tracker node for three reasons: First, whenever I've seen it, I've had tracking data on every frame, so the change that "un-bugs" it might only be applied to the current frame's keyframe. Second, it seems to be the only node that can make the bug go away, despite multiple nodes being able to trigger the bug. And third, it seems like any change to a node that's upstream from the planar tracker causes it to happen, and any downstream nodes don't appear to trigger the issue.

Here is a video showing what I mean about the bug being on every frame:
Offline
User avatar

TheBloke

  • Posts: 1405
  • Joined: Sat Nov 02, 2019 11:49 pm
  • Real Name: Tom Jobbins

Re: Bug: Parts of image disappearing when changing sliders

PostFri Sep 24, 2021 6:15 am

Yeah it looks buggy and it looks to be centred around the Planar Tracker.

My firs thought: the bug is caused by Motion Blur. I've seen several weird MB bugs recently.

Can you try disabling Motion Blur in the Planar Tracker node and seeing if that fixes the bug / causes it to never trigger.

If it doesn't, can you make another video where you're looking at the Planar Transform node in the viewer while you do the inspector manipulations that triggers the issue.
Resolve Studio 17.4 and Fusion Studio 17.4 on macOS 11.5.2

Hackintosh:: X299, Intel i9-10980XE @ 4.6 Ghz, 128GB RAM, AMD 6900XT 16GB
Monitors: 1 x 3840x2160 & 3 x 1920x1200
Audio: Behringer UMC404HD
Blackmagic Speed Editor
Offline

TCP786

  • Posts: 135
  • Joined: Thu Sep 16, 2021 7:05 am
  • Real Name: Cody Predum

Re: Bug: Parts of image disappearing when changing sliders

PostFri Sep 24, 2021 7:32 am

Looks like in this case I hadn't been using the motion blur. I do have a regular blur node before the planar tracker, but it's behaving the same way as everything else upstream from the planar tracker in terms of triggering the bug. As for your request about another video, I don't know if I'm understanding you correctly - I don't think I can be looking at the planar tracker in the viewer while making the inspector adjustments that trigger the bug, because those changes are on other nodes, which would have to deselect the planar tracker in the viewer for me to able to see them in the inspector. Am I misunderstanding your request?
Offline
User avatar

TheBloke

  • Posts: 1405
  • Joined: Sat Nov 02, 2019 11:49 pm
  • Real Name: Tom Jobbins

Re: Bug: Parts of image disappearing when changing sliders

PostFri Sep 24, 2021 7:53 am

In your first video you seemed to have MB enabled on the Planer Tracker:
Image

But I see that in the second video, it's not enabled. So if you've got Motion Blur unticked and the issue still occurs, then it's not obviously not that.

TCP786 wrote:I don't think I can be looking at the planar tracker in the viewer while making the inspector adjustments that trigger the bug
Inspector and Viewer are different things. Select your Planar Tracker node and press 1 or 2 until you see the output of the Planar Tracker node appear in your viewer (you only have one viewer visible so I'm not sure if it's viewer 1 or 2, probably 2). The viewer selection persists regardless of what node you have selected for Inspector adjustments.

(FYI, for future reference, you can also have multiple nodes visible at once in the Inspector by clicking the little Pin icon on one or more nodes, to make them stick there even when other nodes are selected. Selecting multiple nodes at once will also make all of them appear at once in the Inspector.)
Resolve Studio 17.4 and Fusion Studio 17.4 on macOS 11.5.2

Hackintosh:: X299, Intel i9-10980XE @ 4.6 Ghz, 128GB RAM, AMD 6900XT 16GB
Monitors: 1 x 3840x2160 & 3 x 1920x1200
Audio: Behringer UMC404HD
Blackmagic Speed Editor
Offline

TCP786

  • Posts: 135
  • Joined: Thu Sep 16, 2021 7:05 am
  • Real Name: Cody Predum

Re: Bug: Parts of image disappearing when changing sliders

PostFri Sep 24, 2021 8:16 am

Oh, sorry, I did know about that, just got confused between showing a node's output in the viewer and having that node's tool handles visible in the viewer. Also thanks for letting me know about that pin feature; I was hoping DaVinci had something like that, but hadn't found it yet.

Here's the video you asked for. About halfway through I switch the viewers to the MediaOut output, just to show that within the planar tracker node, the image jumps in and out of the bugged state, while in MediaOut it stays in the bugged state.

Offline
User avatar

TheBloke

  • Posts: 1405
  • Joined: Sat Nov 02, 2019 11:49 pm
  • Real Name: Tom Jobbins

Re: Bug: Parts of image disappearing when changing sliders

PostFri Sep 24, 2021 8:26 am

OK now can you:
- File -> Export -> Fusion Composition
- Save this somewhere accessible - it'll create a .comp file
- Zip that comp file
- Attach it here

This does not copy any media, it just copies your exact node layout. Then I can examine the node settings in detail.

I've seen a bug/issue with the Planar Tracker that relates to the size of the image it's overlaying. This may or may not be the same, I'm not quite sure.

Also: please tell me the resolutions of all the MediaIn nodes. I can see a MediaIn1 and a MedianIn4 - not sure if MediaIn2 and 3 still exist? You can check the resolution in Fusion by putting each MediaIn into the Viewer, then looking in the top right where it'll display the resolution, eg 1920x1080 or whatever. Give me the resolution for each one individually.

With all that info hopefully I can recreate the issue here and then see what might be done about it.
Resolve Studio 17.4 and Fusion Studio 17.4 on macOS 11.5.2

Hackintosh:: X299, Intel i9-10980XE @ 4.6 Ghz, 128GB RAM, AMD 6900XT 16GB
Monitors: 1 x 3840x2160 & 3 x 1920x1200
Audio: Behringer UMC404HD
Blackmagic Speed Editor
Offline

TCP786

  • Posts: 135
  • Joined: Thu Sep 16, 2021 7:05 am
  • Real Name: Cody Predum

Re: Bug: Parts of image disappearing when changing sliders

PostFri Sep 24, 2021 1:15 pm

Here you go.
Attachments
Corner pin bug comp01.zip
(24.3 KiB) Downloaded 7 times
Offline

TCP786

  • Posts: 135
  • Joined: Thu Sep 16, 2021 7:05 am
  • Real Name: Cody Predum

Re: Bug: Parts of image disappearing when changing sliders

PostFri Sep 24, 2021 1:32 pm

Oh, sorry, resolutions.

These are the ones that are used:
MediaIn1: 4096x2160
MediaIn4: 4397x1337

These are still in the node tree, but not connected to anything (old temps):
MediaIn2: 1080x540
MediaIn3: 800x800
MediaIn2_1: 1080x540

All 32bit float.
Offline
User avatar

TheBloke

  • Posts: 1405
  • Joined: Sat Nov 02, 2019 11:49 pm
  • Real Name: Tom Jobbins

Re: Bug: Parts of image disappearing when changing sliders

PostFri Sep 24, 2021 2:05 pm

OK I've re-created the problem. Yes it surely must be a bug as it's non-deterministic: I can copy a flow that's currently working, paste it elsewhere, then look at the copy in a Viewer and the output of the PlanarTransform will get clipped in the copy, but not in the original.

Alternative method: Do not use the Planar Tracker as the corner pin. Instead:

- Set the Planer Tracker back to Track mode.

- Click Create Planar Transform.

- Remove the Planar Tracker from the flow.

- Put in a Corner Positioner followed by the Planer Transform like so:
Image

- Go to the frame on which your Planar Tracker was Set (345) and adjust the Corner Positioner such that your image is correctly positioned on that frame. Then the Planar Transform should apply the correct transformations from there.

I did not experience the issue when using a Planar Transform node instead of the Planar Tracker itself.
Resolve Studio 17.4 and Fusion Studio 17.4 on macOS 11.5.2

Hackintosh:: X299, Intel i9-10980XE @ 4.6 Ghz, 128GB RAM, AMD 6900XT 16GB
Monitors: 1 x 3840x2160 & 3 x 1920x1200
Audio: Behringer UMC404HD
Blackmagic Speed Editor
Offline

TCP786

  • Posts: 135
  • Joined: Thu Sep 16, 2021 7:05 am
  • Real Name: Cody Predum

Re: Bug: Parts of image disappearing when changing sliders

PostFri Sep 24, 2021 3:10 pm

Very nice diagnostic work, thank you very much. I do have one small concern with this work-around though. Is there any way to copy the exact values of the tracker's corner pinner to a corner positioner node without having to eyeball it? As we all know, a small error only becomes bigger and bigger as it continues down a signal path. I already have another concern relating to aspects of the corner pinner and having to eyeball point placement (don't worry, that post is coming soon to a forum near you), and I'm worried that a process involving multiple steps that are basically "just match these points to your last points by eye" will quickly become a workflow structure that consistently yields unsatisfactory results.

Most importantly though, this actually allows me to continue working (THANK YOU SO MUCH!), and I can always plan my signal chain to account as best I can for imperfections that have to happen earlier on than I'd like.

But yeah, if there's a way to copy the exact point values of the tracker's corner pinner into a corner positioner, then this work-around is just a matter of a few more clicks, rather than a potential data error. Please let me know if that's possible, and again, thank you so much for the work-around.
Offline
User avatar

TheBloke

  • Posts: 1405
  • Joined: Sat Nov 02, 2019 11:49 pm
  • Real Name: Tom Jobbins

Re: Bug: Parts of image disappearing when changing sliders

PostFri Sep 24, 2021 5:23 pm

Sure, you can copy the four points you defined in the Planar Tracker to your Corner Positioner:

- Put the Planar Tracker back into Corner Pin mode

- At the bottom of the Inspector for the Planar Tracker, expand "Corner Pin 1" and "Reference Time Positions", and there are your four points:
Image

- They can now be entered into Corner Positioner's equivalent controls:
Image

- It would even be possible to link these parameters, by right-clicking on each set of X&Y values in the Planar Tracker -> Publish, then in the equivalent pair of controls in Planar Transform: right-click -> Connect To -> Planar Tracker 1 -> choose the correct value. That's just FYI; there's no point doing that here as it's quicker just to manually copy the values, and you won't need the Planar Tracker's Corner Pin values again.


All that said, I am slightly confused by the question. Your Planar Tracker Corner Positioner was just eyeballed, yeah? So why would it add any more error to re-eyeball it for the Corner Positioner? That's not adding error onto error, it's doing it again with the same chance of inaccuracy as the first time.

Were you to do this again in future you wouldn't even need to try doing the Corner Positioner in the Planar Tracker. At least not until we know the bug is fixed. You could go straight to using the Planar Transform, and your 4-point positioning would be done once only. You're only doing it twice in this case because you tried corner pinning in the Planar Tracker first, and now it needs to be done again due to this bug.


With regard to your general worry about needing to eyeball the corner pin placement: I'll reply in more detail when you make your separate post, but I'm pretty sure I'm correct in saying that it's entirely normal and correct to have to eyeball the target area/corner pin. That because there is a clear distinction between the search area for the track - as you drew with a spline in the Planar Tracker - and the actual tracking data generated, which you then use to manually place the corner pin.


PS. I've recreated the Planar Tracker bug in a test comp. It appears to happen in any situation where "FG Only" corner pinning is done, and the FG input image is subsequently updated (eg by changing Blur size.) It might be some kind of cache-related race condition, where every time the FG input to the Planar Tracker changes, there's a chance of it outputting a cropped image. I'll raise it in a bug report post later tonight.
Resolve Studio 17.4 and Fusion Studio 17.4 on macOS 11.5.2

Hackintosh:: X299, Intel i9-10980XE @ 4.6 Ghz, 128GB RAM, AMD 6900XT 16GB
Monitors: 1 x 3840x2160 & 3 x 1920x1200
Audio: Behringer UMC404HD
Blackmagic Speed Editor
Offline

TCP786

  • Posts: 135
  • Joined: Thu Sep 16, 2021 7:05 am
  • Real Name: Cody Predum

Re: Bug: Parts of image disappearing when changing sliders

PostSat Sep 25, 2021 12:11 am

Ah, awesome. Thanks for showing me that. Also thanks for reminding me about publishing values; I haven't needed to do that yet, but it's a good feature to remember is an option.

Also you are correctly evaluating my other question as not making sense. I was overthinking it. I love it when the answer to a problem is just "actually that's not a problem." Haha.

I have one more follow up question though. The reason I was using "FG only" from the tracker node is because in a lot of situations on this project, I am adding multiple composites to a single shot. Consequently, I have come to prefer to have my trackers only output the FG, so that I can merge the composites together (graffiti on walls in this case), and then merge all of them over the original media so that I can use one single merge node's blend slider to affect all of them (try to avoid situations where I might forget to change one of several sliders when I want to make the same change to multiple things). Can you think of any other way to get that behavior (one slider for multiple composites) without using FG only on the tracker nodes? Honestly, if changing every tracker to FG over BG allows me to avoid that bug, it's completely worth having to change blend values in different places.
Offline
User avatar

TheBloke

  • Posts: 1405
  • Joined: Sat Nov 02, 2019 11:49 pm
  • Real Name: Tom Jobbins

Re: Bug: Parts of image disappearing when changing sliders

PostSat Sep 25, 2021 8:05 am

OK this is super weird, but I've found an easy workaround for the bug:

Put a Dissolve node between the PlanarTracker and the Merge. You can even set the Dissolve to Pass Through so it's not even processing.

This breaks in the way we've talked about:
Image

This does not:
Image

For some reason connecting the Planar Tracker (in FG only) to a Dissolve - even a disabled one - does not trigger the problem. Connecting the Planar Tracker to any other node I've tested - Merge, PipeRouter, Blur, Transform, Channel Booleans, Matte Control, Brightness/Contrast - triggers the bug. But not Dissolve.

How weird! But also good, because that's an easy fix that doesn't require you to change your design at all.
Resolve Studio 17.4 and Fusion Studio 17.4 on macOS 11.5.2

Hackintosh:: X299, Intel i9-10980XE @ 4.6 Ghz, 128GB RAM, AMD 6900XT 16GB
Monitors: 1 x 3840x2160 & 3 x 1920x1200
Audio: Behringer UMC404HD
Blackmagic Speed Editor
Offline

TCP786

  • Posts: 135
  • Joined: Thu Sep 16, 2021 7:05 am
  • Real Name: Cody Predum

Re: Bug: Parts of image disappearing when changing sliders

PostSun Sep 26, 2021 12:44 am

Ah, very nice. Thanks a bunch for that work-around. That helps me out quite a bit.

Also, I posted my other corner pin question to the Fusion forum. I'd appreciate your thoughts if you have time. It's this one here: viewtopic.php?f=22&t=147953

Thank you again.
Offline
User avatar

TheBloke

  • Posts: 1405
  • Joined: Sat Nov 02, 2019 11:49 pm
  • Real Name: Tom Jobbins

Re: Bug: Parts of image disappearing when changing sliders

PostSun Sep 26, 2021 1:21 pm

Bug report thread: viewtopic.php?f=22&t=147970
Resolve Studio 17.4 and Fusion Studio 17.4 on macOS 11.5.2

Hackintosh:: X299, Intel i9-10980XE @ 4.6 Ghz, 128GB RAM, AMD 6900XT 16GB
Monitors: 1 x 3840x2160 & 3 x 1920x1200
Audio: Behringer UMC404HD
Blackmagic Speed Editor

Return to DaVinci Resolve

Who is online

Users browsing this forum: Dermot Shane, Google [Bot], IsraEliteMedia, Leonardo Levy and 60 guests