Cannot find "Enable Deinterlacing" checkbox in the Clip Attr

Get answers to your questions about color grading, editing and finishing with DaVinci Resolve.
  • Author
  • Message
Offline

Asher123

  • Posts: 69
  • Joined: Mon Jan 18, 2021 6:11 pm
  • Real Name: David Asher

Cannot find "Enable Deinterlacing" checkbox in the Clip Attr

PostThu Sep 23, 2021 6:46 am

Hi,

I cannot find the "Enable Deinterlacing" checkbox in the Clip Attributes dialog. Note that I am using the Studio version of DR17. I am referring to page 258 in the DR17 manual.

I have set up in the project settings to use the Davinci Neural Engine to Deinterlace my video clip, but it doesn't do anything to the clip.

Also I have spent a few hours on YouTube looking for how to deinterlace footage in DR, to no avail.

Any help you can provide will be appreciated. Thanks.
Online

Uli Plank

  • Posts: 11190
  • Joined: Fri Feb 08, 2013 2:48 am
  • Location: Germany and Indonesia

Re: Cannot find "Enable Deinterlacing" checkbox in the Clip

PostThu Sep 23, 2021 7:37 am

Is your timeline set for interlaced processing?
Screen Shot 2021-09-23 at 09.36.42.png
Screen Shot 2021-09-23 at 09.36.42.png (169.32 KiB) Viewed 1168 times
Don't approach Resolve with your expectations from other NLEs! They are all different.
Resolve Studio 17.2.2 and Fusion Studio 17.2.1, macOS 11.5
iMac 2017 Radeon Pro 580 8 GB VRAM, 32 GB, eGFX Breakway RX 580
Mac mini M1, 16 GB RAM
Offline

Asher123

  • Posts: 69
  • Joined: Mon Jan 18, 2021 6:11 pm
  • Real Name: David Asher

Re: Cannot find "Enable Deinterlacing" checkbox in the Clip

PostThu Sep 23, 2021 1:14 pm

Yes, my timeline is set for interlaced processing. To assist further, attached are my settings for:
- Project Settings - Master Settings,
- Project Settings - Image Scaling, and
- Clip attributes (which does not have the "Enable Deinterlacing" checkbox as mentioned in the manual.

If someone can lead me through the steps to deinterlace my old DV-PAL video using the Davinci Neural Engine, it would be greatly appreciated. I have even try to render the footage out thinking that Davinci will only deinterlace on the final output, but that doesn't work either.

HELP :-)
Attachments
Project settings - Master Settings.jpg
Project settings - Master Settings.jpg (58.64 KiB) Viewed 1122 times
Project settings - Image scaling.jpg
Project settings - Image scaling.jpg (48.97 KiB) Viewed 1122 times
Clip attributes.jpg
There is no "Enabling Deinterlacing" checkbox in the clip attributes dialog box. I am using Studio edition of Davinci Resolve 17.3. I have seen some YouTube videos which show this checkbox. How do I get the deinterlacing to work??
Clip attributes.jpg (61.77 KiB) Viewed 1122 times
Online

Uli Plank

  • Posts: 11190
  • Joined: Fri Feb 08, 2013 2:48 am
  • Location: Germany and Indonesia

Re: Cannot find "Enable Deinterlacing" checkbox in the Clip

PostThu Sep 23, 2021 2:05 pm

I'm afraid the tags for interlace are missing in those DV clips. Do they open at all?

Can you upload a short clip for testing to a transfer service?
Don't approach Resolve with your expectations from other NLEs! They are all different.
Resolve Studio 17.2.2 and Fusion Studio 17.2.1, macOS 11.5
iMac 2017 Radeon Pro 580 8 GB VRAM, 32 GB, eGFX Breakway RX 580
Mac mini M1, 16 GB RAM
Offline
User avatar

Andy Mees

  • Posts: 530
  • Joined: Wed Aug 22, 2012 7:48 am

Re: Cannot find "Enable Deinterlacing" checkbox in the Clip

PostThu Sep 23, 2021 2:11 pm

Wasn't the 'Enable Deinterlacing' checkbox removed since v17? As I recall, deinterlacing is now applied automatically (according to your chosen preferred setting) whenever you use any interlaced footage in a progressive timeline... as is, as you're working in an interlaced timeline, I wouldn't expect any deinterlacing to be applied. Try creating a progressive timeline, and then edit in one of your clips... if you flag the Clip Attributes of that source appropriately (eg Field Dominance - Upper Field), then it should be deinterlaced automatically.
Resolve Studio 17.3.2 | Adobe CC 2021 | Desktop Video 12.1
AMD Ryzen 5950X | Windows 10 Pro 20H2 | 64GB RAM | GTX 1060 6GB | 462.59 | Decklink Mini Monitor
M1 MacBook Pro | macOS 11.2.1 | 16GB RAM | Ultrastudio Monitor 3G
V24G2 | WVR5000 | 8020B | USBPre
Offline

Asher123

  • Posts: 69
  • Joined: Mon Jan 18, 2021 6:11 pm
  • Real Name: David Asher

Re: Cannot find "Enable Deinterlacing" checkbox in the Clip

PostThu Sep 23, 2021 3:02 pm

Uli Plank wrote:Can you upload a short clip for testing to a transfer service?


Here are two links to a short clip.
(1) The first one (test.avi) is from an old DV-PAL camera which opens up in Premiere Pro and VLC, but will not open correctly in Davinci Resolve 17. You will see what I mean; it's all pixelated.
https://www.dropbox.com/s/scra9efjtcksvwa/test.avi?dl=0

Note that there is some video head issues recorded on this sample, but it was the smallest original file I had to upload for you.

Ideally this is my preferred file to work with as it is the original. I started another thread on how to use this avi file (I have all my footage from 10 years in this format), and the conclusion reached was that I would have to re-encode the file. I have since tried and tried, but the quality (even with "lossless") is reduced noticeably. For old wedding videos, of course I want to maintain the quality.

I believe that the quality is lost in the re-encoding as the delinterlacing algorithms affect it negatively. So I thought I would re-encode the test.avi file into an interlaced format and then try Davinci's Neural Deinterlacing algorithm.

(2) The second link (test-lossless CPU-out2.mov) is the re-encoded test.avi file.
https://www.dropbox.com/s/40o3chvdzsvsq ... 2.mov?dl=0

This file is 50% larger, but importantly opens in Davinci Resolve and appears to be a similar quality as the original file. If you go to 02:20 you will see the interlacing in the file.

That's where I am now, but happy to take any advice on the best way forward - all I want to do is edit my original avi files in Davinci Resolve without compromising video quality. Suggestions?
Offline

Asher123

  • Posts: 69
  • Joined: Mon Jan 18, 2021 6:11 pm
  • Real Name: David Asher

Re: Cannot find "Enable Deinterlacing" checkbox in the Clip

PostThu Sep 23, 2021 3:05 pm

Andy Mees wrote:Wasn't the 'Enable Deinterlacing' checkbox removed since v17? As I recall, deinterlacing is now applied automatically (according to your chosen preferred setting) whenever you use any interlaced footage in a progressive timeline... as is, as you're working in an interlaced timeline, I wouldn't expect any deinterlacing to be applied. Try creating a progressive timeline, and then edit in one of your clips... if you flag the Clip Attributes of that source appropriately (eg Field Dominance - Upper Field), then it should be deinterlaced automatically.

I have tried all this, but it just does not de-interlace the footage. The previous comment suggests that Davinci may not recognise that the file is interlaced, ie no flag set.
Offline

Paul Ingvarsson

  • Posts: 283
  • Joined: Tue Sep 10, 2013 3:57 pm
  • Location: London, UK

Re: Cannot find "Enable Deinterlacing" checkbox in the Clip

PostThu Sep 23, 2021 3:54 pm

Asher123 wrote:I have tried all this, but it just does not de-interlace the footage. The previous comment suggests that Davinci may not recognise that the file is interlaced, ie no flag set.


Andy was suggesting that if resolve does not flag the material properly as upper or lower field first - then you should do that manually. From memory DV is lower field first but I would experiment with both settings - just don't leave it on auto.
Paul Ingvarsson
StormHD
Strongbox DX-G (Dual e5-2690 v3 64GB)
RTX3090 | Decklink 4K Pro
Eizo CG3145
Resolve 17.3.1
Windows 10 Pro 19042.1202
Offline

Asher123

  • Posts: 69
  • Joined: Mon Jan 18, 2021 6:11 pm
  • Real Name: David Asher

Re: Cannot find "Enable Deinterlacing" checkbox in the Clip

PostThu Sep 23, 2021 4:03 pm

Paul Ingvarsson wrote:
Asher123 wrote:I have tried all this, but it just does not de-interlace the footage. The previous comment suggests that Davinci may not recognise that the file is interlaced, ie no flag set.


Andy was suggesting that if resolve does not flag the material properly as upper or lower field first - then you should do that manually. From memory DV is lower field first but I would experiment with both settings - just don't leave it on auto.


Yes I did that. I tried all options. Sorry if I was not clear. None worked.
Offline
User avatar

Andy Mees

  • Posts: 530
  • Joined: Wed Aug 22, 2012 7:48 am

Re: Cannot find "Enable Deinterlacing" checkbox in the Clip

PostThu Sep 23, 2021 5:20 pm

The original file (test.avi) appears to be regular DVCAM PAL 50i footage in an AVI wrapper (encoded with a Matrox system) ... as you note, it doesn't open cleanly in Resolve. The re-encoded file (test-lossless CPU-out2.mov) is a Quicktime wrapped MPEG4 AVC encoded file at 25p ie it does not appear to be interlaced, hence Resolve can't deinterlace it.

As you note, your original file opens in Adobe Premiere / Media Encoder without issue though ... and rewrapped from there as a QuickTime DVPAL file, it can then be opened cleanly (and deinterlaced) in Resolve. Link to the rewrapped file below.
https://www.dropbox.com/s/1z92d4ci7vt7a3c/test.mov?dl=0
Resolve Studio 17.3.2 | Adobe CC 2021 | Desktop Video 12.1
AMD Ryzen 5950X | Windows 10 Pro 20H2 | 64GB RAM | GTX 1060 6GB | 462.59 | Decklink Mini Monitor
M1 MacBook Pro | macOS 11.2.1 | 16GB RAM | Ultrastudio Monitor 3G
V24G2 | WVR5000 | 8020B | USBPre
Offline

Mohan Lakshman

  • Posts: 38
  • Joined: Wed Mar 19, 2014 6:36 am

Re: Cannot find "Enable Deinterlacing" checkbox in the Clip

PostFri Sep 24, 2021 9:27 am

Use avisynth to deinterlace

Sent from my CPH1933 using Tapatalk
Mohan.L.Rangakahale
DOP, Editor, Colorist
Offline

Asher123

  • Posts: 69
  • Joined: Mon Jan 18, 2021 6:11 pm
  • Real Name: David Asher

Re: Cannot find "Enable Deinterlacing" checkbox in the Clip

PostFri Sep 24, 2021 2:47 pm

Andy Mees wrote:As you note, your original file opens in Adobe Premiere / Media Encoder without issue though ... and rewrapped from there as a QuickTime DVPAL file, it can then be opened cleanly (and deinterlaced) in Resolve. Link to the rewrapped file below.
https://www.dropbox.com/s/1z92d4ci7vt7a3c/test.mov?dl=0


Genius! I have been trying to rewrap successfully for months with no luck.

First, your file works perfectly. Thanks!

But I can't get my rewrapping to work. The result of my attempt of rewrapping the file in Premiere Pro and then when viewed in Davinci Resolve - and also strangely in VLC - is all pixelated. The file I created from test.avi is the same size as the file you sent me. Here is it here:
https://www.dropbox.com/s/7oxijhgpfdgw8 ... p.mov?dl=0

Here are screenshots of:
(1) VLC playing my attempt of the rewrap file - it's all pixelated,
(2) Davinci Resolve interface with the three files in the timeline (original test.avi, your mov, and mine)
(3) Export settings in Premiere pro to create the rewrap.

I ended up with the same result using Premiere Pro v15.0.0 (build 41), and then I tried an older version of Premiere Pro v13.1.0 (build 193).

What is odd is that when I uploaded my attempt to Dropbox, the Dropbox preview played it correctly.

Do you have any idea what is going on? If I can get it working it would solve so much for me!

Cheers David
Attachments
test-my try at rewrap.jpg
test-my try at rewrap.jpg (139.56 KiB) Viewed 946 times
Davinci with original test.avi and the two rewrapped versions.jpg
Davinci with original test.avi and the two rewrapped versions.jpg (193.46 KiB) Viewed 946 times
Export Settings- test-my try at rewrap.jpg
Export Settings- test-my try at rewrap.jpg (271.45 KiB) Viewed 946 times
Offline
User avatar

Andy Mees

  • Posts: 530
  • Joined: Wed Aug 22, 2012 7:48 am

Re: Cannot find "Enable Deinterlacing" checkbox in the Clip

PostFri Sep 24, 2021 3:46 pm

Hmmm... only difference I see is that I rewrapped the file directly from the source clip, whereas you're rewrapping from a sequence... or maybe it's because you have 'Quality' set to '4'?

Image
Resolve Studio 17.3.2 | Adobe CC 2021 | Desktop Video 12.1
AMD Ryzen 5950X | Windows 10 Pro 20H2 | 64GB RAM | GTX 1060 6GB | 462.59 | Decklink Mini Monitor
M1 MacBook Pro | macOS 11.2.1 | 16GB RAM | Ultrastudio Monitor 3G
V24G2 | WVR5000 | 8020B | USBPre
Offline

Asher123

  • Posts: 69
  • Joined: Mon Jan 18, 2021 6:11 pm
  • Real Name: David Asher

Re: Cannot find "Enable Deinterlacing" checkbox in the Clip

PostFri Sep 24, 2021 5:22 pm

Hi Andy, how do you rewrap the file directly from the source clip?

I'll then try it and get back to you.

Also do you have it configured to use the upper or the lower frame (I'm not in front of my computer and can't remembee the exact term)?
Offline
User avatar

Andy Mees

  • Posts: 530
  • Joined: Wed Aug 22, 2012 7:48 am

Re: Cannot find "Enable Deinterlacing" checkbox in the Clip

PostFri Sep 24, 2021 6:25 pm

Hey David
Just find the clip in the Project panel, right-click and choose Export Media... (or select it and choose File menu > Export > Media...) ... set the Format to 'Quicktime' and the Preset to 'Match Source (Rewrap)' and click Export. That's all I did ... I've repeated it multiple times and it's worked every time.

You could also skip Premiere and just import your clip(s) directly into Media Encoder and use the same simple settings (Format: Quicktime, Preset: Match Source (Rewrap)) to batch rewrap them (but test your setting/result on one clip first!)
Cheers
Andy
Resolve Studio 17.3.2 | Adobe CC 2021 | Desktop Video 12.1
AMD Ryzen 5950X | Windows 10 Pro 20H2 | 64GB RAM | GTX 1060 6GB | 462.59 | Decklink Mini Monitor
M1 MacBook Pro | macOS 11.2.1 | 16GB RAM | Ultrastudio Monitor 3G
V24G2 | WVR5000 | 8020B | USBPre
Online

Uli Plank

  • Posts: 11190
  • Joined: Fri Feb 08, 2013 2:48 am
  • Location: Germany and Indonesia

Re: Cannot find "Enable Deinterlacing" checkbox in the Clip

PostSat Sep 25, 2021 11:04 am

Shutter Encoder re-wraps it for free, but the codec seems to be the problem.
Converted to ProRes it works perfectly fine here, just tell it under Clip Attributes that it's lower field dominance.
Don't approach Resolve with your expectations from other NLEs! They are all different.
Resolve Studio 17.2.2 and Fusion Studio 17.2.1, macOS 11.5
iMac 2017 Radeon Pro 580 8 GB VRAM, 32 GB, eGFX Breakway RX 580
Mac mini M1, 16 GB RAM
Offline

Asher123

  • Posts: 69
  • Joined: Mon Jan 18, 2021 6:11 pm
  • Real Name: David Asher

Re: Cannot find "Enable Deinterlacing" checkbox in the Clip

PostSat Sep 25, 2021 3:29 pm

Andy Mees wrote:Hmmm... only difference I see is that I rewrapped the file directly from the source clip, whereas you're rewrapping from a sequence... or maybe it's because you have 'Quality' set to '4'?


Hi Andy,

I'm determined to get this working. It will allow me to do over 100GB of my family videos from the last 20 years! There must be something different between our configurations and/or systems.

I tried the Adobe Media Encoder and got the same issue. So I realised that my export screen looked only slightly different to yours, so I did it again (and again) to match yours perfectly yet is still outputs the test.mov as a heavily pixelated file.

I did the following:
(1) right-click on the test.avi clip from the project list above the timeline and selected to export the clip.
(2) Selected format = Quicktime, and Preset = Match Source (rewrap)

The output of exporting this resulted in the same pixelated file.

So - and to completely match your export screen - I then did the following:
(3) changed Preset to = PAL DV (just like yours). Note that this changed the Quality setting from 4 to 100 (just like yours),
(4) ticked the 5 check-boxes that now appeared (highlighted in yellow on the attached file below) - again to match your export settings,
(5) unchecked the "Aspect Ratio Correction" button at the bottom of the export dialog box (also highlighted in yellow). Although I don't think this actually affects the export output file in any way - but I did it anyway.

And then I exported the file.

Unfortunately I got the same pixelated resulting output file. I can't see why it would work for you but not for me.

Some questions for you if you don't mind:

(1) Did the test_1.mov file that I created and attached in a previous message work for you, or did you see it highly pixelated like I did?

(2) What settings do you have when clicking on the "Metadata..." button at the bottom of the export page? Are the same as mine - I have attached a screenshot of mine here. I have tried every one of the "Export Options" at the top of this Metadata dialog box, and none solved my problem. I haven't tried anything else on this Metadata settings dialog box.

(3) Which version of Premiere Pro are you using? Could there be some codecs or something that I need to update (or downdate?!) to get this working?

And finally, thank you so much for taking the time to help me!
Attachments
Export settings identical.jpg
Export settings identical.jpg (375.88 KiB) Viewed 805 times
Export settings identical-metadata dialog.jpg
Export settings identical-metadata dialog.jpg (119.42 KiB) Viewed 805 times
Offline

Asher123

  • Posts: 69
  • Joined: Mon Jan 18, 2021 6:11 pm
  • Real Name: David Asher

Re: Cannot find "Enable Deinterlacing" checkbox in the Clip

PostSat Sep 25, 2021 3:31 pm

Uli Plank wrote:Shutter Encoder re-wraps it for free, but the codec seems to be the problem.
Converted to ProRes it works perfectly fine here, just tell it under Clip Attributes that it's lower field dominance.

Thanks Uli, I tried previously every option in Shutter Encoder to re-wrap the test.avi file, but had no success. I also tried re-encoding the file using ProRes (and that it's lower field), however the resulting file is very soft (and large, which I don't mind). A lot of the details are missing.
Online

Uli Plank

  • Posts: 11190
  • Joined: Fri Feb 08, 2013 2:48 am
  • Location: Germany and Indonesia

Re: Cannot find "Enable Deinterlacing" checkbox in the Clip

PostSat Sep 25, 2021 4:21 pm

You shouldn't use Shutter Encoder for any scaling or de-interlacing, just for conversion.

If I do that with your test file, it opens perfectly fine in DR as interlaced PAL in normal quality. Do the de-interlacing in DR and use the neural de-interlacer, the other options are crap. Scaling should also be done by SuperScale.
Both options are Studio only!

If you don't want to buy Studio (which I highly recommend), you can give Topaz Labs VEAI a try.
This is the setting for the de-interlacer:
Screen Shot 2021-09-25 at 18.25.05.png
Screen Shot 2021-09-25 at 18.25.05.png (288.71 KiB) Viewed 781 times
Don't approach Resolve with your expectations from other NLEs! They are all different.
Resolve Studio 17.2.2 and Fusion Studio 17.2.1, macOS 11.5
iMac 2017 Radeon Pro 580 8 GB VRAM, 32 GB, eGFX Breakway RX 580
Mac mini M1, 16 GB RAM
Offline

Asher123

  • Posts: 69
  • Joined: Mon Jan 18, 2021 6:11 pm
  • Real Name: David Asher

Re: Cannot find "Enable Deinterlacing" checkbox in the Clip

PostSat Sep 25, 2021 8:11 pm

Uli Plank wrote:You shouldn't use Shutter Encoder for any scaling or de-interlacing, just for conversion.

If I do that with your test file, it opens perfectly fine in DR as interlaced PAL in normal quality. Do the de-interlacing in DR and use the neural de-interlacer, the other options are crap. Scaling should also be done by SuperScale.
Both options are Studio only!

If you don't want to buy Studio (which I highly recommend), you can give Topaz Labs VEAI a try.
This is the setting for the de-interlacer:
Screen Shot 2021-09-25 at 18.25.05.png


Hi Uli,

I have tried what you said to do, but had no success. I actually started this topic because I couldn't get the Davinci Neural deinterlacing to work.

I do have the Studio version of Davinci Resolve.

Using my test.avi as an example, would you mind giving me step - by-step instructions on how to do what you have suggested?

Eg, (1) use Shutter Encoder and select the following options,
(2) instructions on how to get Davinci to deinterlace the video. Please read my previous comments on this thread as I explain that I cannot get Davinci to work for me in this regard.
Offline

Asher123

  • Posts: 69
  • Joined: Mon Jan 18, 2021 6:11 pm
  • Real Name: David Asher

Re: Cannot find "Enable Deinterlacing" checkbox in the Clip

PostSat Sep 25, 2021 8:12 pm

Uli Plank wrote:You shouldn't use Shutter Encoder for any scaling or de-interlacing, just for conversion.

If I do that with your test file, it opens perfectly fine in DR as interlaced PAL in normal quality. Do the de-interlacing in DR and use the neural de-interlacer, the other options are crap. Scaling should also be done by SuperScale.
Both options are Studio only!

If you don't want to buy Studio (which I highly recommend), you can give Topaz Labs VEAI a try.
This is the setting for the de-interlacer:
Screen Shot 2021-09-25 at 18.25.05.png


Hi Uli,

I have tried what you said to do, but had no success. I actually started this topic because I couldn't get the Davinci Neural deinterlacing to work.

I do have the Studio version of Davinci Resolve.

Using my test.avi as an example, would you mind giving me step - by-step instructions on how to do what you have suggested?

Eg, (1) use Shutter Encoder and select the following options,
(2) instructions on how to get Davinci to deinterlace the video. Please read my previous comments on this thread as I explain that I cannot get Davinci to work for me in this regard.
Online

Uli Plank

  • Posts: 11190
  • Joined: Fri Feb 08, 2013 2:48 am
  • Location: Germany and Indonesia

Re: Cannot find "Enable Deinterlacing" checkbox in the Clip

PostSat Sep 25, 2021 8:59 pm

In Shutter Encoder, set it like this and click Start function:
Shutter_Encoder.png
Shutter_Encoder.png (54.24 KiB) Viewed 759 times


You should get a file called test_Apple_ProRes_422_HQ.mov.

Now set up your timeline as I described above in my first answer. Import that file to your Media pool and set the Clip Attributes like this:
Lower_field.png
Lower_field.png (208.68 KiB) Viewed 759 times


Cut or drag the clip into the timeline. Set de-interlacing for the project as I've shown above.
If you single-step through your timeline, you should see 50 clean progressive de-interlaced frames by now.
Last edited by Uli Plank on Sat Sep 25, 2021 9:01 pm, edited 1 time in total.
Don't approach Resolve with your expectations from other NLEs! They are all different.
Resolve Studio 17.2.2 and Fusion Studio 17.2.1, macOS 11.5
iMac 2017 Radeon Pro 580 8 GB VRAM, 32 GB, eGFX Breakway RX 580
Mac mini M1, 16 GB RAM
Offline
User avatar

Andy Mees

  • Posts: 530
  • Joined: Wed Aug 22, 2012 7:48 am

Re: Cannot find "Enable Deinterlacing" checkbox in the Clip

PostSat Sep 25, 2021 9:00 pm

Asher123 wrote:I did the following:
(1) right-click on the test.avi clip from the project list above the timeline and selected to export the clip.
(2) Selected format = Quicktime, and Preset = Match Source (rewrap)
The output of exporting this resulted in the same pixelated file.

Yes, that sounds right.

Asher123 wrote:So - and to completely match your export screen - I then did the following:
(3) changed Preset to = PAL DV (just like yours). Note that this changed the Quality setting from 4 to 100 (just like yours),
(4) ticked the 5 check-boxes that now appeared (highlighted in yellow on the attached file below) - again to match your export settings,
(5) unchecked the "Aspect Ratio Correction" button at the bottom of the export dialog box (also highlighted in yellow). Although I don't think this actually affects the export output file in any way - but I did it anyway.

And then I exported the file.

Those settings are just the result of clicking the 'Match Source' button in the Export window's Basic Video Settings pane. I tried both methods... they both worked for me.

Asher123 wrote:Some questions for you if you don't mind:

(1) Did the test_1.mov file that I created and attached in a previous message work for you, or did you see it highly pixelated like I did?

I don't recall seeing a ' test_1.mov'. There was a 'test-my try at rewrap.mov' ... like your original test.avi that wouldn't open cleanly in Resolve.

Asher123 wrote:(2) What settings do you have when clicking on the "Metadata..." button at the bottom of the export page? Are the same as mine - I have attached a screenshot of mine here. I have tried every one of the "Export Options" at the top of this Metadata dialog box, and none solved my problem. I haven't tried anything else on this Metadata settings dialog box.

I had the default setting (Embed, Preserve Metadata etc)... but I just tested again with Metadata Export Options set to 'Off'... as with my previous tests, the resulting exported (rewrapped) file opens in Resolve without issue.

Asher123 wrote:(3) Which version of Premiere Pro are you using? Could there be some codecs or something that I need to update (or downdate?!) to get this working?

I'm using the current Premiere Pro CC release version, which as of writing is 15.4.1 Build 6 ... and for good measure I just tested with the latest Premiere Pro Beta build as well, which is 22.1.0 Build 11, and that also produced a rewrap that opens in Resolve just as with my other tests.
This is all on my Windows PC running Windows 10 Pro version 20H2 || OS build 19042.1237
Resolve Studio 17.3.2 | Adobe CC 2021 | Desktop Video 12.1
AMD Ryzen 5950X | Windows 10 Pro 20H2 | 64GB RAM | GTX 1060 6GB | 462.59 | Decklink Mini Monitor
M1 MacBook Pro | macOS 11.2.1 | 16GB RAM | Ultrastudio Monitor 3G
V24G2 | WVR5000 | 8020B | USBPre
Offline

Asher123

  • Posts: 69
  • Joined: Mon Jan 18, 2021 6:11 pm
  • Real Name: David Asher

Re: Cannot find "Enable Deinterlacing" checkbox in the Clip

PostSun Sep 26, 2021 4:14 pm

Thanks Andy for all your help. It's a real conundrum that it doesn't work for me.

I am thinking that perhaps I should recapture all my miniDV tapes but somehow directly into Davinci. Is that a good idea? I'll have to see if Davinci offers that function.

I'll keep trying and post my updates for everyone.
Offline

Asher123

  • Posts: 69
  • Joined: Mon Jan 18, 2021 6:11 pm
  • Real Name: David Asher

Re: Cannot find "Enable Deinterlacing" checkbox in the Clip

PostSun Sep 26, 2021 5:09 pm

Thanks Uli, your advice has been helpful... and opened up my eyes on how to get deinterlacing to work.

I followed your instructions and it works well.

The Apple-ProRes_422_HQ resulting file from Shutter Encoder is about double the size of my original file (not an issue), and also the colours are more saturated (again not an issue). I then imported the media into Davinci and tried to set the timeline to PAL (720x576) but could not get the aspect ratio to look right.

Instead I set a new timeline to 1280x720HD 720P (and although it originally set the frame rate to 25 fps, I later updated it to 50 fps) and tried again and it looked much better. I also tried 1920x1080 for the timeline also with 50 fps. The deinterlacing (Neural setting) worked well. But the aspect ratio of the resulting footage is not right. It is very close, but slightly too narrow, ie I would have to increase the Zoom-x amount slightly to get it right. Any idea why this should happen?

In terms of upscaling to 1280x720 - as I have never done this before - I right-clicked the clip in the media folder and selected "Super Scale" and set to 2x, then 3x then 4x (Sharpness = medium, Noise Reduction = medium). I even tried to scale to 1920x1080.

What do you recommend in terms of Super Scale settings for miniDV PAL 720x576 footage?

Finally, with the deinterlacing and the Super Scale settings enabled, the playback on the timeline during the editing process is very jittery. What is your workflow and what do you suggest?

Thanks again.
Online

Uli Plank

  • Posts: 11190
  • Joined: Fri Feb 08, 2013 2:48 am
  • Location: Germany and Indonesia

Re: Cannot find "Enable Deinterlacing" checkbox in the Clip

PostMon Sep 27, 2021 7:15 am

Glad it works for you now. AVI is such an outdated format that many small things can happen, but it has more to do with flagging than with missing any video data. After all, as long as the tapes are readable, it's just a copying process, not digitizing. So, if you can convert to ProRes and the image is not pixellated or disturbed in any other massive way, you are good on that side.

Now, DV had two different formats, out of the same number of pixels. Early one was 'classic' TV in 4:3, and regarding your test footage I'm not sure, it doesn't look right to me. The other was 16:9, as in modern TV, but only stretched when being displayed. If DR is not interpreting it correctly, probably missing a flag, you can always set that by changing the pixel aspect ratio in the clip Attributes. It's even a bit more complicated in NTSC, but we are referring to PAL here.

Finally, many amateur camcorders where recording some empty pixels on both sides (IIRC about 8) and you are doing the right thing by de-coupling x and y scaling and changing x in the Inspector to stretch the image horizontally and cut these off.

How to set SuperScale depends on your content and taste, just experiment. Personally, I wouldn't try to go beyond 1280 by 720 from PAL (if your sources are 16:9). If they were 4:3, you can only leave black on the sides or scale them even further and cut from the top and the bottom.

And SuperScale is demanding, depending on your GPU it may not play in realtime. If you ever try Topaz VEAI you'll see that AI scaling takes even more time. Much more!
Don't approach Resolve with your expectations from other NLEs! They are all different.
Resolve Studio 17.2.2 and Fusion Studio 17.2.1, macOS 11.5
iMac 2017 Radeon Pro 580 8 GB VRAM, 32 GB, eGFX Breakway RX 580
Mac mini M1, 16 GB RAM
Offline

Asher123

  • Posts: 69
  • Joined: Mon Jan 18, 2021 6:11 pm
  • Real Name: David Asher

Re: Cannot find "Enable Deinterlacing" checkbox in the Clip

PostMon Sep 27, 2021 1:51 pm

Uli Plank wrote:And SuperScale is demanding, depending on your GPU it may not play in realtime. If you ever try Topaz VEAI you'll see that AI scaling takes even more time. Much more!


Thanks Uli! Just wondering with all the processing required by Davinci Resolve with deinterlacing and SuperScaling do you leave those settings OFF until you have completed your final edit, or do you somehow get Davinci to create proxy(?) files so that you can edit and see what the output will be like during the editing process?

I am more used to Premiere Pro and it has red bars above the clips in the timeline which will not play back at correct speed due to the processing required, and therefore there is an opportunity to render those parts to help with the playback during editing. I have no idea how to do this with Davinici. Do you know how?
Online

Uli Plank

  • Posts: 11190
  • Joined: Fri Feb 08, 2013 2:48 am
  • Location: Germany and Indonesia

Re: Cannot find "Enable Deinterlacing" checkbox in the Clip

PostMon Sep 27, 2021 2:13 pm

Well, you may need to do some learning then.
You can either cache those parts or you can use a "Render in Place".
Don't approach Resolve with your expectations from other NLEs! They are all different.
Resolve Studio 17.2.2 and Fusion Studio 17.2.1, macOS 11.5
iMac 2017 Radeon Pro 580 8 GB VRAM, 32 GB, eGFX Breakway RX 580
Mac mini M1, 16 GB RAM
Offline

Asher123

  • Posts: 69
  • Joined: Mon Jan 18, 2021 6:11 pm
  • Real Name: David Asher

Re: Cannot find "Enable Deinterlacing" checkbox in the Clip

PostMon Sep 27, 2021 2:18 pm

Uli Plank wrote:Well, you may need to do some learning then.
You can either cache those parts or you can use a "Render in Place".

Thanks for your quick reply.

But what do you do? following on from the process you outlined above, to deinterlace and SuperScale Apple ProRes footage?
Online

Uli Plank

  • Posts: 11190
  • Joined: Fri Feb 08, 2013 2:48 am
  • Location: Germany and Indonesia

Re: Cannot find "Enable Deinterlacing" checkbox in the Clip

PostMon Sep 27, 2021 2:22 pm

De-interlacing is normally fast enough for me.
I tend to adjust SuperScale to my liking and then switch it off during editing and grading.
Don't approach Resolve with your expectations from other NLEs! They are all different.
Resolve Studio 17.2.2 and Fusion Studio 17.2.1, macOS 11.5
iMac 2017 Radeon Pro 580 8 GB VRAM, 32 GB, eGFX Breakway RX 580
Mac mini M1, 16 GB RAM
Offline

Asher123

  • Posts: 69
  • Joined: Mon Jan 18, 2021 6:11 pm
  • Real Name: David Asher

Re: Cannot find "Enable Deinterlacing" checkbox in the Clip

PostMon Sep 27, 2021 2:33 pm

Uli Plank wrote:De-interlacing is normally fast enough for me.
I tend to adjust SuperScale to my liking and then switch it off during editing and grading.

Thanks again Uli!
Offline

Asher123

  • Posts: 69
  • Joined: Mon Jan 18, 2021 6:11 pm
  • Real Name: David Asher

Re: Cannot find "Enable Deinterlacing" checkbox in the Clip

PostThu Sep 30, 2021 6:44 am

Asher123 wrote:Thanks Andy for all your help. It's a real conundrum that it doesn't work for me.

I am thinking that perhaps I should recapture all my miniDV tapes but somehow directly into Davinci. Is that a good idea? I'll have to see if Davinci offers that function.

I'll keep trying and post my updates for everyone.


** SOLVED ** - But in an odd way. This solution may help others who have had my issue as stated above in converting (rewrapping) the miniDV avi files using Premiere Pro so that it can be used in Davinici Resolve without major pixelation. The issue was resolved by Andy above, yet did not work for me. This slight change to the process now works for me too. Thanks to Andy for his help and thoughts.

After further testing - read, trying to do cover every possible option with the hope that something odd will work - I stumbled across this which seems to work for me, although I cannot explain why it should.

What I did:
(1) Create a new sequence in Premiere Pro as DV-PAL.
(2) Move the test.avi file to the new sequence, and choose "Change sequence settings" so that sequence now matches the avi file perfectly.
(3) Now delete the test.avi file from the sequence, and then go into the sequence settings and change Fields to "Upper field first". I know, what am I doing! :-)
(4) Move the test.avi file back to the sequence and this time select "Keep existing settings". My aim is that the sequence configuration is exactly the same as the test.avi file configuration BUT only the "Upper field" setting is different.
(5) Right-click on this SEQUENCE in the project list above the timeline and select "Export Media"
(6) Select "Quicktime" and "PAL DV" (as "Match Source" is "not compatible with this preset")
(7) Make no other changes and click on the "Export" button.

[*Note that you may be able to omit steps (3) and (4) above, but I wanted make the Sequence setting have "Upper field" while the video file has the correct setting of "Lower field" for the field dominance.]

IT WORKS! ...and I don't know why. The output is the same as what Andy sent previously and the file size is the same. Very odd. But it works consistently for me and across all my MiniDV files.

Return to DaVinci Resolve

Who is online

Users browsing this forum: Baidu [Spider], Google [Bot], RikshaDriver, Uli Plank and 49 guests