9 fps playback speed after 17.4 upgrade

Get answers to your questions about color grading, editing and finishing with DaVinci Resolve.
  • Author
  • Message
Offline

68arti

  • Posts: 17
  • Joined: Mon Feb 03, 2020 11:44 pm
  • Real Name: Andrzej Artymowicz

9 fps playback speed after 17.4 upgrade

PostSat Oct 23, 2021 12:54 pm

Hi!

I get 9 fps playback speed on typical 4K h.264, h.265 even without any color correction after 17.4 upgrade. I've deleted cache files. Still unusable. Any ideas?

The 17.3.2 was perfectly fine and fast. Looks like a definite bug.

Mac Pro 2013, 10 core, 128GB RAM, 2x 6800XT eGPUs, Mini Monitor 4K, Monterey OS.
I had to switch back to 17.3.2 and get back to work.

Regrards
Arti
Last edited by 68arti on Sat Oct 23, 2021 8:41 pm, edited 1 time in total.
Mac Pro 2013
10-core
2x D500
128GB RAM
2xAMD 6800XT
26GB SSD
NEC 302W - UI monitor (D500)
NEC 311D - Grading monitor (Mini Monitor 4K)
MacOS Monterey 12
Offline

Andrew Kolakowski

  • Posts: 7858
  • Joined: Tue Sep 11, 2012 10:20 am
  • Location: Poland

Re: 9 fps playback speed after 17.4 upgrade

PostSat Oct 23, 2021 1:33 pm

First thing to avoid in production environment - beta OS and app installation on officially unsupported OS.
You just asking for problems for no reason.

No idea what is so great in Monterey that you need it so badly (specially when you use Mac 2013).
Last edited by Andrew Kolakowski on Sat Oct 23, 2021 9:55 pm, edited 1 time in total.
Offline

68arti

  • Posts: 17
  • Joined: Mon Feb 03, 2020 11:44 pm
  • Real Name: Andrzej Artymowicz

Re: 9 fps playback speed after 17.4 upgrade

PostSat Oct 23, 2021 8:20 pm

Andrew Kolakowski wrote:No idea what is so great in Monterey that you need it so baldy (specially when you use Mac 2013).


I know what's so great.
I've switched from Catalina to Monterey because of faster, more efficient eGPU performance.
The Monterey serves me well since summer with no issues.
The issue appeared when moving from previous 17.3.2 to current Resolve 17.4, not when changing the OS.
Resolve 17.4 is Monterey compatible release.

p.s. Don't call me baldy :D
Mac Pro 2013
10-core
2x D500
128GB RAM
2xAMD 6800XT
26GB SSD
NEC 302W - UI monitor (D500)
NEC 311D - Grading monitor (Mini Monitor 4K)
MacOS Monterey 12
Offline

Andrew Kolakowski

  • Posts: 7858
  • Joined: Tue Sep 11, 2012 10:20 am
  • Location: Poland

Re: 9 fps playback speed after 17.4 upgrade

PostSat Oct 23, 2021 9:57 pm

It can't be as system is not released yet.
17.4 uses Monterey properly :lol:
Offline
User avatar

Marc Wielage

  • Posts: 7809
  • Joined: Fri Oct 18, 2013 2:46 am
  • Location: Hollywood, USA

Re: 9 fps playback speed after 17.4 upgrade

PostSat Oct 23, 2021 11:48 pm

H.264 and other highly-compressed codecs are intended as DELIVERY formats, not necessarily to be used for editing and final color. Using H.264 puts a lot of stress on the computer, since it has to de-compress the images and play them back at speed, in addition to applying all the processes Resolve requires. My advice is to transcode all the H.264 material to a simpler codec for your system, something visually-lossless like DNxHR or ProRes 422HQ, and use that instead. You'll get much better performance that way.

The alternative is to use Optimized Media, which basically transcodes it all in the background. My preference is to do it manually, because then I can control where the files go and how they're named. Proxy Media can also work very effectively (and is preferred in some ways).
marc wielage, csi • VP/color & workflow • chroma | hollywood
Offline

68arti

  • Posts: 17
  • Joined: Mon Feb 03, 2020 11:44 pm
  • Real Name: Andrzej Artymowicz

Re: 9 fps playback speed after 17.4 upgrade

PostSun Oct 24, 2021 12:20 pm

Marc Wielage wrote:H.264 and other highly-compressed codecs are intended as DELIVERY formats, not necessarily to be used for editing and final color.


Sure I know the theory.
The only difference is the Resolve version.
The question is do you think is it normal:

17.3.2 - great smooth editing/playback performance on 4K, no matter h264, h265, of course ProRes422, smooth playback, not a single problem

17.4. - Resolve playback is 3-4x slower, stuttery 9fps playback, without any color correction, same project, same settings, with deleted cache. Unusable
Mac Pro 2013
10-core
2x D500
128GB RAM
2xAMD 6800XT
26GB SSD
NEC 302W - UI monitor (D500)
NEC 311D - Grading monitor (Mini Monitor 4K)
MacOS Monterey 12
Offline

Andrew Kolakowski

  • Posts: 7858
  • Joined: Tue Sep 11, 2012 10:20 am
  • Location: Poland

Re: 9 fps playback speed after 17.4 upgrade

PostSun Oct 24, 2021 4:25 pm

Just some compatibility issue, so needs fix with future update. You can send email with details to BM support so they log it.
Offline
User avatar

waltervolpatto

  • Posts: 8977
  • Joined: Thu Feb 07, 2013 5:07 pm
  • Location: 1146 North Las Palmas Ave. Hollywood, California 90038 USA

Re: 9 fps playback speed after 17.4 upgrade

PostSun Oct 24, 2021 6:06 pm

does the egpu even work on Monterey?
SuperServer 5039AD-I
C9X299-PGF - DDR4-2400 16x4 GB
i9-7920xCPU 12c 2.90GHz Water cooled
2x 1080ti DeckLink Studio 4K (11.5.1)
W10-1903 - BMR St. 17.3.2-08
nvidia: 462.59 studio
Offline

Andrew Kolakowski

  • Posts: 7858
  • Joined: Tue Sep 11, 2012 10:20 am
  • Location: Poland

Re: 9 fps playback speed after 17.4 upgrade

PostSun Oct 24, 2021 6:47 pm

It may not, so no GPU decoding and 9fps playback.
Offline

68arti

  • Posts: 17
  • Joined: Mon Feb 03, 2020 11:44 pm
  • Real Name: Andrzej Artymowicz

Re: 9 fps playback speed after 17.4 upgrade

PostSun Oct 24, 2021 11:00 pm

waltervolpatto wrote:does the egpu even work on Monterey?


Of course!
With such a fast GPUs as double AMD 6800XT (internal D500 not used) the rendering is very quick. I can even playback better quality noise reduction + CC + sharpen almost in real time without the rendering/caching with C4K resolution using previous Resolve 17.3.2.
Mac Pro 2013
10-core
2x D500
128GB RAM
2xAMD 6800XT
26GB SSD
NEC 302W - UI monitor (D500)
NEC 311D - Grading monitor (Mini Monitor 4K)
MacOS Monterey 12
Offline

68arti

  • Posts: 17
  • Joined: Mon Feb 03, 2020 11:44 pm
  • Real Name: Andrzej Artymowicz

Re: 9 fps playback speed after 17.4 upgrade

PostSun Oct 24, 2021 11:36 pm

Andrew Kolakowski wrote:Just some compatibility issue, so needs fix with future update. You can send email with details to BM support so they log it.


I hope so it's not a "planned obsolescence", it would be too drastic from 17.3.2 to 17.4
From great to no performance in one step.

The Mac Pro 2013 it's not a single core monster but 10-core Xeon it's a sweet spot IMO.
And with 2 fast GPUs on different TB buses it works fine in C4K.
So I can wait for the Mac Pro M2 in the future.

I've sent an email to BMD waiting for a reply.
Mac Pro 2013
10-core
2x D500
128GB RAM
2xAMD 6800XT
26GB SSD
NEC 302W - UI monitor (D500)
NEC 311D - Grading monitor (Mini Monitor 4K)
MacOS Monterey 12
Offline
User avatar

waltervolpatto

  • Posts: 8977
  • Joined: Thu Feb 07, 2013 5:07 pm
  • Location: 1146 North Las Palmas Ave. Hollywood, California 90038 USA

Re: 9 fps playback speed after 17.4 upgrade

PostMon Oct 25, 2021 1:02 am

68arti wrote:
waltervolpatto wrote:does the egpu even work on Monterey?


Of course!
With such a fast GPUs as double AMD 6800XT (internal D500 not used) the rendering is very quick. I can even playback better quality noise reduction + CC + sharpen almost in real time without the rendering/caching with C4K resolution using previous Resolve 17.3.2.


THAT is my point: the eGPU is accessible by resolve in 17.3.x, but it might be screwed in 17.4

check:
1) is the GPU visible in the resolve system
2) is the CUDA/Metal?OpenGL correctly selected? (switch to another, restart, switch back to the right one and check again)
3) monitor what the system is doing while playing back: do you get the files on time (drives/bandwidth), do you deflated in time (CPU at 100% or more), did you process it in time (D5oo is active and the eGPU is not)

bonus: check if the h264/265 deflating processing is setup for GPU or CPU.

also, do not simply assume that because it was working in 17.3x is automatically setup correctly in 17.4, things changes....
SuperServer 5039AD-I
C9X299-PGF - DDR4-2400 16x4 GB
i9-7920xCPU 12c 2.90GHz Water cooled
2x 1080ti DeckLink Studio 4K (11.5.1)
W10-1903 - BMR St. 17.3.2-08
nvidia: 462.59 studio

Return to DaVinci Resolve

Who is online

Users browsing this forum: Andreas Hanten, Bing [Bot], crtkecnkl659, jfykeaucq871, peterbaumann and 98 guests