Speed Editor bluetooth connection issues

Get answers to your questions about color grading, editing and finishing with DaVinci Resolve.
  • Author
  • Message
Offline
User avatar

smeijel

  • Posts: 3
  • Joined: Mon Oct 14, 2019 1:52 am
  • Real Name: Sam van Meijel

Speed Editor bluetooth connection issues

PostSun Oct 17, 2021 5:21 pm

Hi!

I've tried anything but Resolve doesn't seem to recognise the paired Speed Editor. Once I plug it in everything works just fine. When I unplug the cable and connect it with bluetooth it successfully connects. But neither Resolve or Control Panels recognises the Speed Editor.

I'm on macOS Monterey version 12.0 Beta (21A5552a).
DaVinci Resolve Studio version 17.3.2
Speed Editor Version 1.4, Build d0821c87

Maybe the Speed Editor isn't compatible yet with the new macOS Monterey?
Offline

Nikki264

  • Posts: 3
  • Joined: Mon Sep 06, 2021 9:46 pm
  • Real Name: Matthias Patzelt

Re: Speed Editor bluetooth connection issues

PostTue Oct 19, 2021 11:50 am

I’m on Big Sur and have the same problem; probably Monterey is not the problem.
Offline

michaelx

  • Posts: 2
  • Joined: Thu Oct 21, 2021 2:07 pm
  • Real Name: Michael Garcia

Re: Speed Editor bluetooth connection issues

PostThu Oct 21, 2021 2:09 pm

I have the same issue. Sometimes it does not connect via bluetooth in system preferences, but the battery level still shows in Resolve and the lights are on the panel, but none of the buttons function / register.

When connected, works immediately.
Offline
User avatar

csilverman66

  • Posts: 6
  • Joined: Sun Jun 30, 2019 2:16 pm
  • Location: Ridgefield, CT
  • Real Name: Charles Silverman

Re: Speed Editor bluetooth connection issues

PostSun Oct 24, 2021 2:29 pm

I'm on Catalina... 2017 iMac Pro... running DR17.4... and have the same issue... works plugged in... connects to computer via bluetooth, but DR will not recognize the device via Bluetooth.

However... works exactly as expected running DR17.4 on 2015 MacBook Pro/Big Sur.
Offline

michaelx

  • Posts: 2
  • Joined: Thu Oct 21, 2021 2:07 pm
  • Real Name: Michael Garcia

Re: Speed Editor bluetooth connection issues

PostSun Oct 24, 2021 8:41 pm

Now after updating to 17.4 and 1.4.1 Speed Editor firmware, the STOP / PLAY button does not work. The result is the same on both my MacBook Pro (15'', late 2017) and iMac (27'', late 2019).

I've factory reset, done the CUT - SMTH CUT - SOURCE - TIMELINE reset, and rebooted.
Offline

studio1492

  • Posts: 426
  • Joined: Fri Oct 26, 2018 6:22 pm
  • Real Name: Fran Navas

Re: Speed Editor bluetooth connection issues

PostSun Oct 24, 2021 9:02 pm

Same issue here since I purchased the device months ago.
- iMac 27" 5K 2019 i9 3.6Ghz 40GB Vega 48 8GB
- MBP 16" 2019 i9 2.3GHz 16GB Radeon Pro 5500M 4GB
- Resolve Studio 17.2.2 @ macOS Catalina 11.5.1
- Mini Panel v1.3.2
- Synology DS218
Offline

Peter Chamberlain

Blackmagic Design

  • Posts: 11276
  • Joined: Wed Aug 22, 2012 7:08 am

Re: Speed Editor bluetooth connection issues

PostMon Oct 25, 2021 2:11 am

michaelx wrote:Now after updating to 17.4 and 1.4.1 Speed Editor firmware, the STOP / PLAY button does not work. The result is the same on both my MacBook Pro (15'', late 2017) and iMac (27'', late 2019).

I've factory reset, done the CUT - SMTH CUT - SOURCE - TIMELINE reset, and rebooted.


Is this bluetooth related or the same with USB connected?
DaVinci Resolve Product Manager
Offline

Likeable Media

  • Posts: 10
  • Joined: Sun Apr 11, 2021 1:25 am
  • Real Name: Darren Varney

Re: Speed Editor bluetooth connection issues

PostTue Oct 26, 2021 11:55 pm

I have issues with the Speed Editor connecting via bluetooth on my PC too. Sometimes the Speed Editor lights up when Davinci starts but then it just fails to work via bluetooth. Other times it's been working ok then when I stop using it for a short period 5min it turns off and won't reconnect.
The speed editor needs a key to wake it up and there should be an option in Davinci to connect with it.


The speed editor works fine with a cable, but that's a pain.
Offline
User avatar

Charles Bennett

  • Posts: 3604
  • Joined: Sat Nov 05, 2016 11:55 am
  • Location: United Kingdom

Re: Speed Editor bluetooth connection issues

PostWed Oct 27, 2021 1:02 pm

To wake up the SE just press the STOP/PLAY key before launching Resolve.
Resolve Studio 17.4.2 Build 9
Dell XPS 8700 i7-4790 4 core, 24GB RAM, 2 x internal Samsung Evo SSDs, GTX1060/6GB (472.47 Studio), Win10 Home 19043, Speed Editor, PreSonus Faderport 1, Eizo ColorEdge CS230 + BenQ GW2270 (both calibrated)
Offline

studio1492

  • Posts: 426
  • Joined: Fri Oct 26, 2018 6:22 pm
  • Real Name: Fran Navas

Re: Speed Editor bluetooth connection issues

PostThu Oct 28, 2021 5:16 pm

Charles Bennett wrote:To wake up the SE just press the STOP/PLAY key before launching Resolve.


Stop/Play doesn't works to me to wake up the unit.

Mi Speed editor wakes up with "Cut + Smooth Cut + Source + Timeline" ) It's 4 keys.

Also "Cut + Smooth Cut" resets the unit.
- iMac 27" 5K 2019 i9 3.6Ghz 40GB Vega 48 8GB
- MBP 16" 2019 i9 2.3GHz 16GB Radeon Pro 5500M 4GB
- Resolve Studio 17.2.2 @ macOS Catalina 11.5.1
- Mini Panel v1.3.2
- Synology DS218
Offline

rvaclavik

  • Posts: 27
  • Joined: Thu Mar 08, 2018 8:42 pm
  • Real Name: Radek Václavík

Re: Speed Editor bluetooth connection issues

PostThu Oct 28, 2021 5:19 pm

Same here after update to 17.4 I was prompted to update panel to Version 1.4.1, Build 7e520cee. Bluetooth not working anymore. Did anybody found solution?

iMac 27
MacOS Montenery
Offline

TheRVAddict

  • Posts: 8
  • Joined: Wed Nov 11, 2020 9:19 pm
  • Real Name: Kevin Bowen

Re: Speed Editor bluetooth connection issues

PostThu Oct 28, 2021 9:28 pm

I have had similar connection issues where I can not play the timeline because the SE will act like the jog wheel has been moved and it will stop my play or scrubbing through.. the DR screen will sit on a Frame and glitch outas if someone or something is moving the playhead back and forth one frame. Also when rendering, DR will just stop rendering and pass an error with SE is connected using BT.
The only way to work around is use the USB cable.

I reported this problem months ago and the problem WAS confirmed as existing.
Perhaps it is my Windows PC or the Logitech BT dongle that i use ?
I am absolutely willing to switch to another BT dongle that Blackmagic suggests.

This issue really kills my enthusiasm that the SE brings to the program.
Any help is appreciate.

Windows 10 64bit / DR 17.4
Offline

Peter Chamberlain

Blackmagic Design

  • Posts: 11276
  • Joined: Wed Aug 22, 2012 7:08 am

Re: Speed Editor bluetooth connection issues

PostFri Oct 29, 2021 3:59 am

Are the issues just BT related and the USB connection is fine?
DaVinci Resolve Product Manager
Offline

TheRVAddict

  • Posts: 8
  • Joined: Wed Nov 11, 2020 9:19 pm
  • Real Name: Kevin Bowen

Re: Speed Editor bluetooth connection issues

PostFri Oct 29, 2021 4:26 am

Peter, Yes Sir, problem exists only with BT.
Offline

studio1492

  • Posts: 426
  • Joined: Fri Oct 26, 2018 6:22 pm
  • Real Name: Fran Navas

Re: Speed Editor bluetooth connection issues

PostMon Nov 01, 2021 7:59 pm

USB works fine. Only bluetooth, it never worked on my two Macs since I purchased it running DVR17.3.#
- iMac 27" 5K 2019 i9 3.6Ghz 40GB Vega 48 8GB
- MBP 16" 2019 i9 2.3GHz 16GB Radeon Pro 5500M 4GB
- Resolve Studio 17.2.2 @ macOS Catalina 11.5.1
- Mini Panel v1.3.2
- Synology DS218
Offline

svenphon

  • Posts: 1
  • Joined: Thu Aug 05, 2021 10:43 am
  • Real Name: sven seibler

Re: Speed Editor bluetooth connection issues

PostTue Nov 02, 2021 10:34 am

Same here. Resolve Studio 17.4.1, Big Sur 11.5.1 on a iMac Pro 2017, Speed Editor Version 1.02
only works with USB cable connected. Tried all the reset button pushing, but nada.
Via bluetooth no Speed Editor.
Do I have to send it back or is this a software bug which can be fixed? Hm...
iMac Pro 2017 3,2GHz
Radeon Pro VEga 56 8GB
Big Sur
Resolve Studio 17.4.1
Offline

Peter Chamberlain

Blackmagic Design

  • Posts: 11276
  • Joined: Wed Aug 22, 2012 7:08 am

Re: Speed Editor bluetooth connection issues

PostTue Nov 02, 2021 10:57 am

For v17.4.1, you should have the DaVinci Control Panels Setup app, v 2.0.1.

With DaVinci Resolve no running. You need to install DaVinci Resolve 17.4.1 again and this time be sure to install the extras (customize install in Mac) and then update the speed editor via USB with the new DaVinci Control Panels Setup app, v 2.0.1.

Then start Resolve, and verify it works on USB.

Then remove the USB.
If the SE is not seen, from the computer disconnect the BT, then establish a new BT connection.
DaVinci Resolve Product Manager
Offline

peterbaumann

  • Posts: 71
  • Joined: Tue Apr 16, 2019 7:23 pm
  • Real Name: Peter Baumann

Re: Speed Editor bluetooth connection issues

PostFri Nov 05, 2021 12:10 pm

Received my Speed Editor yesterday and it's working fine over USB but Bluetooth is just not working.

Reinstalled DR17 Studio 17.4.1 using the custom install button (ticked all the boxes, only one that wasn't ticked was a Fairlight Accelerator).

Running Panels 2.0.1 the unit is instantly recognised over USB. I disconnected the USB and added the device over Bluetooth to my MacBook Pro. In the Bluetooth preferences on the Mac it connects instantly and is showing in the top menubar with my main keyboard and mouse as being connected. DR Control Panels Setup still says 'No Davinci Control Panels Found'.

Loaded DR17 to test, but none of the Speed Editor controls are functioning (no LEDs either). As soon as I connect the USB cable, the Speed Editor kicks into action in DR17 and pops up in the Control Panels Setup app. Disconnecting the USB cable causes it to it disappear again from Panels and the DR17 Control Panels tab in the Preferences - all buttons stop working but LEDs remain on.
MacBook Pro 15-inch (2018)
OS Catalina 10.15.7
2.6GHz 6-Core Intel Core i7
32GB RAM
Radeon Pro Vega 20 4GB
Offline

dare_dennis

  • Posts: 2
  • Joined: Fri Nov 05, 2021 8:02 pm
  • Real Name: Dionisis Kotopoulos

Re: Speed Editor bluetooth connection issues

PostFri Nov 05, 2021 8:06 pm

peterbaumann wrote:Received my Speed Editor yesterday and it's working fine over USB but Bluetooth is just not working.

Reinstalled DR17 Studio 17.4.1 using the custom install button (ticked all the boxes, only one that wasn't ticked was a Fairlight Accelerator).

Running Panels 2.0.1 the unit is instantly recognised over USB. I disconnected the USB and added the device over Bluetooth to my MacBook Pro. In the Bluetooth preferences on the Mac it connects instantly and is showing in the top menubar with my main keyboard and mouse as being connected. DR Control Panels Setup still says 'No Davinci Control Panels Found'.

Loaded DR17 to test, but none of the Speed Editor controls are functioning (no LEDs either). As soon as I connect the USB cable, the Speed Editor kicks into action in DR17 and pops up in the Control Panels Setup app. Disconnecting the USB cable causes it to it disappear again from Panels and the DR17 Control Panels tab in the Preferences - all buttons stop working but LEDs remain on.



I have exactly the same problem i received it yesterday and cant connect with BT
Offline

dare_dennis

  • Posts: 2
  • Joined: Fri Nov 05, 2021 8:02 pm
  • Real Name: Dionisis Kotopoulos

Re: Speed Editor bluetooth connection issues

PostSat Nov 06, 2021 12:41 pm

Ok. I have found a way after 2 days of trying out things.

I downloaded DaVinci_Resolve_17.1 installed it with SE plugged in with USB. I started the program and a pop up informed that control panel need to update SE.

I did it and it actually downgraded the version.
After that i closed everything unplugged the SE from USB and connect it with bluetooth on my iMac.

Started resolve again and the SE works like a charm with the Bluetooth.

After that i downloaded and install the latest version of resolve.

When it prompted me to update the new control panel drivers... i said no thanks and choose cancel.

Now i have DR 17.4.1 with a working Bluetooth SE

Hope it will work for you.
Offline

TheRVAddict

  • Posts: 8
  • Joined: Wed Nov 11, 2020 9:19 pm
  • Real Name: Kevin Bowen

Re: Speed Editor bluetooth connection issues

PostMon Nov 08, 2021 5:32 pm

MY problems with the Speed editor have gone away after purchasing an "ASUS" brand BT dongle to match the brand of my motherboard (Windows machine).
SE has been working flawless for over a week now connected only via BT.
I Hope this helps someone.
Offline

mikedkelly

  • Posts: 115
  • Joined: Tue Apr 10, 2018 9:31 pm
  • Real Name: Mike Kelly

Re: Speed Editor bluetooth connection issues

PostTue Nov 09, 2021 2:02 pm

I have the same issue. Works fine with USB connected, but when I use Bluetooth, the lights come on but the SE is unresponsive. It is not just that it is unresponsive in Resolve, but the unit seems to be locked. Pressing SHTL, JOG, or SCRL should light the LEDs under those buttons, but it stays lit under Jog and won't change.

-----------------------
Resolve Studio 17.4.1
OS: Windows 11 Home x64, 21H2 Build 22000.258
CPU: Intel i7-8700K
RAM: 32GB
GPU: GTX-1080 8 GB
Driver: Nvidia Studio 472.12
MB: Asus Z390-i Gaming, C: 970 Evo 500 GB, D: 970 Evo 1 TB
Offline

mikedkelly

  • Posts: 115
  • Joined: Tue Apr 10, 2018 9:31 pm
  • Real Name: Mike Kelly

Re: Speed Editor bluetooth connection issues

PostTue Nov 09, 2021 7:52 pm

dare_dennis wrote:When it prompted me to update the new control panel drivers... i said no thanks and choose cancel. Now i have DR 17.4.1 with a working Bluetooth SE


I downgraded mine as well and I'm back in business. I thought that the firmware was tied to the Resolve version, so I am glad that is not the case. I think I will just stick with this SE firmware version from now on.

-----------------------
Resolve Studio 17.4.1
OS: Windows 11 Home x64, 21H2 Build 22000.258
CPU: Intel i7-8700K
RAM: 32GB
GPU: GTX-1080 8 GB
Driver: Nvidia Studio 472.12
MB: Asus Z390-i Gaming, C: 970 Evo 500 GB, D: 970 Evo 1 TB
Offline

GHSteadman

  • Posts: 4
  • Joined: Tue Mar 03, 2020 4:02 pm
  • Real Name: Gary H Steadman

Re: Speed Editor bluetooth connection issues

PostFri Nov 12, 2021 4:49 am

dare_dennis wrote:I downloaded DaVinci_Resolve_17.1 installed it with SE plugged in with USB. I started the program and a pop up informed that control panel need to update SE.

I did it and it actually downgraded the version.
After that i closed everything unplugged the SE from USB and connect it with bluetooth on my iMac.

Started resolve again and the SE works like a charm with the Bluetooth.

After that i downloaded and install the latest version of resolve.

When it prompted me to update the new control panel drivers... i said no thanks and choose cancel.


I followed these instructions precisely on my Mac and unfortunately it fails for me. In Bluetooth mode Davinci Resolve Studio doesn't recognize the Speed Editor. I have made the connection in the Mac via Bluetooth and the Mac sees it fine. If I connect the USB cable then Davinci Resolve works with the Speed Editor just fine. The moment I pull the USB cable DR instantly stops recognizing the Speed Editor.

Frustrating...

It also seems like I can't "wake" the Speed Editor. Once the lights go out they will not come back on until I plug in the USB. If the Speed Editor is disconnected from the USB nothing I do seems to wake it. I've seen recommendations that you need to touch a key on the Speed Editor to wake it just before your launch Davinci Resolve. That's what I'm doing but no life.
Offline

TransylvanianHiker

  • Posts: 6
  • Joined: Sun Sep 22, 2019 2:39 pm
  • Location: Romania
  • Real Name: Patcas Csaba

Re: Speed Editor bluetooth connection issues

PostTue Nov 16, 2021 12:07 am

Similar problems on Windows 10, latest Windows version / nVidia driver / SE firmware / Davinci Resolve Studio version.
I have already tried a complete reinstall, it made things somewhat more stable, but didn't completely solve the problems. Speed Editor works flawlessly using USB. When it works using Bluetooth, it works well. I use a desktop with an Asus BT500 dongle.
-Sometimes the connection is getting lost randomly (every light turns off on the SE), and I have to press the four buttons a couple of times to get it back.
-Sometimes everything works except the wheel.
-Sometimes I have the glitch, where the wheel keeps moving forward and backward continuously.
DaVinci Resolve Studio
Windows 10 64-bit
NVIDIA GeForce GTX 1060 6GB
i7-7700 32GB RAM

Return to DaVinci Resolve

Who is online

Users browsing this forum: crtkecnkl659, Google Feedfetcher, jfykeaucq871, Piotr Wozniacki, Sarasota, Sean Nelson and 65 guests