SRT captions not displaying in media players and Vimeo

Get answers to your questions about color grading, editing and finishing with DaVinci Resolve.
  • Author
  • Message
Offline

JimCurtis

  • Posts: 22
  • Joined: Mon Nov 29, 2021 3:15 pm
  • Real Name: Jim Curtis

SRT captions not displaying in media players and Vimeo

PostFri Dec 03, 2021 9:23 pm

I'm not new to captioning. I've made dozens in Premiere and successfully linked them to files on Vimeo, YouTube and in the VLC and Elmedia players.

However, I just created my first CC SRT in Resolve 17.4.2, and the subtitles/captions not showing up in any of the above platforms.

I can open the SRT in Aegisub, a captioning utility app, and they look identical to SRTs I've made in Premiere.

There was a time when I had to open SRTs fromPr in Aegisub, and immediately export them to SRT to get them to show up on Vimeo. I tried that with my Resolve generated SRTs, and that didn't work either.

I've tried using the Deliver page, exporting from the File menu, and exporting from the Edit page Timeline, both with and without formatting, and still no luck. I've tried turning off all the Styles and formatting in Resolve, read the manual and searched the forum for the secret.

Any ideas what I'm doing wrong?
New Resolve user November 2021 - 25 years with other NLEs: Avid, FCP, Premiere
MacPro7,1 - 2.7 GHz 24-Core Intel Xeon W - 256G RAM - AMD Radeon Pro Vega II 32 GB • ATTO R680 PCIe SAS SCSI RAID6 (8 drives: 1 to 1.5 GB/s io) • OSX 10.15.7 • Resolve 17.4.2.8
Offline

Peter Chamberlain

Blackmagic Design

  • Posts: 11397
  • Joined: Wed Aug 22, 2012 7:08 am

Re: SRT captions not displaying in media players and Vimeo

PostSat Dec 04, 2021 7:45 am

Are the timelines and SRT starting at 00 timecode or 1 hr or different?
DaVinci Resolve Product Manager
Offline

JimCurtis

  • Posts: 22
  • Joined: Mon Nov 29, 2021 3:15 pm
  • Real Name: Jim Curtis

Re: SRT captions not displaying in media players and Vimeo

PostSat Dec 04, 2021 3:08 pm

Sequence starts at 01:00:00:00.

The first caption, according to Aegisub, starts at 1:00:03.59. Does that mean anything?

I ended up doing my captions successfully in Premiere 2022, but I'd sure like to figure out how to stay in Resolve for this. I have two more videos on deck that I'm going to caption.

The Pr generated SRT starts at 0:00:00.00, and it displays properly on Vimeo. My video is 3 min, and I detect NO significant drift in the cut points between captions. I hope that's helpful.
New Resolve user November 2021 - 25 years with other NLEs: Avid, FCP, Premiere
MacPro7,1 - 2.7 GHz 24-Core Intel Xeon W - 256G RAM - AMD Radeon Pro Vega II 32 GB • ATTO R680 PCIe SAS SCSI RAID6 (8 drives: 1 to 1.5 GB/s io) • OSX 10.15.7 • Resolve 17.4.2.8
Offline
User avatar

Andy Mees

  • Posts: 944
  • Joined: Wed Aug 22, 2012 7:48 am

Re: SRT captions not displaying in media players and Vimeo

PostSat Dec 04, 2021 7:37 pm

The SRT output from Resolve correctly matches the timecode of your sequence.
But chances are that the export format of your video file either does not support/embed your sequence timecode or the online media player does not correctly read/use the timecode. Instead the players are using a default start timecode of 00:00:00:00... thats why your subtitles don't appear, because the player is waiting for the timecodes given in the SRT.

Change the start timecode of your sequence in Resolve to 00:00:00, then reexport and reupload the SRT... the online players should then display the subtitles correctly.
Resolve Studio 17.4.3 | Adobe CC 2021 | Desktop Video 12.1
AMD Ryzen 5950X | Windows 10 Pro 20H2 | 64GB RAM | GTX 1060 6GB | 462.31 | Decklink Mini Monitor
M1 MacBook Pro | macOS 11.2.1 | 16GB RAM | Ultrastudio Monitor 3G
V24G2 | WVR5000 | 8020B | USBPre
Offline

JimCurtis

  • Posts: 22
  • Joined: Mon Nov 29, 2021 3:15 pm
  • Real Name: Jim Curtis

Re: SRT captions not displaying in media players and Vimeo

PostSun Dec 05, 2021 8:22 pm

I've already delivered my SRT for that project, but I went back to my Resolve project in which I did the captions, changed the Sequence start to 00:00:00:00, exported the SRT (from the Timeline Subtitle track), and imported into VLC with the video, and now I am seeing the captions.

So, your solution is confirmed. Thank you, Andy! Edited: please see my comment below.
Last edited by JimCurtis on Mon Dec 06, 2021 4:13 pm, edited 1 time in total.
New Resolve user November 2021 - 25 years with other NLEs: Avid, FCP, Premiere
MacPro7,1 - 2.7 GHz 24-Core Intel Xeon W - 256G RAM - AMD Radeon Pro Vega II 32 GB • ATTO R680 PCIe SAS SCSI RAID6 (8 drives: 1 to 1.5 GB/s io) • OSX 10.15.7 • Resolve 17.4.2.8
Offline

JimCurtis

  • Posts: 22
  • Joined: Mon Nov 29, 2021 3:15 pm
  • Real Name: Jim Curtis

Re: SRT captions not displaying in media players and Vimeo

PostMon Dec 06, 2021 4:12 pm

I spoke too soon. My subtitles show up in VLC, but not on Vimeo.
New Resolve user November 2021 - 25 years with other NLEs: Avid, FCP, Premiere
MacPro7,1 - 2.7 GHz 24-Core Intel Xeon W - 256G RAM - AMD Radeon Pro Vega II 32 GB • ATTO R680 PCIe SAS SCSI RAID6 (8 drives: 1 to 1.5 GB/s io) • OSX 10.15.7 • Resolve 17.4.2.8

Return to DaVinci Resolve

Who is online

Users browsing this forum: Bing [Bot], fisentke545, Google [Bot], jjisnow, MarvinBarre, mkloxsfpv659 and 120 guests