Toolbox Titles alters ProRes Video CST colour

Get answers to your questions about color grading, editing and finishing with DaVinci Resolve.
  • Author
  • Message
Offline
User avatar

rick.lang

  • Posts: 15528
  • Joined: Wed Aug 22, 2012 5:41 pm
  • Location: Victoria BC Canada

Toolbox Titles alters ProRes Video CST colour

PostMon Jul 04, 2022 12:25 am

I have a Timeline with mostly CinemaDNG Colour Science 3 clips from URSA Mini 4.6K 4.8 camera and some ProRes Colour Science 4/5 clips from BMPCC4K 7.9 camera.

My Project Settings are set for ACES 1.3 and the raw clips. For the ProRes clips, I use a Colour Space Transform CST node to bypass the Project Settings and refer to the proper codec settings.

That all is all working well and the ProRes clips are a good match to the CDNG clips.

Each raw clip begins with a Titles Lower Thirds Text Box where I have adjusted the Colour of the bottom title and left the top title white. I set handles to permit the video to show below the title gradually. All is good as the Colour corrected video plays as expected.

The problem is that any Text Box I place over the beginning of the ProRes clips alters the colour of the video with CST. It’s an ugly Colour shift where blacks are blacker and the lighter colours have a higher saturated red shift. After the five second title plays there’s a sudden change to the proper Colour of the clip.

I’ve tried for hours to correct this behaviour but nothing works. Tried all Text Settings for Compositing including the default Normal; those changes affect the presentation of text but still have the ugly shift in the background video below. Even cutting the clip and removing the CST from the video directly below the Titles does not stop the ugly Colour shift. That’s not a good solution as then I’m not defining the IDT correctly and it’s basically ungraded.

My workaround is removing the video below the text box so it’s text against a black screen. Better than nothing but I don’t like it; I want it to behave consistently with the text box over the raw files.

Any help appreciated. I’m using Resolve 17.4.6 on Mac Pro 2019 with the latest Big Sur and Pro Vega II GPU.
Rick Lang
Offline
User avatar

shebbe

  • Posts: 412
  • Joined: Tue Mar 06, 2018 11:48 am
  • Location: Amsterdam
  • Real Name: Shebanjah Klaasen

Re: Toolbox Titles alters ProRes Video CST colour

PostMon Jul 04, 2022 10:05 am

I don't see this issue. My settings are ACES 1.3 ACEScct with No Input Transform. Clip is ProRes .mov
I'm getting the same image with or without Lower Third on top. I'm on 18 beta on Windows.
Attachments
7.png
7.png (834.07 KiB) Viewed 513 times
Workstation: ASUS PRIME X299-A / i9 7960X 16c/32t / 64GB DDR4 / 2x EVGA GTX1080Ti / 2x M.2 512GB & 1TB
Offline
User avatar

rick.lang

  • Posts: 15528
  • Joined: Wed Aug 22, 2012 5:41 pm
  • Location: Victoria BC Canada

Re: Toolbox Titles alters ProRes Video CST colour

PostMon Jul 04, 2022 12:15 pm

Thanks for confirming that you’re getting the proper expected results. Can you clarify if your ProRes footage is really ARRI or are you just using those settings and the footage is from another camera? I ask because I’m using the Input Colour Space and Gamma for my BMPCC4K ProRes Film footage.
Rick Lang
Offline
User avatar

shebbe

  • Posts: 412
  • Joined: Tue Mar 06, 2018 11:48 am
  • Location: Amsterdam
  • Real Name: Shebanjah Klaasen

Re: Toolbox Titles alters ProRes Video CST colour

PostMon Jul 04, 2022 1:25 pm

It shouldn't really matter what camera it was if the file is ProRes. Resolve doesn't do anything to it in managed unless there's metadata but even then there shouldn't be a difference as per what you described. The clip shown is from ARRI sample footage website.

You could perhaps doublecheck if it's only happening to your camera footage or to any ProRes file or any file that isn't raw and automatically handled by Resolve.
Workstation: ASUS PRIME X299-A / i9 7960X 16c/32t / 64GB DDR4 / 2x EVGA GTX1080Ti / 2x M.2 512GB & 1TB
Offline

Rick van den Berg

  • Posts: 1064
  • Joined: Tue Jun 02, 2015 7:47 am

Re: Toolbox Titles alters ProRes Video CST colour

PostMon Jul 04, 2022 2:25 pm

i remember this behaviour in RCM with tone mapping set to redIPP2. but i never have this with cst nodes.
Offline

Howard Roll

  • Posts: 1762
  • Joined: Fri Jun 03, 2016 7:50 am

Re: Toolbox Titles alters ProRes Video CST colour

PostMon Jul 04, 2022 2:48 pm

Rick, I can reproduce this on my Catalina MBP, DR18b5. A solution is to convert the text to a compound clip and bypass color management on that clip as well.

Good Luck
Notext.png
Notext.png (576.39 KiB) Viewed 452 times


Text.png
Text.png (618.81 KiB) Viewed 452 times
Offline
User avatar

rick.lang

  • Posts: 15528
  • Joined: Wed Aug 22, 2012 5:41 pm
  • Location: Victoria BC Canada

Re: Toolbox Titles alters ProRes Video CST colour

PostMon Jul 04, 2022 3:23 pm

Thank you for the comments.

My project (mostly using CDNG gen 3) uses ACEScct and AP1, not RCM. I did make some changes to my CST for the BMPCC4K ProRes Film clips based on the earlier snapshot of the suggested CST.

I produce two versions of deliverables: either Rec.709 or sRGB as defined in Project Settings ODT. My Delivery page settings for output gamut/gamma don’t change from “Use Project Settings.” Although it’s more work for me, since I need to copy the altered CST to all my ProRes clips, this approach lets me see if all clips look right before rendering the respective deliverables.

For my ProRes CST, I changed my Output Colour Space from either Rec.709 or sRGB to ACES (AP1) for both and Output Gamma to either sRGB or Rec.709-A as appropriate. When those gammas are selected, the CST checkmarks Apply Forward OOTF. That works for my grade, but I may uncheck it to bring more light to the shadows.

None of these changes I made corrected the problem of the text box altering the video colour unfortunately but I can live with no video under the box if I must. If I do find out what’s wrong, I’ll update this post.
Rick Lang
Offline

Howard Roll

  • Posts: 1762
  • Joined: Fri Jun 03, 2016 7:50 am

Re: Toolbox Titles alters ProRes Video CST colour

PostMon Jul 04, 2022 3:39 pm

rick.lang wrote:None of these changes I made corrected the problem of the text box altering the video colour unfortunately but I can live with no video under the box if I must. If I do find out what’s wrong, I’ll update this post.


Resolve is struggling with compositing of color managed and non-color managed clips. Why not compound and bypass the text box like I suggested, it works perfectly.

Good Luck
Offline
User avatar

rick.lang

  • Posts: 15528
  • Joined: Wed Aug 22, 2012 5:41 pm
  • Location: Victoria BC Canada

Toolbox Titles alters ProRes Video CST colour

PostMon Jul 04, 2022 10:33 pm

Apologies, Howard. I totally missed your first message which was sent I guess while I was either head-down editing or writing my message that followed your message! I’ll give that a try too. Nice you could replicate my problem. A six hour delay as I finished the grading for the performance videos (hopefully).
Rick Lang
Offline
User avatar

rick.lang

  • Posts: 15528
  • Joined: Wed Aug 22, 2012 5:41 pm
  • Location: Victoria BC Canada

Toolbox Titles alters ProRes Video CST colour

PostMon Jul 04, 2022 11:05 pm

Howard, if you create a compound clip, it is necessary to also set Bypass Colour Management for the new compound clip! Both the text box and the video clip have always set Bypass Colour Management for the text and the video. Setting it on the Compound Clip appeared to make this successful! But after the compound clip is rendered, it still has the same Colour shift.
Rick Lang
Offline
User avatar

rick.lang

  • Posts: 15528
  • Joined: Wed Aug 22, 2012 5:41 pm
  • Location: Victoria BC Canada

Re: Toolbox Titles alters ProRes Video CST colour

PostTue Jul 05, 2022 12:28 am

Okay, here’s a pretty good solution with only a small Colour shift. The problem causing the ugly Colour shift under the text box appears to be the CST for the ProRes clips even though Bypass Colour Management is set for the video and the Toolkit Titles text box.

The titles included white and yellow fonts. It plays back cleaner if there are only white font colours, which I’ll do.

I placed text box over a larger graded ProRes clip that included a CST. Then I cut the video clip at the end of the text box.

Removed the CST from the short clip under the text box.

Set Bypass Colour Management for the text box and short video clip.

Let the Smart Cache turn blue over the text box.

The result is an almost perfect render of the text box and the short video clip with a very slight Colour shift but I think the client will not be concerned about it.

As Howard suggested, if I make a compound clip, I get similar good results.

Thank you for the suggestions as they were helpful.
Rick Lang
Offline
User avatar

Marc Wielage

  • Posts: 8393
  • Joined: Fri Oct 18, 2013 2:46 am
  • Location: Hollywood, USA

Re: Toolbox Titles alters ProRes Video CST colour

PostTue Jul 05, 2022 5:30 am

The workaround I'd suggest is to just do the entire show textless, and render all that out. Then in a non-color-managed session, just add the titles. I'd bet that will work.

I have no explanation as to why color management would affect the titles -- it's not supposed to.
marc wielage, csi • VP/color & workflow • chroma | hollywood
Offline
User avatar

shebbe

  • Posts: 412
  • Joined: Tue Mar 06, 2018 11:48 am
  • Location: Amsterdam
  • Real Name: Shebanjah Klaasen

Re: Toolbox Titles alters ProRes Video CST colour

PostTue Jul 05, 2022 9:06 am

Given it was reproduceable on a MBP with different OS on v18b5 it's might be a general Resolve for MacOS problem, or possibly AMD GPU problem. Let's hope BMD gets on this and fix it.
Workstation: ASUS PRIME X299-A / i9 7960X 16c/32t / 64GB DDR4 / 2x EVGA GTX1080Ti / 2x M.2 512GB & 1TB
Offline
User avatar

rick.lang

  • Posts: 15528
  • Joined: Wed Aug 22, 2012 5:41 pm
  • Location: Victoria BC Canada

Re: Toolbox Titles alters ProRes Video CST colour

PostTue Jul 05, 2022 11:51 am

Marc Wielage wrote:… do the entire show textless, and render all that out. Then in a non-color-managed session, just add the titles. I'd bet that will work...


I hadn’t thought of that but I have many music festival promos to do as well and I’ll take that approach if it’s still a problem when I do them this month. I already have rendered many .264 shorts so I can certainly give that a go to verify as an effective workaround for the ProRes clips. The CinemaDNG clips are fine as is and those are the bulk of the clips. Thanks, Marc.
Rick Lang
Offline
User avatar

rick.lang

  • Posts: 15528
  • Joined: Wed Aug 22, 2012 5:41 pm
  • Location: Victoria BC Canada

Re: Toolbox Titles alters ProRes Video CST colour

PostTue Jul 05, 2022 12:09 pm

shebbe wrote:Given it was reproduceable on a MBP with different OS on v18b5… Let's hope BMD gets on this and fix it.


I won’t be able to submit this to BMD Support for awhile unfortunately as I have other priorities. It’s easy to verify as Howard’s post indicates. And it’s almost totally correct if the underlying video clip doesn’t use a CST or coloured text.

It would be interesting to see how a Toolbox Titles Text+ box fared. I can’t try that for a bit, but I should do that as well.

My use case was ACEScct AP1, but if I’m filing a report, I’d investigate RCM and non-managed to be thorough. I know ACES isn’t fully defined yet but it may be reasonable to use it as I’ve been doing without issue.
Rick Lang
Offline
User avatar

rick.lang

  • Posts: 15528
  • Joined: Wed Aug 22, 2012 5:41 pm
  • Location: Victoria BC Canada

Re: Toolbox Titles alters ProRes Video CST colour

PostThu Jul 21, 2022 5:57 pm

Thank you for the DaVinci Resolve Studio 18 release today! This new release easily solved the problem described in this thread.

To summarize I have a single music festival video timeline with clips shot on my UM4.6K Gen 3 in CinemaDNG and BMPCC4K Gen 5 ProRes. Using ACEScct 1.3 (AP1) in Resolve 17.4.x, I found when I placed a test box above every song that the colour was affected for the Gen 5 ProRes clip beneath and the actual text Colour was also altered even though I used Bypass Colour Management and a CST.

The issue has been that ACES was not completely defined in Resolve for Gen 5. However Resolve 18 has added Gen 5.

The solution was to:
select the ProRes clips in the Media Page,
right click for ACES Input Transform,
mouse over Blackmagic Design,
select Blackmagic Design Film Gen5.

In the Colour page, I then removed the Bypass Colour Management and the CST because ACES understood how to handle my ProRes Gen 5 input now.

Simple solution. Happy camper. Everything now plays back exactly as you would expect without weird text or incorrect colour for the ProRes clips below the box.
Rick Lang

Return to DaVinci Resolve

Who is online

Users browsing this forum: Baidu [Spider], panos_mts and 68 guests