MXF encoding causes titles to block badly

Get answers to your questions about color grading, editing and finishing with DaVinci Resolve.
  • Author
  • Message
Offline

Ingo Schmoll

  • Posts: 79
  • Joined: Thu Oct 12, 2017 7:21 pm

MXF encoding causes titles to block badly

PostWed Mar 23, 2022 1:53 pm

Hi, today I noticed again that when exporting files to MXF Formats such as XDCAM HD or any other MXF file format title fonts glitch badly giving a lot of blocky artefacts. When exporting the same file to ProRes for example it is all fine. Even if I take the successfully rendered ProRes and export THAT to MXF the titles still go glitchy.

I need to export to MXF so often for clients and this is just not acceptable. I had to take the ProRes Ive rendered in Davinci , import that into Premiere and only then I was able to export without any issues. Attached you can see what happens to the font when exporting MXF in Davinci. Im on the latest version on a M1 Max Mac Pro. Thanks!

EDIT: I just noticed that when I launch Davinci on the M1 Max in Rosetta emuation the MXF files export fine. BUT with M1 Macs there obviously is a serious glitch. Setting down the render speed in Davinci does not solve this issue either. So for now I can only work in Rosetta emulation mode...


Screenshot 2022-03-23 at 14.52.37.jpg
Screenshot 2022-03-23 at 14.52.37.jpg (308.11 KiB) Viewed 13465 times
Offline

Steve Alexander

  • Posts: 2134
  • Joined: Mon Mar 23, 2015 2:15 am

Re: MXF encoding causes titles to block badly

PostWed Mar 23, 2022 2:46 pm

Is this just a standard title or is this Title+ (Fusion) title? I thought I might give it a try to see if I can reproduce. I'm assuming I can just put a title over a clip on an UHD p23.976 timeline and then export on the deliver page as MXF using something like DNxHR and I should see the same issue, is that correct?
Time Traveller
Resolve Studio 18.1.1 | Fusion Studio 18.1.1 | Win 11 Pro (22H2) | i9-7940x, P4000 (517.40, 8GB VRAM), 64GB RAM, M.2 boot, SSD scratch, RAID10 data | (laptop) 16" MacBook Pro M1 MAX, 32 GPU cores, 64 GB RAM, 2 TB SSD, Ventura 13.0.1
Offline

Uli Plank

  • Posts: 15790
  • Joined: Fri Feb 08, 2013 2:48 am
  • Location: Germany and Indonesia

Re: MXF encoding causes titles to block badly

PostWed Mar 23, 2022 3:39 pm

Does it happen too if you encode the same codecs into a MOV container?
The software may be free, but the hardware needed for smooth performance is not.

Resolve Studio 18.1, MacOS 12.6.1
MacBook M1 Pro, 16 GPU cores, 32 GB RAM
and
iMac 2017, Radeon 580, 32 GB RAM
Speed Editor
Offline

Andrew Kolakowski

  • Posts: 8678
  • Joined: Tue Sep 11, 2012 10:20 am
  • Location: Poland

Re: MXF encoding causes titles to block badly

PostWed Mar 23, 2022 5:42 pm

Looks like this is M1 related problem. XDCAM MXF encoder is a Sony library if I'm correct, so this will probably need new version for M1.
Report to BM directly, so they can fix it.
Are you on latest OSX?
Try watching this files on some PC or some other player than QTX as it may be also just decoding problem.
Offline

Ingo Schmoll

  • Posts: 79
  • Joined: Thu Oct 12, 2017 7:21 pm

Re: MXF encoding causes titles to block badly

PostThu Mar 24, 2022 12:45 am

Steve Alexander wrote:Is this just a standard title or is this Title+ (Fusion) title? I thought I might give it a try to see if I can reproduce. I'm assuming I can just put a title over a clip on an UHD p23.976 timeline and then export on the deliver page as MXF using something like DNxHR and I should see the same issue, is that correct?


Yes Steve just standard titles, no title+ or fusion or anything. The titles are also not in any way keyframed, moving or animated. And yes you can try and put a title over a clip and then export on the deliver page as MXF. I tried XDCAM HD and AVC Intra codecs .Since Im in Europe I export in 25p for tv broadcast over here. As you can see I used the font in a rather large format over the picture.
Offline

Ingo Schmoll

  • Posts: 79
  • Joined: Thu Oct 12, 2017 7:21 pm

Re: MXF encoding causes titles to block badly

PostThu Mar 24, 2022 12:47 am

Uli Plank wrote:Does it happen too if you encode the same codecs into a MOV container?


Hi Uli, how do you put XDCAM HD or AVC Intra into a MOV container. Is that even possible?
Offline

Ingo Schmoll

  • Posts: 79
  • Joined: Thu Oct 12, 2017 7:21 pm

Re: MXF encoding causes titles to block badly

PostThu Mar 24, 2022 12:58 am

Andrew Kolakowski wrote:Looks like this is M1 related problem. XDCAM MXF encoder is a Sony library if I'm correct, so this will probably need new version for M1.
Report to BM directly, so they can fix it.
Are you on latest OSX?
Try watching this files on some PC or some other player than QTX as it may be also just decoding problem.



Hi Andrew, It certainly looks to me that it is M1 related all the way. I did issue a bug report to BM already. I am on the very latest OSX. And no, its unfortunately no decoding problem. Other PCs and Players will playback the issue exactly the same.

So my first workaround has been to render the file out as ProRes instead and the glitch is gone, BUT and here its gets even crazier. If I now take the rendered ProRes file and re-encode it to MXF the glitches are visible again even though Im not even having any separate titles anymore in my timeline, but only the rendered ProRes file with the titles!

So ust for fun I also tried to import the ProRes file into Adobe Premiere and render it out from there as MXF and it worked just fine. So this issue is limited to DaVinci Resolve.

My next workaround was to launch Davinci by using the Rosetta emulation option which also makes the issue disappear. But obviously I would like to use Resolve without the need to emulate via Rosetta.
Offline

Uli Plank

  • Posts: 15790
  • Joined: Fri Feb 08, 2013 2:48 am
  • Location: Germany and Indonesia

Re: MXF encoding causes titles to block badly

PostThu Mar 24, 2022 2:16 am

You are right, by spec it's limited to MXF, I was just thinking about a test.
But you already narrowed it down, it looks like a bug on your system. The MainConcept plug-in would be an alternative, unfortunately BM broke it in 17.4.5.

Can you give me all details about your title setting, like font and the specific effect? Or send me the .drp?

I can't reproduce the problem here on M1, neither in Sony XAVC nor in XDCAM:
Sony_XAVC.jpg
Sony_XAVC.jpg (1014.37 KiB) Viewed 12975 times
The software may be free, but the hardware needed for smooth performance is not.

Resolve Studio 18.1, MacOS 12.6.1
MacBook M1 Pro, 16 GPU cores, 32 GB RAM
and
iMac 2017, Radeon 580, 32 GB RAM
Speed Editor
Offline

Ingo Schmoll

  • Posts: 79
  • Joined: Thu Oct 12, 2017 7:21 pm

Re: MXF encoding causes titles to block badly

PostThu Mar 24, 2022 11:22 am

Uli Plank wrote:You are right, by spec it's limited to MXF, I was just thinking about a test.
But you already narrowed it down, it looks like a bug on your system. The MainConcept plug-in would be an alternative, unfortunately BM broke it in 17.4.5.

Can you give me all details about your title setting, like font and the specific effect? Or send me the .drp?

I can't reproduce the problem here on M1, neither in Sony XAVC nor in XDCAM:
Sony_XAVC.jpg


Here's a link the drp of the project:https://www.dropbox.com/s/tk44cs5abpqalk5/TEST%20TITLE.drp?dl=0

And here's a link to the failed MXF encode:
https://www.dropbox.com/s/r8saq8dk25tzd ... R.mxf?dl=0

As you can see the problem will not happen throughout the whole clip but only in some places. So some titles work fine just like when you tried it out, but then at some point it just randomly happens.

Ive also dont have any other effects on the video track since that was already finished. So basically it is only 1 video track, no effects and the titles on top. Extremely simple really which means several factors that could cause this error are not even in play here.

Thank you
Offline

Steve Alexander

  • Posts: 2134
  • Joined: Mon Mar 23, 2015 2:15 am

Re: MXF encoding causes titles to block badly

PostThu Mar 24, 2022 12:36 pm

I tried your DRP but for media I didn't have any ProRes so I used some Sony XAVC-L media (not sure if that matters). Otherwise I just exported using your settings from the DRP and then brought the resulting MXF back into Resolve where it played flawlessly.
Time Traveller
Resolve Studio 18.1.1 | Fusion Studio 18.1.1 | Win 11 Pro (22H2) | i9-7940x, P4000 (517.40, 8GB VRAM), 64GB RAM, M.2 boot, SSD scratch, RAID10 data | (laptop) 16" MacBook Pro M1 MAX, 32 GPU cores, 64 GB RAM, 2 TB SSD, Ventura 13.0.1
Offline

Ingo Schmoll

  • Posts: 79
  • Joined: Thu Oct 12, 2017 7:21 pm

Re: MXF encoding causes titles to block badly

PostThu Mar 24, 2022 1:10 pm

Steve Alexander wrote:I tried your DRP but for media I didn't have any ProRes so I used some Sony XAVC-L media (not sure if that matters). Otherwise I just exported using your settings from the DRP and then brought the resulting MXF back into Resolve where it played flawlessly.


Thanks for trying that out. That is actually strange, but then again, what could actually cause this? You are running without Rosetta emulation, right? Because if I start up Resolve using Rosetta the issue does not occur. Same project file and everything. Ive even lowered the render speed because on the M1 Max that sometimes causes issues when rendering at full speed, but that also didn't help.
Offline

Steve Alexander

  • Posts: 2134
  • Joined: Mon Mar 23, 2015 2:15 am

Re: MXF encoding causes titles to block badly

PostThu Mar 24, 2022 1:48 pm

No, I'm not running Resolve under Rosetta. Maybe you could repeat the test using some other media on V1 - perhaps transcode your ProRes media to DNxHD and place that on V1/A1 to remove the possibility that the issue is to do with decoding of ProRes during delivery (since M1 has special ProRes descoding engine - you never know). That's the only obvious difference between my test and yours that I can think of.
Time Traveller
Resolve Studio 18.1.1 | Fusion Studio 18.1.1 | Win 11 Pro (22H2) | i9-7940x, P4000 (517.40, 8GB VRAM), 64GB RAM, M.2 boot, SSD scratch, RAID10 data | (laptop) 16" MacBook Pro M1 MAX, 32 GPU cores, 64 GB RAM, 2 TB SSD, Ventura 13.0.1
Offline

Ingo Schmoll

  • Posts: 79
  • Joined: Thu Oct 12, 2017 7:21 pm

Re: MXF encoding causes titles to block badly

PostThu Mar 24, 2022 1:49 pm

Ingo Schmoll wrote:
Steve Alexander wrote:I tried your DRP but for media I didn't have any ProRes so I used some Sony XAVC-L media (not sure if that matters). Otherwise I just exported using your settings from the DRP and then brought the resulting MXF back into Resolve where it played flawlessly.


Ok, I think I found something. My ProRes clip in the HD timeline is actually in UHD resolution. When exporting that to MXF with the titles the issue does occur as we know. So instead Ive used the same source footage, but an HD version instead of UHD and when I render that out to MXF the issue does not occur. So it must be related to Davinci acting buggy when UHD Prores footage is used in this way.

In order to confirm this I've made a short UHD ProRes (no sound) for you with scenes from the same clip. Maybe if you could download that and see if the issue can then be replicated on your M1 Mac now. Here it is:

https://www.dropbox.com/s/6z602mvl4q7ss ... S.mov?dl=0

Also, Ive used this exact free font: https://fonts.google.com/specimen/Raleway
Offline

Uli Plank

  • Posts: 15790
  • Joined: Fri Feb 08, 2013 2:48 am
  • Location: Germany and Indonesia

Re: MXF encoding causes titles to block badly

PostThu Mar 24, 2022 1:51 pm

I just tested with ProRes 422 HQ footage in UHD on V1 and there is no problem, neither in XDCAM nor in XAVC.
The test files are uploading to my DropBox right now. I'm running natively too, no Rosetta.

Ready:
https://www.dropbox.com/s/twwrxnbh4wpxtek/XAVC.mxf?dl=0
https://www.dropbox.com/s/za5fzatuf4m41 ... M.mxf?dl=0

I have tried Raleway too, no problem.
The software may be free, but the hardware needed for smooth performance is not.

Resolve Studio 18.1, MacOS 12.6.1
MacBook M1 Pro, 16 GPU cores, 32 GB RAM
and
iMac 2017, Radeon 580, 32 GB RAM
Speed Editor
Offline

Steve Alexander

  • Posts: 2134
  • Joined: Mon Mar 23, 2015 2:15 am

Re: MXF encoding causes titles to block badly

PostThu Mar 24, 2022 2:15 pm

I tested it with your UHD ProRes mov file and I did see the issue on a single frame. So I have replicated the issue.

I then transcoded your ProRes to DNxHR SQ MXF and replaced your ProRes footage with the DNxHR footage and could not reproduce the issue.

Would you please try the same?

I'm also wondering why you have specified interlaced rendering in your delivery page for your XDCAM MPEG2 - Does this affect the result if this checkbox is cleared? I've never rendered to XDCAM MPEG2 before so I'm just asking.
Last edited by Steve Alexander on Thu Mar 24, 2022 2:28 pm, edited 1 time in total.
Time Traveller
Resolve Studio 18.1.1 | Fusion Studio 18.1.1 | Win 11 Pro (22H2) | i9-7940x, P4000 (517.40, 8GB VRAM), 64GB RAM, M.2 boot, SSD scratch, RAID10 data | (laptop) 16" MacBook Pro M1 MAX, 32 GPU cores, 64 GB RAM, 2 TB SSD, Ventura 13.0.1
Offline

Andrew Kolakowski

  • Posts: 8678
  • Joined: Tue Sep 11, 2012 10:20 am
  • Location: Poland

Re: MXF encoding causes titles to block badly

PostThu Mar 24, 2022 2:18 pm

I think it's purely related to MXF XDCAM encoder (maybe to interlaced mode as mentioned).
These artefacts were reported in the past, no?
Looks like they are back.
Offline

Andrew Kolakowski

  • Posts: 8678
  • Joined: Tue Sep 11, 2012 10:20 am
  • Location: Poland

Re: MXF encoding causes titles to block badly

PostThu Mar 24, 2022 2:20 pm

Uli Plank wrote:
I can't reproduce the problem here on M1, neither in Sony XAVC nor in XDCAM:


Try ticking interlaced mode.
Offline

Ingo Schmoll

  • Posts: 79
  • Joined: Thu Oct 12, 2017 7:21 pm

Re: MXF encoding causes titles to block badly

PostThu Mar 24, 2022 5:55 pm

Steve Alexander wrote:I tested it with your UHD ProRes mov file and I did see the issue on a single frame. So I have replicated the issue.

I then transcoded your ProRes to DNxHR SQ MXF and replaced your ProRes footage with the DNxHR footage and could not reproduce the issue.

Would you please try the same?

I'm also wondering why you have specified interlaced rendering in your delivery page for your XDCAM MPEG2 - Does this affect the result if this checkbox is cleared? I've never rendered to XDCAM MPEG2 before so I'm just asking.


Hi Steve , its kind of good to hear that you were able to replicate the issue. At least I can be certain its not just me where this happens.

So I tried your approach and transcoded the ProRes UHD to DNxHR SQ MXF UHD and also to DNxHR SQ MXF HD resolution. Ive replaced the ProResHQ in my timeline first with the DNxHR SQ MXF UHD and the issue still happened after exporting XDCAM HD even with interlaced unticked. I then tried with the DNxHR SQ MXF HD and once again the glitch occurred. So we get different results still it seems.

As I mentioned in a previous post the glitch does not happen if I use ProRes HD instead of ProRes UHD in the project, but obviously with the DNxHR files it occurs with both the UHD and the HD files. My guess is also that there is some issue with the MXF decoders in Davinci.
Offline

Steve Alexander

  • Posts: 2134
  • Joined: Mon Mar 23, 2015 2:15 am

Re: MXF encoding causes titles to block badly

PostThu Mar 24, 2022 6:56 pm

Great that you ruled-out ProRes as the root cause. Since I only saw the glitch on a single frame, it is possible that I would need to test multiple times to see if it actually happens with other media. Maybe the problem is more to do with the way the UHD is transcoded by the XDCAM MPEG2 encoder as Andrew suggested.
Time Traveller
Resolve Studio 18.1.1 | Fusion Studio 18.1.1 | Win 11 Pro (22H2) | i9-7940x, P4000 (517.40, 8GB VRAM), 64GB RAM, M.2 boot, SSD scratch, RAID10 data | (laptop) 16" MacBook Pro M1 MAX, 32 GPU cores, 64 GB RAM, 2 TB SSD, Ventura 13.0.1
Offline

Rick van den Berg

  • Posts: 1135
  • Joined: Tue Jun 02, 2015 7:47 am

Re: MXF encoding causes titles to block badly

PostThu Mar 24, 2022 8:52 pm

I noticed exactly the same artifacts with the XDCAM encoder a few versions ago, but on a windows system. But it wasn't just in titles, it was mostly in all pure white parts of the frame.
Offline

Ingo Schmoll

  • Posts: 79
  • Joined: Thu Oct 12, 2017 7:21 pm

Re: MXF encoding causes titles to block badly

PostFri Mar 25, 2022 12:54 am

Rick van den Berg wrote:I noticed exactly the same artifacts with the XDCAM encoder a few versions ago, but on a windows system. But it wasn't just in titles, it was mostly in all pure white parts of the frame.


It would make sense that you saw it in other white parts also because the thing is I’ve even tried out was render a version of my clip in ProRes which worked fine and then re-rendered that clip with the now baked in titles to MXF. Guess what the glitches happened again. Not just when the titles are actually part of the timeline, but even if they are the whitest part of a clip rendered to MXF
Offline

Uli Plank

  • Posts: 15790
  • Joined: Fri Feb 08, 2013 2:48 am
  • Location: Germany and Indonesia

Re: MXF encoding causes titles to block badly

PostFri Mar 25, 2022 1:05 am

I tried to tick interlaced for another render. No artefacts.
It wouldn't make much sense, since the timeline I received was not set to interlaced rendering anyway.

Did you ever try to reduce the white just a little bit, like 98% instead of 100%?
The software may be free, but the hardware needed for smooth performance is not.

Resolve Studio 18.1, MacOS 12.6.1
MacBook M1 Pro, 16 GPU cores, 32 GB RAM
and
iMac 2017, Radeon 580, 32 GB RAM
Speed Editor
Offline

Andrew Kolakowski

  • Posts: 8678
  • Joined: Tue Sep 11, 2012 10:20 am
  • Location: Poland

Re: MXF encoding causes titles to block badly

PostFri Mar 25, 2022 9:08 am

Ticking interlaced switches encoder to different mode, so it’s different case.
Offline

nucelar

  • Posts: 61
  • Joined: Thu Mar 21, 2013 10:03 am

Re: MXF encoding causes titles to block badly

PostFri Mar 25, 2022 11:29 am

My bet is that there is a white level overshoot that overflows the encoder somehow.
As suggested by Uli, try very light gray instead of pure white, to see what happens,
You can also try to slighly blur the text to make the black to white transition less abrupt, to see what happens.

In any case It seems a bug in the xdcam encoder
Offline

Andrew Kolakowski

  • Posts: 8678
  • Joined: Tue Sep 11, 2012 10:20 am
  • Location: Poland

Re: MXF encoding causes titles to block badly

PostFri Mar 25, 2022 3:41 pm

Very possible.
Offline

Uli Plank

  • Posts: 15790
  • Joined: Fri Feb 08, 2013 2:48 am
  • Location: Germany and Indonesia

Re: MXF encoding causes titles to block badly

PostSat Mar 26, 2022 2:57 am

I've seen such problems with Sony encoders on 100% white before, even if not on text.
Which is ridiculous, when Sony is the manufacturer of most cameras that record so-called Superwhites.
So, I'd say it's worth a try, since the final look of slightly darker white will not be that different.
The software may be free, but the hardware needed for smooth performance is not.

Resolve Studio 18.1, MacOS 12.6.1
MacBook M1 Pro, 16 GPU cores, 32 GB RAM
and
iMac 2017, Radeon 580, 32 GB RAM
Speed Editor
Offline

Ingo Schmoll

  • Posts: 79
  • Joined: Thu Oct 12, 2017 7:21 pm

Re: MXF encoding causes titles to block badly

PostSat Mar 26, 2022 3:25 pm

Uli Plank wrote:I've seen such problems with Sony encoders on 100% white before, even if not on text.
Which is ridiculous, when Sony is the manufacturer of most cameras that record so-called Superwhites.
So, I'd say it's worth a try, since the final look of slightly darker white will not be that different.


Ive just tried it and this actually makes it way better, but doesn't eliminate the problem completely. Id say when I pull the slider from white to quite grey (see attachment) the glitches are reduced by about 80%.

attachment=0]Screenshot 2022-03-26 at 16.22.33.jpg[/attachment]
Attachments
Screenshot 2022-03-26 at 16.22.33.jpg
Screenshot 2022-03-26 at 16.22.33.jpg (54.98 KiB) Viewed 12344 times
Offline

Andrew Kolakowski

  • Posts: 8678
  • Joined: Tue Sep 11, 2012 10:20 am
  • Location: Poland

Re: MXF encoding causes titles to block badly

PostSat Mar 26, 2022 5:04 pm

Those Sony libraries are used in other tools as well and I've never seen problem outside Resolve.
Must be some issue between Resolve engine and encoder.
Offline

Uli Plank

  • Posts: 15790
  • Joined: Fri Feb 08, 2013 2:48 am
  • Location: Germany and Indonesia

Re: MXF encoding causes titles to block badly

PostSun Mar 27, 2022 2:02 am

Second that. BM definitely needs to look into this one.
The software may be free, but the hardware needed for smooth performance is not.

Resolve Studio 18.1, MacOS 12.6.1
MacBook M1 Pro, 16 GPU cores, 32 GB RAM
and
iMac 2017, Radeon 580, 32 GB RAM
Speed Editor
Offline

MarkSpano

  • Posts: 12
  • Joined: Fri May 03, 2019 5:59 pm
  • Real Name: Mark Spano

Re: MXF encoding causes titles to block badly

PostSat Apr 23, 2022 5:09 am

I have a lot of XDCAM MXF (MPEG-2) deliveries to make and have been using this system for a while with no issues:

Mac Pro 2019
OS 11.6.5
Resolve 17.4.5

I just recently got a new system for offloading fast renders, and experienced this glitchy artifacting on my XDCAM MXF renders for the first time. The new system is:

Mac Studio 2022 M1 Ultra
OS 12.3.1
Resolve 17.4.5

The errors imitate the above precisely. It is 100% reproducible on the M1 system, and 100% clean on the Intel system, using the exact same export settings. Rendering on the M1 system to ProRes does not exhibit the issue.

Errors appear on 100% white content and are intermittent but obvious.

Normal (ProRes) output:
Image

Glitchy (XDCAM MXF) output:
Image
Offline
User avatar

iddos-l

  • Posts: 659
  • Joined: Sat Mar 30, 2019 7:55 pm
  • Real Name: iddo lahman

Re: MXF encoding causes titles to block badly

PostSat Apr 23, 2022 7:22 am

This really needs to be addressed!



Sent from my iPhone using Tapatalk
Offline

MarkSpano

  • Posts: 12
  • Joined: Fri May 03, 2019 5:59 pm
  • Real Name: Mark Spano

Re: MXF encoding causes titles to block badly

PostThu Apr 28, 2022 4:01 pm

gonna bump this to see if anyone from BM can address…
Offline

Dejan Špagnut

  • Posts: 56
  • Joined: Sun Jun 21, 2015 2:45 pm
  • Location: Belgrade, Serbia

Re: MXF encoding causes titles to block badly

PostThu Apr 28, 2022 7:00 pm

I’ve had the same issues when exporting xdcamhd mxf with pure white areas on the M1 MacMini in Resolve Studio 17.4.x versions. Same material exports just fine on an 2015 Intel MacBookPro in Resolve Studio 17.2.2
Offline

Uli Plank

  • Posts: 15790
  • Joined: Fri Feb 08, 2013 2:48 am
  • Location: Germany and Indonesia

Re: MXF encoding causes titles to block badly

PostThu Apr 28, 2022 8:51 pm

Did you try the MainConcept plug-in as a workaround?
The software may be free, but the hardware needed for smooth performance is not.

Resolve Studio 18.1, MacOS 12.6.1
MacBook M1 Pro, 16 GPU cores, 32 GB RAM
and
iMac 2017, Radeon 580, 32 GB RAM
Speed Editor
Offline

MarkSpano

  • Posts: 12
  • Joined: Fri May 03, 2019 5:59 pm
  • Real Name: Mark Spano

Re: MXF encoding causes titles to block badly

PostThu Apr 28, 2022 9:19 pm

No - why would I do this? Pay for another product when the functionality is built in to Resolve and just broken?
The workaround is already stated - an Intel Mac does it. M1 render is bugged, and I'm hoping Blackmagic can look into it.
Offline

Uli Plank

  • Posts: 15790
  • Joined: Fri Feb 08, 2013 2:48 am
  • Location: Germany and Indonesia

Re: MXF encoding causes titles to block badly

PostFri Apr 29, 2022 12:19 am

Since it happens in 18 too, you should post it in the beta subform. I'm sure the developers monitor that.
I suggested to try the demo by MainConcept to narrow down the issue: is it M1 or the software?
The software may be free, but the hardware needed for smooth performance is not.

Resolve Studio 18.1, MacOS 12.6.1
MacBook M1 Pro, 16 GPU cores, 32 GB RAM
and
iMac 2017, Radeon 580, 32 GB RAM
Speed Editor
Offline

MarkSpano

  • Posts: 12
  • Joined: Fri May 03, 2019 5:59 pm
  • Real Name: Mark Spano

Re: MXF encoding causes titles to block badly

PostFri Apr 29, 2022 2:37 am

It is interesting to know that it happens in v18. However, I am not a beta user, so I would not post about issues with betas. I am only a release version user, and this is where the issue lies for me. I have no use for Resolve 18 for at least 6 months presumably, but I have a use for a solution to be mended into the release version. Someone else can post about problems with betas.
Offline
User avatar

Helge Tjelta

  • Posts: 136
  • Joined: Fri Mar 08, 2013 8:07 am
  • Location: Oslo, NORWAY

Re: MXF encoding causes titles to block badly

PostThu Oct 06, 2022 12:12 pm

Still there on 18.0.4 on my M1
Attachments
XDCam_problems_on_m1.png
Difference Prores vs XDcam
XDCam_problems_on_m1.png (346.34 KiB) Viewed 11310 times
Offline
User avatar

Dwaine Maggart

Blackmagic Design

  • Posts: 9817
  • Joined: Wed Aug 22, 2012 2:53 pm

Re: MXF encoding causes titles to block badly

PostThu Oct 06, 2022 4:06 pm

We're not able to reproduce this. Could you provide a link to a project archive .dra zip that will reproduce the issue for you, along with a Resolve diagnostics log?
Dwaine Maggart
Blackmagic Design DaVinci Support
Offline

MarkSpano

  • Posts: 12
  • Joined: Fri May 03, 2019 5:59 pm
  • Real Name: Mark Spano

Re: MXF encoding causes titles to block badly

PostThu Oct 06, 2022 4:38 pm

I've got one for you.

Simple project with my aforementioned ESPN+ logo (see GIFs above).

Resolve 17.4.5 project, with the ProRes HQ source file. I've also included sample renders from the Intel Mac Pro and the Mac Studio M1 Ultra. Clear render on the Intel, glitchy render on the M1.

https://drive.google.com/drive/folders/1RoR7xqzRCVtmJq7D7QMx31reMadqlJ5O?usp=sharing

Logs included as well.
Offline
User avatar

Dwaine Maggart

Blackmagic Design

  • Posts: 9817
  • Joined: Wed Aug 22, 2012 2:53 pm

Re: MXF encoding causes titles to block badly

PostThu Oct 06, 2022 11:48 pm

Thanks. That does allow us to repro the issue on Apple M1.
Dwaine Maggart
Blackmagic Design DaVinci Support
Offline
User avatar

Helge Tjelta

  • Posts: 136
  • Joined: Fri Mar 08, 2013 8:07 am
  • Location: Oslo, NORWAY

Re: MXF encoding causes titles to block badly

PostFri Oct 07, 2022 6:21 am

Hi Dwaine, I've sendt a PM to you, but is says still in outbox, not in send box ?
Offline
User avatar

Helge Tjelta

  • Posts: 136
  • Joined: Fri Mar 08, 2013 8:07 am
  • Location: Oslo, NORWAY

Re: MXF encoding causes titles to block badly

PostFri Oct 07, 2022 1:53 pm

Looking from a program Bitrate Analyzer, the bitrate goes up to 57000 and 58000 at those seconds in my projects output...

So something goes wild with a lot of whites...
Offline
User avatar

GregAusina

  • Posts: 177
  • Joined: Thu Aug 23, 2012 7:30 pm
  • Location: Paris - France

Re: MXF encoding causes titles to block badly

PostThu Oct 13, 2022 4:56 pm

Dwaine Maggart wrote:Thanks. That does allow us to repro the issue on Apple M1.


I have the same issue on my Windows machines running 18.0.4. Do you want a dra from a windows machine as well?
Grégoire AUSINA / Gisèle productions
Davinci 18.1.1 on Windows 10 (22H2) / Nvidia studio driver 526.98/ Dual Xeon E-2650v4 / supermicro X10DRG-Q / 128 Go RAM / GUI GTX 1070 / Cuda GTX 3090 - FSI CM250 - Tangent Elements - Accusys A12S3-p+
Offline
User avatar

Dwaine Maggart

Blackmagic Design

  • Posts: 9817
  • Joined: Wed Aug 22, 2012 2:53 pm

Re: MXF encoding causes titles to block badly

PostThu Oct 13, 2022 5:19 pm

Sure. Along with a Resolve diagnostics log please. Generate that from the Resolve Help menu.
Dwaine Maggart
Blackmagic Design DaVinci Support
Offline
User avatar

Helge Tjelta

  • Posts: 136
  • Joined: Fri Mar 08, 2013 8:07 am
  • Location: Oslo, NORWAY

Re: MXF encoding causes titles to block badly

PostThu Oct 13, 2022 7:12 pm

GregAusina wrote:
Dwaine Maggart wrote:Thanks. That does allow us to repro the issue on Apple M1.


I have the same issue on my Windows machines running 18.0.4. Do you want a dra from a windows machine as well?



Well, this is no good... I thought it only was M1 mac... but I don't get it on my Intel iMac...
What machine are you running windows on? i.e. what CPU brand, etc.

Was this problem on the Dual Xeon E-2650v4 / supermicro X10DRG-Q machine of yours ?
Offline
User avatar

GregAusina

  • Posts: 177
  • Joined: Thu Aug 23, 2012 7:30 pm
  • Location: Paris - France

Re: MXF encoding causes titles to block badly

PostThu Oct 13, 2022 8:07 pm

Dwaine Maggart wrote:Sure. Along with a Resolve diagnostics log please. Generate that from the Resolve Help menu.

I'll do that tomorrow morning ( Paris GMT+2) . Meanwhile if you want to reproduce it happens only if you render mxfop1a XDCAM422 ( field rendering or not ). Other codecs don't show the issue.
Regards.
Grégoire AUSINA / Gisèle productions
Davinci 18.1.1 on Windows 10 (22H2) / Nvidia studio driver 526.98/ Dual Xeon E-2650v4 / supermicro X10DRG-Q / 128 Go RAM / GUI GTX 1070 / Cuda GTX 3090 - FSI CM250 - Tangent Elements - Accusys A12S3-p+
Offline
User avatar

GregAusina

  • Posts: 177
  • Joined: Thu Aug 23, 2012 7:30 pm
  • Location: Paris - France

Re: MXF encoding causes titles to block badly

PostThu Oct 13, 2022 8:12 pm

Helge Tjelta wrote:
GregAusina wrote:
Dwaine Maggart wrote:Thanks. That does allow us to repro the issue on Apple M1.


I have the same issue on my Windows machines running 18.0.4. Do you want a dra from a windows machine as well?



Well, this is no good... I thought it only was M1 mac... but I don't get it on my Intel iMac...
What machine are you running windows on? i.e. what CPU brand, etc.

Was this problem on the Dual Xeon E-2650v4 / supermicro X10DRG-Q machine of yours ?


Happens on the supermicro and on an AMD threadripper both with an Nvidia RTX 3090 with the latest Nvidia studio driver. So it doesn't seem to be CPU related to me.
Grégoire AUSINA / Gisèle productions
Davinci 18.1.1 on Windows 10 (22H2) / Nvidia studio driver 526.98/ Dual Xeon E-2650v4 / supermicro X10DRG-Q / 128 Go RAM / GUI GTX 1070 / Cuda GTX 3090 - FSI CM250 - Tangent Elements - Accusys A12S3-p+
Offline
User avatar

GregAusina

  • Posts: 177
  • Joined: Thu Aug 23, 2012 7:30 pm
  • Location: Paris - France

Re: MXF encoding causes titles to block badly

PostFri Oct 14, 2022 7:42 am

Dwaine Maggart wrote:Sure. Along with a Resolve diagnostics log please. Generate that from the Resolve Help menu.


There you are : https://gisele.fromsmash.com/bm-feedback-mxf-issue
Grégoire AUSINA / Gisèle productions
Davinci 18.1.1 on Windows 10 (22H2) / Nvidia studio driver 526.98/ Dual Xeon E-2650v4 / supermicro X10DRG-Q / 128 Go RAM / GUI GTX 1070 / Cuda GTX 3090 - FSI CM250 - Tangent Elements - Accusys A12S3-p+
Offline
User avatar

Dwaine Maggart

Blackmagic Design

  • Posts: 9817
  • Joined: Wed Aug 22, 2012 2:53 pm

Re: MXF encoding causes titles to block badly

PostFri Oct 14, 2022 5:46 pm

Closest system I have to yours is a Lenovo workstation with dual Xeon's and an RTX 8000, and I don't see any issues with your dra with 18.0.4 Studio. I tried with and without Field rendering checked.

Edit: Never mind: I've finally focused in on the issue. It's a bit more subtle than the issue with Marks ESPN sample above. But I see it. I also see it on a Linux system with an RTX 6000 card.
Dwaine Maggart
Blackmagic Design DaVinci Support
Next

Return to DaVinci Resolve

Who is online

Users browsing this forum: Bing [Bot], Google [Bot], nnjrewzas112 and 53 guests