R3dAPI fails to initialize

Get answers to your questions about color grading, editing and finishing with DaVinci Resolve.
  • Author
  • Message
Offline

pierrotlefou65

  • Posts: 1
  • Joined: Wed Jan 29, 2020 4:44 pm
  • Real Name: Tony Moore

R3dAPI fails to initialize

PostThu Jan 30, 2020 11:06 am

I'm running Da Vinci 16 on a new build Linux machine. Everything is running fine except its inability to import RED (one mx) footage. The media page only shows Folder structure, .no r3d files are seen. RED clips in existing projects show as 'Media offline' and cannot be found when trying to relink. I can see from the logs that R3DAPI initialization fails.

Code: Select all
[0x7f885df94b40] | Main                 | INFO  | 2020-01-19 16:19:27,694 | Updating display GPU information...
[0x7f885df94b40] | Main                 | INFO  | 2020-01-19 16:19:27,694 | Detecting Main Display properties
[0x7f885df94b40] | Main                 | INFO  | 2020-01-19 16:19:27,754 | Process to detect main display has finished
[0x7f885df94b40] | Main                 | INFO  | 2020-01-19 16:19:27,821 | Fallback process to detect main display has finished
[0x7f885df94b40] | Main                 | INFO  | 2020-01-19 16:19:27,822 | GPU Name = 'Radeon RX 580 Series', Main display = 0
[0x7f885df94b40] | Main                 | INFO  | 2020-01-19 16:19:27,822 | Not GLmap capable. GPUs: 1 discrete, 0 integrated, 0 external. Auto mapping, OpenCL processing, main display not on external GPU.
[0x7f885df94b40] | Main                 | INFO  | 2020-01-19 16:19:27,822 | LsManager.3.NumGPUs is set in the config file. No auto-detecting GPUs
[0x7f885df94b40] | IO                   | INFO  | 2020-01-19 16:19:27,822 | RED InitializeSdk with library path at /opt/resolve/libs
[0x7f885df94b40] | IO                   | ERROR | 2020-01-19 16:19:27,858 | R3DAPI 7.2.0-41A39 (20191205 L64S) init failed with status = 3
[0x7f885df94b40] | Main                 | INFO  | 2020-01-19 16:19:27,858 | 0 RED rocket cards available
There are 1 GPUs in the system.
[0x7f885df94b40] | SyManager.DeckLink
  | INFO  | 2020-01-19 16:19:27,867 | DL::DisplayDevices: (1/1)
[0x7f885df94b40] | Main                 | INFO  | 2020-01-19 16:19:27,867 | Decklink model name: 'DeckLink Mini Monitor', version: '11.4.0'


Does anyone have any ideas on why this is/how to resolve?
Da Vinci 16.1.2/ Ubuntu 18.04
Thanks.
Offline

Lucius Snow

  • Posts: 250
  • Joined: Sun Nov 24, 2013 1:19 pm

Re: R3dAPI fails to initialize

PostWed Feb 19, 2020 12:02 pm

Hello,

I have the same bug on Centos 8.1 and Davinci 16.1.2 (but working in Windows 10).

R3D files can only be played if I remove GPU debayer / decompression support in the Preferences.

Can you please help us to fix this?

By the way, it doesn't occur on 16.1.1.

Thanks.

Return to DaVinci Resolve

Who is online

Users browsing this forum: Andrei Andreev, Andy Mees, Baidu [Spider], Charles Bennett, ChipKng, Chris Leutger, Dmitry Shijan, drtdsjlp, Google Feedfetcher, roger.magnusson and 86 guests