Motion tracker behaving strangely

Get answers to your questions about color grading, editing and finishing with DaVinci Resolve.
  • Author
  • Message
Offline

jsturick

  • Posts: 1
  • Joined: Sat Mar 27, 2021 3:47 pm
  • Real Name: Jeff Turick

Motion tracker behaving strangely

PostSat Mar 27, 2021 4:11 pm

Hi folks,

New here. I’ve searched around for this problem but can’t find any solutions. I’ve been experiencing 2 tracker problems since at least v16 (currently running 17). It’s so bad that most of the time I can’t even use it and have to keyframe everything manually.

1. The tracker stops tracking after a few frames even on super simple, contrasty subjects. A face, for example, that barely moves. The tracker will advance 10 frames or so and then stop. If I tell it to advance forward again, it will go a few more frames and even drift out of alignment.

2. On shots where the tracker manages to get through the whole clip but needs some adjustments, attempting to keyframe causes wild inconsistencies. For example, if I advance to the problem frame and start adding keyframes, moving forward 5 frames at a time or so to readjust the power window, in between my adjustments, the window drifts way off course, even further than the original track data. It’s like the tracker is negatively responding to my adjustments and overcompensating to get back to its original track. In some cases it even takes my window and suddenly expands its scale WAY outside the border of the image.

Anyone have any thoughts on this? Is it possible that there’s some corrupt data in my Resolve files somewhere that’s causing the tracker not to respond properly? I can try reinstalling the app, but I suspect the corrupt files are so buried in the system folders it's just going to relink to them on reinstall.

Running a MacPro Late 2013, 3.7GHz Quad-Core, Xeon E5; 64GB Ram. AMD FirePro D300, System 10.15.7

Many thanks for any insight.

Jeff
Offline

Johannes Hoffmann

  • Posts: 198
  • Joined: Mon Aug 26, 2013 5:22 am
  • Location: Germany

Re: Motion tracker behaving strangely

PostThu Apr 01, 2021 9:51 am

You are talking abaout the tracker in the color page, right?

I noticed the same issues yesterday night (have to finish the project, so no time now for further investigation). Never seen this in DR before:
1) even a simple talking head would only track a few frames
2) the circle window suddenly had a hard edge in the softening polygon line

Running DR 17.0, not yet updated to 17.1.
MacPro 5.1, 48GB, RX 580
MacOS Mojave
Offline

Jim Simon

  • Posts: 16210
  • Joined: Fri Dec 23, 2016 1:47 am
  • Warnings: 2

Re: Motion tracker behaving strangely

PostThu Apr 01, 2021 2:19 pm

Can you share one of the clips that won't track properly, Jeff? Les us test on our systems?
Offline

wfolta

  • Posts: 598
  • Joined: Fri May 15, 2020 1:12 pm
  • Real Name: Wayne Folta

Re: Motion tracker behaving strangely

PostThu Apr 01, 2021 2:34 pm

Could you also post a screenshot of your entire Tracker panel so we can check settings?

FWIW, I just tried a track of a face in 17.1.1 and it just did a frame or so each click. I switched from Clip to Frame and fiddled with other parameters and suddenly it worked perfectly. Switched back to Clip and it works fine. So it seems like there is a bug, and if you try a bunch of things you may be able to unstick it.

Once it was unstuck, it worked just fine on that and other clips, including clips with multiple Power Windows tracking multiple faces.
Resolve Studio 17 latest, Fusion Studio 17 latest, macOS Big Sur latest, MacBook Pro 2020 64GB RAM and Radeon Pro 5600M 8GB VRAM
Offline

Johannes Hoffmann

  • Posts: 198
  • Joined: Mon Aug 26, 2013 5:22 am
  • Location: Germany

Re: Motion tracker behaving strangely

PostMon Apr 05, 2021 6:34 pm

I updated to DR 17.1. The issue remains.

I did some tests and discovered, that when I check "Interactive Mode" (no further adjustments), the tracking went smoothly as before. When I uncheck it I am back to "track only a few frames and stop".

So (unless I miss something very obvious) I would say: this is a bug. But we have a simple work around :-)

Johannes
MacPro 5.1, 48GB, RX 580
MacOS Mojave
Offline

Rohit Singhal

Blackmagic Design

  • Posts: 574
  • Joined: Wed Aug 22, 2012 11:07 am

Re: Motion tracker behaving strangely

PostTue Apr 06, 2021 6:03 am

Johannes Hoffmann wrote:I updated to DR 17.1. The issue remains.

I did some tests and discovered, that when I check "Interactive Mode" (no further adjustments), the tracking went smoothly as before. When I uncheck it I am back to "track only a few frames and stop".

So (unless I miss something very obvious) I would say: this is a bug. But we have a simple work around :-)

Johannes


Hi Johannes, Can you please send us a sample clip which shows the issue for you? Also please send us the logs captured right after the tracking. Please upload to dropbox (or similar) and send us a link.
Rohit Singhal
DaVinci Resolve Software Development
Blackmagic Design
Offline

Shrinivas Ramani

Blackmagic Design

  • Posts: 1574
  • Joined: Wed Sep 20, 2017 10:19 am

Re: Motion tracker behaving strangely

PostTue Apr 06, 2021 3:29 pm

In addition to Rohit's request above, it would also be useful if someone were to share a phone video showing this tracking behavior on screen, so the others can check if it is the same issue.

Thanks
Shrinivas
Offline

Johannes Hoffmann

  • Posts: 198
  • Joined: Mon Aug 26, 2013 5:22 am
  • Location: Germany

Re: Motion tracker behaving strangely

PostTue Apr 06, 2021 7:58 pm

Thanks Rohit and Shrinivas for looking into this. I'll put all things together tomorrow and send you a link. Which support Email address should I use?

Johannes
MacPro 5.1, 48GB, RX 580
MacOS Mojave
Offline

Jean Coudsi

  • Posts: 4
  • Joined: Tue Nov 21, 2017 6:35 am

Re: Motion tracker behaving strangely

PostThu Apr 08, 2021 4:50 pm

Hello Rohit and co
Here some files with same issue.

We have tested on macOS Catalina and BigSur on last iMac (AMD RX 5700XT)
The cloud tracker on color page is not working with apple prores, DNxHR 444, DPX and h264 files
The cloud tracker on color page is working with RED Raw, Braw and png files ...

We have also tested on Win 10
The cloud tracker on color page is working with apple prores and h264 files

Source file : https://drive.infomaniak.com/app/share/ ... e6cd73071e
GUI video : https://drive.infomaniak.com/app/share/ ... bb328b945e

Serious issue !
Hope it's help
Regards
Jean and Olivier
Last edited by Jean Coudsi on Fri Apr 09, 2021 6:02 am, edited 1 time in total.
Offline

Jean Coudsi

  • Posts: 4
  • Joined: Tue Nov 21, 2017 6:35 am

Re: Motion tracker behaving strangely

PostThu Apr 08, 2021 5:18 pm

Hello again

the issue seems to come from "Percepective 3D" feature !
without it tracker analyse like always ... before
Regards
Jean and Olivier
Offline

Shrinivas Ramani

Blackmagic Design

  • Posts: 1574
  • Joined: Wed Sep 20, 2017 10:19 am

Re: Motion tracker behaving strangely

PostFri Apr 09, 2021 6:22 am

Thanks for the report Jean

We'll take a look.
Offline

Andreas Teichert

  • Posts: 24
  • Joined: Wed Jul 29, 2015 11:59 am

Re: Motion tracker behaving strangely

PostThu Apr 15, 2021 12:51 pm

same here. Really annoying - used to be one of resolves best features.

MacPro 2019
Resolve 17.1.1
Offline
User avatar

Olivier MATHIEU

  • Posts: 153
  • Joined: Thu Aug 04, 2016 1:55 pm
  • Location: Paris/Grenoble, FRANCE

Re: Motion tracker behaving strangely

PostFri Apr 16, 2021 6:17 am

May be this issue is also related on the other
The planar Tracker in FUSION page is also buggy.
You can't re-track a portion/the end of defective first track.

We had this issue on the 4 iMacs during a Fusion Training, But Non of windows 10 computer were affected !!
Media : Vantrack.mov from BlackMagicDesign Fusion book

Hope this helps
Resolve Studio 17 & Fusion Studio 17
MacOS 11.4
i9 10 cores 3,7 Ghz
RAM : 64 Go (3200Mhz)
GPU : RX 6800 XT 16 Go
GUI : 3840 x 2160
Offline
User avatar

Frank Glencairn

  • Posts: 1693
  • Joined: Wed Aug 22, 2012 7:07 am
  • Location: Germany

Re: Motion tracker behaving strangely

PostFri Apr 16, 2021 9:01 am

Run into the same issue (PC/Win10/Resolve 17/BRAW) - works just fine on other clips though.
http://frankglencairn.wordpress.com/

I told you so :-)
Offline

Misha Mazor

  • Posts: 14
  • Joined: Fri Aug 31, 2012 12:22 am

Re: Motion tracker behaving strangely

PostFri Apr 16, 2021 7:29 pm

Same issue, Cloud Track doesn't work with either Prores or R3D.
Clicking "Interactive Mode" does not help, just says "No live features to track"


OSX 10.15.7 (19H524)
Resolve 17.1.1
Offline
User avatar

waltervolpatto

  • Posts: 8652
  • Joined: Thu Feb 07, 2013 5:07 pm
  • Location: 1146 North Las Palmas Ave. Hollywood, California 90038 USA

Re: Motion tracker behaving strangely

PostMon Apr 19, 2021 9:57 pm

I have EXR timeline and I was used to track on my machine about 20 frames per second (linux) on that type of material.

Now the tracker is down to 3-4 frames per second on a simple shape, this si a new movie with really basic color.

This is a severe step back: shape tracking in color is one of the basic functions, now every time i need to track I dread the time loss....

EDIT: i re-opened a project that was started in v16 (and therefore i know the tracker speed on that) and I can confirm that I went form 20-24 frame per second to 3-4 frame per second tracking speed.

Frankly... that is unacceptable....
SuperServer 5039AD-I
C9X299-PGF - DDR4-2400 16x4 GB
i9-7920xCPU 12c 2.90GHz Water cooled
2x 1080ti DeckLink Studio 4K (11.5.1)
W10-1903 - BMR St. 16.2.2.012
nvidia: 441.66 studio
Offline
User avatar

waltervolpatto

  • Posts: 8652
  • Joined: Thu Feb 07, 2013 5:07 pm
  • Location: 1146 North Las Palmas Ave. Hollywood, California 90038 USA

Re: Motion tracker behaving strangely

PostTue Apr 20, 2021 9:48 pm

Yeah... i have 4x2080ti cards and I’m tracking 3 frames per second... it feels 2005 again......
SuperServer 5039AD-I
C9X299-PGF - DDR4-2400 16x4 GB
i9-7920xCPU 12c 2.90GHz Water cooled
2x 1080ti DeckLink Studio 4K (11.5.1)
W10-1903 - BMR St. 16.2.2.012
nvidia: 441.66 studio
Offline

Andreas Teichert

  • Posts: 24
  • Joined: Wed Jul 29, 2015 11:59 am

Re: Motion tracker behaving strangely

PostWed Apr 21, 2021 7:55 am

I just opened a ticket. I hope they react fast. This is a pain.
Offline
User avatar

waltervolpatto

  • Posts: 8652
  • Joined: Thu Feb 07, 2013 5:07 pm
  • Location: 1146 North Las Palmas Ave. Hollywood, California 90038 USA

Re: Motion tracker behaving strangely

PostWed Apr 21, 2021 6:52 pm

Andreas Teichert wrote:I just opened a ticket. I hope they react fast. This is a pain.


How do you open a ticket?
SuperServer 5039AD-I
C9X299-PGF - DDR4-2400 16x4 GB
i9-7920xCPU 12c 2.90GHz Water cooled
2x 1080ti DeckLink Studio 4K (11.5.1)
W10-1903 - BMR St. 16.2.2.012
nvidia: 441.66 studio
Offline

Andreas Teichert

  • Posts: 24
  • Joined: Wed Jul 29, 2015 11:59 am

Re: Motion tracker behaving strangely

PostThu Apr 22, 2021 9:47 am

I just wrote to the BlackmagicSupport and got a ticket number. :)
Offline

Misha Mazor

  • Posts: 14
  • Joined: Fri Aug 31, 2012 12:22 am

Re: Motion tracker behaving strangely

PostThu Apr 22, 2021 4:37 pm

Switched to another project with different media, but also all Prores and its tracking as expected. Jump back into the old project and its not tracking.
Offline

Lucas Paschoalick

  • Posts: 29
  • Joined: Tue Sep 15, 2020 10:59 pm
  • Real Name: Lucas Paschoalick Oliveir

Re: Motion tracker behaving strangely

PostFri Apr 23, 2021 2:28 pm

Hey guys and girls,

I'm experience this same issue, sudden I can not track at all... never had this problem before, but I normally work with BRAW footage. This time I'm working with some Prores 422 and some XAVCHD footage...

My footages is shots of some friend skateboarding, I tried the motion track inside color tab in 20+ different footage and it worked in zero of then.

I am a few months baby in video editing so I would appreciate if someone could analyze my footage and tell me if this is because of this weird bug, or if my shot is not good enough for tracking.

This is one of the shots:



1.1.jpg
1.1.jpg (332.68 KiB) Viewed 83 times

1.2.jpg
1.2.jpg (339.5 KiB) Viewed 83 times

Return to DaVinci Resolve

Who is online

Users browsing this forum: Ariel_Brener, cradulescu, Google [Bot], manuelj_baeza, MeneerK, Sean Nelson, SinadShan, Vaclav Chaloupka and 93 guests