Resolve 17.2.2 has bricked my speed editor

Get answers to your questions about color grading, editing and finishing with DaVinci Resolve.
  • Author
  • Message
Offline

colinelves

  • Posts: 19
  • Joined: Thu Feb 20, 2014 11:57 am

Resolve 17.2.2 has bricked my speed editor

PostFri Jul 23, 2021 9:49 pm

It would appear that updating to 17.2.2 has completely bricked my speed editor as it’s no longer detected by Resolve in either Mac or windows.

The Mac is unable to even connect to it via bluetooth. In windows it’s being detected as both a USB device and a bluetooth device (although neither are identified as Blackmagic) but it’s not getting detected by Resolve or the Resolve panel manager. I’ve tried downloading 17.2.2, 17.2, 17.0 and 16.7 - uninstalling both Resolve and the Resolve panel manager each time - nothing works.

I’ve tried holding down Cut. + Smooth cut. I’ve tried holding down Cut + Smooth Cut + Source + Timeline.

I’ve now completely run out of ideas and suggestions from the forum. I’ve emailed support a couple of times but haven’t had a response.

Does anyone else have any suggestions? Should I just RMA it now?

Thanks!

Colin.
Offline

59burst

  • Posts: 7
  • Joined: Mon Jun 28, 2021 2:03 am
  • Real Name: George Darby

Re: Resolve 17.2.2 has bricked my speed editor

PostSat Jul 24, 2021 12:32 am

Do you still have an earlier version of R17 to try?
Offline

colinelves

  • Posts: 19
  • Joined: Thu Feb 20, 2014 11:57 am

Re: Resolve 17.2.2 has bricked my speed editor

PostSat Jul 24, 2021 5:08 am

59burst wrote:Do you still have an earlier version of R17 to try?


All the previous versions are available on the Blackmagic website. I’ve tried previous versions on both Mac and Windows. Still no dice.

Return to DaVinci Resolve

Who is online

Users browsing this forum: Charles Bennett, FaunoStudio, Hendrik Proosa, Majestic-12 [Bot], mauirixxx, mgstet, michael2021, nucelar and 100 guests