DNxHR audio attributes in DR 14.01

Get answers to your questions about color grading, editing and finishing with DaVinci Resolve.
  • Author
  • Message
Offline

Mark Sterne

  • Posts: 292
  • Joined: Wed Dec 17, 2014 6:15 pm

DNxHR audio attributes in DR 14.01

PostFri Oct 27, 2017 2:27 am

Scenario: I'm grading client-provided ProRes 422 HQ HD clips with stereo audio on a Win 10 workstation and exporting DNxHR HQX in a MXF Op1a wrapper. Then I'm using a 2013 Mac Pro to transcode the DNxHR back to ProRes for those clients who require it. Recently I've run across an issue.

The mxf files, when previewed in the media page on the Mac, have stereo playback as heard and confirmed on the meters. Even when dragged into media pool, they play back properly on the media page. However, once a timeline is created from them, there is audio on channel one only.

Inspecting clip attributes shows that the stereo audio in the mxf file is being read as two channels of mono. By changing the attributes to a single stereo channel, the audio appears correctly when put into a new timeline.

I've read the section of the manual about assigning audio channels in the media pool and it discusses this. However, it seems like an unnecessarily complicated thing to have to do with an embedded stereo track.

Looking at the source .mov and my exported .mxf in MediaInfo, I notice that the ProRes under Audio, under Channel(s): 2 Channels has an entry for Channel positions: Front L R. The DNxHR file does not have the Channel positions entry.

So my question is, is this a problem with DNxHR itself, or with Resolve's implementation of it, or is this a bug in the way Resolve reads the file? Any enlightenment appreciated!

Both computers on Resolve Studio 14.0.1.008

Win machine specs:

Win 10 Pro 1703 build 15063.608
ASUS X99 Deluxe II
Xeon E5-2696 v4 2.2 GHz
64GB RAM
2 x 1080Ti

Mac:

MacOS Sierra 10.12.6
Mac Pro late 2013 12 core
32 GB RAM
2 x D700
Offline
User avatar

Jean Claude

  • Posts: 2973
  • Joined: Sun Jun 28, 2015 4:41 pm
  • Location: France

Re: DNxHR audio attributes in DR 14.01

PostFri Oct 27, 2017 5:32 pm

Mark Sterne wrote:.../...
2 Channels has an entry for Channel positions: Front L R. The DNxHR file does not have the Channel positions entry.

Win 10 Pro
ASUS X99 AII(me)

+1
"Saying it is good, but doing it is better! "
Win10-1809 | Resolve Studio V16.1 | Fusion Studio V16.1 | Decklink 4K Extreme 6G | RTX 2080Ti 431.86 NSD driver! |
Offline

Steve Alexander

  • Posts: 710
  • Joined: Mon Mar 23, 2015 2:15 am

Re: DNxHR audio attributes in DR 14.01

PostSat Oct 28, 2017 1:25 pm

Yep - I've seen this too. It does seem that Resolve has some issues with mxf containers - even XAVC-L not just DNx.
Resolve Studio 16.2.3 | Fusion Studio 16.2.3 | Win 10 Pro (1909) | i9-7940x, P4000 (441.66, 8GB VRAM), 64GB RAM, M.2 boot, SSD scratch, RAID10 data | (laptop) i7-6600, M1000M (2GB VRAM), 32GB RAM, SSD OS, M.2 scratch, T3 external
Offline
User avatar

Jean Claude

  • Posts: 2973
  • Joined: Sun Jun 28, 2015 4:41 pm
  • Location: France

Re: DNxHR audio attributes in DR 14.01

PostSun Oct 29, 2017 11:27 am

test with just delivery audio:
wav: not positions
MP4: yes
"Saying it is good, but doing it is better! "
Win10-1809 | Resolve Studio V16.1 | Fusion Studio V16.1 | Decklink 4K Extreme 6G | RTX 2080Ti 431.86 NSD driver! |

Return to DaVinci Resolve

Who is online

Users browsing this forum: Mel Matsuoka, oatbean, rikopr14 and 100 guests