FIXED Resolve 15 on Dell XPS - Would not Launch

Get answers to your questions about color grading, editing and finishing with DaVinci Resolve.
  • Author
  • Message
Offline

JohnTodd

  • Posts: 9
  • Joined: Thu Aug 16, 2018 1:20 pm
  • Real Name: John Andersen

FIXED Resolve 15 on Dell XPS - Would not Launch

PostTue Aug 21, 2018 8:19 pm

After much trial and error I finally got Resolve 15.0.0.86 release version to launch on my Dell XPS 15 (9560) again.
After launching the app It would only appear in the Task Manager with no UI.

What I did to Fix:
I uninstalled resolve completely including the Blackmagic Program Data folder.
Reinstalled the release version 15
Before launching Resolve change the Nvidia control panel settings listed below:

Note: Since Dell does not have an option in the BIOS for disabling the Intel GPU you have to use the Nvidia Control Panel. This will favor using the Nvidia card for everything which will most likely effect your battery life, if that matters to you.

Go to Nvidia Control Panel>
Manage 3D Settings>
Global Settings>
Preferred graphics processor > Set to "High Performance NVIDIA processor"

The above may be enough but I also changed the following

Program Specific Settings Changed:
Go to Nvidia Control Panel>
Manage 3D Settings>
Program Settings> DaVinci Resolve
Make sure "High Performance NVIDIA processor" is selected
Specific Settings I changed:
CUDA - GPUs = ALL (use these GPUs NVIDIA all)
Maximum pre-rendered frames = Use 3D application settings
Power management mode = Prefer Maximum Performance
Threaded Optimization = Auto


After making the changes listed above I was able to start Resolve, get past the splash screen and run the program without issue.
I have since restored my projects and relinked my footage and all seems ok.

I tried so many other things to get this to work, for me, this is what fixed it.

Hope this helps anyone else stuck with Resolve only appearing in the Task Manager

Screenshot_7.jpg
Screenshot_7.jpg (67.35 KiB) Viewed 10466 times


Screenshot_5.jpg
Screenshot_5.jpg (224.17 KiB) Viewed 10466 times
Dell XPS-15 9560 intel Core i7-7700HQ CPU @ 2.80Ghz - 16GB RAM - Nvidia GTX 1050 4GB Vram (Driver Version 398.82)- Intel(R) HD Graphics 630 (Driver Version 21.20.16.4574) - Windows 10 Pro - 1803 - OS Build 17134.228

Return to DaVinci Resolve

Who is online

Users browsing this forum: Bing [Bot], ethanxatris, Google Feedfetcher, Kenzo, mwalton, roger.magnusson and 131 guests