Page 1 of 1

Node Pan/Tilt position 0.5px produces edge black pixel line

PostPosted: Sun Sep 01, 2019 1:34 am
by Dmitry Shijan
Ok, I'll give another try to report a problem with edge artifacts produced by 0.5px Cross Hatching fix.

DNG files have so-called Cross Hatching pattern described a lot in this thread viewtopic.php?f=2&t=51936&start=400

This pattern is very easy to fix by adding node with Node Pan/Tilt position 0.5px. And another node with Pan/Tilt position -0.5px. https://ursa-mini-fpn-grid-pattern-nois ... 18/fix-46k This simple trick 100% removes Cross Hatching pattern from DNG files and have 100% no any affect to image sharpness. Pixel perfect image. It worked perfectly in Resolve 14 and earlier. But starting from Resolve 15 it start to produce artifact pixel lines at the left and right edges. In later versions Clip attribute SuperScale combined with different project scale settings also became affect pixel lines at the edges. Things became even more confused.

I send bug report to support (few times) and have long email conversation with support, i provide a project file illustrating this problem. But still nothing was changed.

As i know DNG files always have few additional hidden pixel rows at the edges outside visible area. There are no any black pixel lines at top and bottom, so Is it really so complicated to fix those black pixel lines artifacts at left and right edges in same way? If it worked perfectly in Resolve 14 and earlier, so why it broken in Resolve 16.1 b2?

Things became even more confused when multiple settings are combined:

Project Resize Filter Sharp + Clip Attributes SuperScale + Input sizing Pan/Tilt 0.5px = No Pixel line Edge
Project Resize Filter Sharp + Input sizing Pan/Tilt 0.5px = Pixel line Edge

Project Resize Filter Smooth or Bicubic + Clip Attributes SuperScale + Input sizing Pan/Tilt 0.5px = Pixel line Edge
Project Resize Filter Smooth or Bicubic + Input sizing Pan/Tilt 0.5px = No Pixel line Edge

P.S. You can see my earlier report here: viewtopic.php?f=21&t=75290

Image
Image
Image

Re: Node Pan/Tilt position 0.5px produces edge black pixel l

PostPosted: Mon Oct 21, 2019 10:12 pm
by Dmitry Shijan
Unfortunately problem is not fixed yet in Resolve 16.1 final :cry:

Re: Node Pan/Tilt position 0.5px produces edge black pixel l

PostPosted: Tue Mar 10, 2020 4:01 pm
by Dmitry Shijan
Problem is not fixed yet in Resolve 16.2 :cry: