Jump to: Board index » General » Fusion

Image (planar tracker) is randomly cut off in viewer

Learn about 3D compositing, animation, broadcast design and VFX workflows.
  • Author
  • Message
Offline

TCP786

  • Posts: 135
  • Joined: Thu Sep 16, 2021 7:05 am
  • Real Name: Cody Predum

Image (planar tracker) is randomly cut off in viewer

PostTue Sep 28, 2021 3:13 am

This feels very similar to the other issue I posted about, but I'm starting a new thread because some of the behavior is noticeably different. In this case, my comped image is sometimes showing up as cut off in the viewer, but it seems random as to when. In the case of my earlier issue, it seemed to be caused by changing slider values in the inspector. Here though, I am not changing anything at all, but just by cycling through different nodes being displayed in the viewers, I can get either the correct or incorrect image from the same node without making any changes whatsoever. For example, sometimes the image is incorrect as displayed in the planar tracker, but after looking at the output from a different node and then looking at the planar tracker again, it shows up correctly. Or it doesn't. I am also seeing the same behavior on the next two downstream merge nodes.

It's kind of like that old riddle: "There's a planar tracker and merge node. One of them always tells the truth, and the other always lies. However, sometimes the planar tracker tells you what its output is, but sometimes it tells you what it thinks the merge node's output will be. The merge node does the same regarding the signal it gets from the planar tracker, or what it thinks the signal was that the tracker received. What upstream signal do you send to them so that you can figure out which one is lying?"

Ok, jokes aside, here's a screen recording:


Since this felt similar to the other issue I was seeing, I tried the work-around that we found for that bug (adding a disabled dissolve node after the planar tracker). So far that seems to treat the symptoms, but I still figured it would be worth reporting.
Offline

UserNoah

  • Posts: 313
  • Joined: Fri Oct 04, 2019 3:32 pm
  • Location: Berlin
  • Real Name: Noah Hähnel

Re: Image (planar tracker) is randomly cut off in viewer

PostTue Sep 28, 2021 5:24 am

This happened to me, too when doing a quick comp where I thought the built in planar tracker would suffice. Eventually spend more time to debug this issue then it would've taken me to do it in mocha lol.

In my case I noticed that the image is only cut off if you set the planar tracker to corner pin and view any node after the planar tracker.
So I put down a saver directly after the planar tracker and rendered that while viewing only the planar tracker.
I could then load that back in and continue working.

I assume you could also use a planar transform and use the corner pin tool beforehand to place the graphics. I don't think the planar transform suffers from this issue. But this isn't something I tested and since the planar transform is backed in, too (it won't interactively change when you redo your track) you might as well save the images directly and save some render time later on.
Offline

TCP786

  • Posts: 135
  • Joined: Thu Sep 16, 2021 7:05 am
  • Real Name: Cody Predum

Re: Image (planar tracker) is randomly cut off in viewer

PostTue Sep 28, 2021 6:41 am

This seems related to the issue we investigated on this thread: viewtopic.php?f=22&t=147965

In that thread we found out that using a disabled dissolve node after the planar tracker also seems to be a work-around. Depending on your workflow it might be quicker than save/load. I can't exactly remember, but I feel like planar transform actually has the same problem. At least I don't think Tom would have randomly tried a disabled dissolve node before swapping the tracker for a transform...
Online
User avatar

TheBloke

  • Posts: 1448
  • Joined: Sat Nov 02, 2019 11:49 pm
  • Real Name: Tom Jobbins

Re: Image (planar tracker) is randomly cut off in viewer

PostTue Sep 28, 2021 9:39 am

If it's solved by adding a Dissolve node after the PTra, it's surely the same bug. Different pictures in viewers is likely caused by different cache states for different nodes. You can check this by right-clicking on the RAM display in the very bottom right of the Fusion UI and choosing to Clear Cache (or similar wording). If you're viewing the PTra when you do that it will probably clear the issue; if not, click to another frame. If you then view any node after the PTra (in the absence of an intervening Dissolve), then adjust the input image, you're likely to see parts get cropped out.

Here's my bug report thread from a day or two ago: viewtopic.php?f=22&t=147970

I'd suggest any other discussions of similar symptoms go in that thread.
Resolve Studio 17.4 and Fusion Studio 17.4 on macOS 11.5.2

Hackintosh:: X299, Intel i9-10980XE @ 4.6 Ghz, 128GB RAM, AMD 6900XT 16GB
Monitors: 1 x 3840x2160 & 3 x 1920x1200
Audio: Behringer UMC404HD
Blackmagic Speed Editor

Return to Fusion

Who is online

Users browsing this forum: Bing [Bot] and 14 guests