Jump to: Board index » General » Fusion

Visibility of particles placed behind a mesh object

Learn about 3D compositing, animation, broadcast design and VFX workflows.
  • Author
  • Message
Offline

buplPW

  • Posts: 2
  • Joined: Wed Jun 29, 2022 7:18 am
  • Real Name: Tomasz Makieła

Visibility of particles placed behind a mesh object

PostWed Jun 29, 2022 7:36 am

Hello,
Learning compositing with particles I found that particles placed behind a mesh object are visible to the camera, while they should be hidden. At least in my use case. See the linked screenshot.
Please advice how to change this behavior.
Many thanks in advance.

EDIT: I can't post urls yet, so can't provide you with a the screenshot. Hopefully the description is clear enough...

EDIT 2: I forgot to mention, I need to keep the 3D object not visible to the camera, however it should be used by the particle emitter or the camera as a sort of a ‘mask’ to hide all particles that are placed behind it.
Offline

UserNoah

  • Posts: 385
  • Joined: Fri Oct 04, 2019 3:32 pm
  • Location: Germany
  • Real Name: Noah Hähnel

Re: Visibility of particles placed behind a mesh object

PostWed Jun 29, 2022 8:56 pm

You want to set the Mode of the 3D object to transparent matte. Then it cuts out everything that is behind it but it’s not visible to the camera.
You can find that setting on the first tab of the 3D object or you can use an Override3D. You need to set it for the appropriate render engine as well. So if you don’t know which you’re using just set Software and OpenGL blending mode to Transparent Matte.
Offline

buplPW

  • Posts: 2
  • Joined: Wed Jun 29, 2022 7:18 am
  • Real Name: Tomasz Makieła

Re: Visibility of particles placed behind a mesh object

PostThu Jun 30, 2022 6:30 am

Thank you, that helped. I also had to check 'Is matte' option and tweak a little the node graph, but it works finally.

Return to Fusion

Who is online

Users browsing this forum: No registered users and 13 guests